Celebrate National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

RDP - The Logon Attemp Failed

Posted on 2012-03-18
9
Medium Priority
?
799 Views
Last Modified: 2012-03-18
Hi guys

My setup is as this:
Ubuntu host machine running VMWare with Windows 7 Professional VM. I have a static IP address. VMWare is using BRIDGED connection to this VM.
My routers internal IP is 192.168.0.1- Port 3389 forwarded to 192.168.0.9
Ubuntu host (DHCP enabled) 192.168.0.16
Windows 7 Pro has (DHCP enabled) 192.168.0.9 - computer name is "VPS-2" and user name is "virtual"
I have enabled "Allow connection from computers running any version of Remote Desktop"
So, before installing SP1 on Win7 Pro I'm pretty sure my RDP was working, but now all I get from another machine connecting via the RDP to Win7 Pro is:
"The Logon Atempt Failed". It even gives me this error when I use incorrect usernames and passwords. I have tried connection using these credentials using external IP:
1) "vps-2\virtual" and password
2) "virtual" and password
3) incorrect machine name and password
Result is always the same error message - The Logon Attempt Failed
I have also tried connection using local IP address and same usernames/passwords stated above with the same result.
So what's wrong?
Thanks.
0
Comment
Question by:kirret
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 4
9 Comments
 
LVL 7

Expert Comment

by:lucifer82
ID: 37734953
Have you checked the firewall setting on the Virtual PC? Make sure the RDP (3389) is allowed.

Also for testing purpose you might want to disable firewall all together and see if that is causing the issue.
0
 

Author Comment

by:kirret
ID: 37734991
If firewall was blocking it then I guess I wouldn't get as far as asking for a password?
Anyway, there is only firewall there is is the built-in Windows Firewall which I have disabled and still the same message keeps coming up.
Thanks
0
 
LVL 77

Expert Comment

by:Rob Williams
ID: 37735117
See if the VM is accesible by telneting to the VM using
telnet  123.123.123.123  3389
If accesible you will get a blank screen and a flashing cursor.

If not accesible, see if the VM is "listening"
netstat -an |find "3389"
Should return:
TCP    0.0.0.0:3389           0.0.0.0:0              LISTENING

If not listening, make sure the RD services role is running on the VM in services.msc
0
Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

 

Author Comment

by:kirret
ID: 37735433
@RobWill

Did telnet 192.168.0.9 3389 and got a blank black screen so I guess it is telnetting. Also check VM services on VM and they are all in STARTED state.
I think if it's gonna take too much effort to find out the problem then I;m just gonna reinstall that VM as there's no 3rd party software on it right now, just MS updates.
Let me know if you have any other thoughts...
0
 
LVL 77

Expert Comment

by:Rob Williams
ID: 37735441
If telnet works it definately sounds like an account issue.  Is the user account "virtual" a mamber of the remote desktop users group?
0
 

Author Comment

by:kirret
ID: 37735703
It's a standalone installation, no domain. During the installation I named this account "IM" but after installing all the updates I started to get that problem so have changed the account name since then with no positive effect.
0
 
LVL 77

Accepted Solution

by:
Rob Williams earned 2000 total points
ID: 37735788
I would try creating a new user account, add it to the remote desktop user group, and test it.
0
 

Author Closing Comment

by:kirret
ID: 37735812
LOL, created a new account with a password and problem solved with that account. So I'm just going to delete the original account and use this new one for RDP. By the way, didn't have to add this new user to any groups, just made it an admin account.
Thanks!
0
 
LVL 77

Expert Comment

by:Rob Williams
ID: 37735818
Good to hear.
Administrators are added to the remote desktop users group by default.
0

Featured Post

Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Enterprise networks where VoIP phones have been deployed frequently use port configurations that allow both a computer and an IP phone to be plugged into the same switch port but use different VLANs. On Cisco equipment I'm referring to the "native V…
Citrix XenApp, Internet Explorer 11 set to Enterprise Mode and using central hosted sites.xml file.
Windows 8 comes with a dramatically different user interface known as Metro. Notably missing from the new interface is a Start button and Start Menu. Many users do not like it, much preferring the interface of earlier versions — Windows 7, Windows X…
With the advent of Windows 10, Microsoft is pushing a Get Windows 10 icon into the notification area (system tray) of qualifying computers. There are many reasons for wanting to remove this icon. This two-part Experts Exchange video Micro Tutorial s…

730 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question