Link to home
Create AccountLog in
Avatar of Eric Bourland
Eric BourlandFlag for United States of America

asked on

Trying to install FastCGI on Web Platform 3.0; error: "The product that you are trying to install is not supported on your operating system."

Platform: Windows 2008 R2, IIS 7.5

Hi. I am trying to install FastCGI on a Windows 2008 R2, IIS 7.5 server, using Web Platform 3.0.

In MSIE, I start at this web page: http://www.iis.net/download/fastcgi

And I click to download the FastCGI Update for IIS 7. Web Platform 3.0 launches and then I get this error:

 “The product that you are trying to install is not supported on your operating system. Click here for more information.”

When I click for more information, I am directed to this page: http://learn.iis.net/page.aspx/604/troubleshooting-problems-with-microsoft-web-platform-installer-30/

 ... which does not seem to have a specific solution for me.

Does anybody know what I need to do to resolve this?

My goal is to run PHP, FastCGI, and PHP Manager on this Windows server. Thanks very much for your help.

Eric
ASKER CERTIFIED SOLUTION
Avatar of Dave Baldwin
Dave Baldwin
Flag of United States of America image

Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account
Avatar of Eric Bourland

ASKER

Dear Dave,

Interesting! I was able to install and run FastCGI on my previous server, which had IIS 7. This server has IIS 7.5.

I have confirmed, in Server Manager, that the CGI service is active.

I was reading up on IIS 7.5 here: http://technet.microsoft.com/en-us/library/cc753473.aspx

Do I need to worry at all about FastCGI?

Thank you very much for your help.

Eric
That page I linked tells you more than I know.  It is the recommended method.
Got it. I'll go ahead and close this question. I installed PHP, and am getting  a handler error, but I am researching the way to fix that and I don't think it has anything to do with FastCGI. Thanks very much for your help.

Eric
Thank you, DaveBaldwin!
You're welcome.