Solved

Receive Connector on Exchange 2010 Std.

Posted on 2012-03-18
7
581 Views
Last Modified: 2012-03-21
Hi Folks,

I have an Exchange Server 2010 std. edition. It was all working fine for almost 10 months and suddenly what happened is, any mails coming from outside was rejected

The sender receives the following message:
Delivery has failed to these recipients or groups:
'User Name (user@xyz.com)'
Your message wasn't delivered due to a permission or security issue. It may have been rejected by a moderator, the address may only accept e-mail from certain senders, or another restriction may be preventing delivery.
The following organization rejected your message: receivingservername@xyz.com.
Diagnostic information for administrators:
Generating server: servername.abc.com
user@xyz.com
receivingservername.domain.com #550 5.7.1 Recipient not authorized, your IP has been found on a block list ##
======================================================================================

No changes been made to the receive connector except for the permission groups which has all the options checked except Partners. This change was done after the installation of the exchange on the default receive connectors.

Since I was not receiving emails, I did checked my firewall, spam suite and nothing seems to have problem, as I continue to have the problem even after disabling the spam suite.
Finally, I created a new custom receive connector, set the IP address as local IP with port 25. Checked only the Externally Secured (IPSec) option under the authentication and permission group as default, by this I started getting emails, but the sad part is, I get to lots of spammers in the mail queue and looks really ugly. When the newly created connector is disabled, removing the spam domains in the queue, it looks fine but unable to receive mails and again when enabled, all goes for six...

I have another domain in my office with exchange 2010, I copied the same settings for the receive connectors (on the default ones created during exchange installation), but doesn't work. Works only when I enable the new connector.

Your resolution is highly appreciated.

Thanks,
Anand
0
Comment
Question by:jaiho
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 2
  • 2
7 Comments
 
LVL 17

Accepted Solution

by:
Suraj earned 250 total points
ID: 37736537
Instead of using a relay connector. try adding the IP in the IP allow list. once done restart transport and then test.
0
 
LVL 20

Expert Comment

by:compdigit44
ID: 37738376
Have you installed any Windows OS or Exchange updates recently?
0
 

Author Comment

by:jaiho
ID: 37745855
@x-sam: Tried that, no mails coming + no bounce error mail coming for the sender

@compdigit44: It happened on 8th March 2012, during that time, there was no windows / Exchange updates except for Windows Defender.
0
Free NetCrunch network monitor licenses!

Only on Experts-Exchange: Sign-up for a free-trial and we'll send you your permanent license!

Here is what you get: 30 Nodes | Unlimited Sensors | No Time Restrictions | Absolutely FREE!

Act now. This offer ends July 14, 2017.

 
LVL 20

Assisted Solution

by:compdigit44
compdigit44 earned 250 total points
ID: 37747118
I like to work with the mind set what changed from the time something work until it stopped working. You stated nothing has changed hardware wise and not Windows OS or Exchange updates were installed. Did you try to removed the latest Windows Deferener updates or disable windows defender as a test?
0
 
LVL 17

Expert Comment

by:Suraj
ID: 37747954
Please upload the agent.log. for me.
Also please tell me what have you configured on ip block list provider agent?

I suspect some thing miss-configured on BlockListProvider Agent.
Meanwhile, as for a quick troubleshooting step try  to disable IP block list providers , restart transport and then test.
0
 
LVL 20

Expert Comment

by:compdigit44
ID: 37748299
Have you checked the following:

-Open the Exchange Management Console.
  -Expand Server Configuration and select Hub Transport.
  -Right click on Default <Server Name> and select Properties.
-Click on Permission Groups.
 -Ensure Anonymous Users is checked and click Apply and then OK.
- Restart the Microsoft Exchange Transport service.
0
 

Author Closing Comment

by:jaiho
ID: 37750938
@x-sam: Added the neccessary IP address in the IP allow list for spam

@compdigit44: Disabled the Win Defender

- Worked like charm... Thanks so much techies. Happy to learn a lot on this... :)
0

Featured Post

Optimizing Cloud Backup for Low Bandwidth

With cloud storage prices going down a growing number of SMBs start to use it for backup storage. Unfortunately, business data volume rarely fits the average Internet speed. This article provides an overview of main Internet speed challenges and reveals backup best practices.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

A list of top three free exchange EDB viewers that helps the user to extract a mailbox from an unmounted .edb file and get a clear preview of all emails & other items with just a single click on mailboxes.
Unified and professional email signatures help maintain a consistent company brand image to the outside world. This article shows how to create an email signature in Exchange Server 2010 using a transport rule and how to overcome native limitations …
Windows 8 comes with a dramatically different user interface known as Metro. Notably missing from the new interface is a Start button and Start Menu. Many users do not like it, much preferring the interface of earlier versions — Windows 7, Windows X…
With the advent of Windows 10, Microsoft is pushing a Get Windows 10 icon into the notification area (system tray) of qualifying computers. There are many reasons for wanting to remove this icon. This two-part Experts Exchange video Micro Tutorial s…

717 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question