Network file open as read only.

It's funny to ask but I am having trouble to set write access to file server 2008. User have a read access but not the write access. Not sure what causing wrong.

1. Shared this folder
2. Set the user as a "contributor" in file sharing
3. Set in Security as Modify, read and write access
4. Checked Effective Permission & it seems ok but users still don't have access to write. I can't think of at the moment is there anything else causing wrong? How to diagnose this issue?  

Thanks to All in advance.
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Zerox HoopLinux AdminCommented:
Add the user in administrator group

go to manage > local user and groups>go to groups>Administrators

open and add user >save
Then try again.
SilenseAuthor Commented:
I don't want to add those users to administrator group. I only want them to give access to specific forlder for read, write and delete files. Thanks.
Zerox HoopLinux AdminCommented:
The 7 Worst Nightmares of a Sysadmin

Fear not! To defend your business’ IT systems we’re going to shine a light on the seven most sinister terrors that haunt sysadmins. That way you can be sure there’s nothing in your stack waiting to go bump in the night.


Have you tried to reset the permission?

Replace permission entries on all child

SilenseAuthor Commented:
Yaaa. I did. But not sure what happen to this VM. It's not allowing sahre.
SilenseAuthor Commented:
Even I create a temp.txt file to test. But can't update or write. Even I set all permission & security as I mention before. Thanks.
seems you lack of 'modify' permission
have you set the Share permissions accordingly as well as the NTFS permissions?
SilenseAuthor Commented:
I been in IT industry for 5/6 years and I am pretty sure my share & permission settings is ok. Just wondering is there anything in my VM (win 2008 Server) which causing issue? Please help me if you have same experience in VM. It's nothing to do with my share & permission settings on folder. I think it's something to do with VM which stopping to access write share. Thanks.
SilenseAuthor Commented:
It's really strange I setup full read & write access to user. But when user try to update files it's getting error message: "Cannot create the *.txt file. Make sure the file & path are correct. Another waring show that " you do not have permission to save in this directory.  Thanks.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
SilenseAuthor Commented:
Issue not been solved.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Server Apps

From novice to tech pro — start learning today.