print spooler

Hi there,
Iam facing a problem when trying to install printers on my server 2003!
Whenever i go to services->print spool->click it to start...it starts and after few seconds it stops with the following error message:The Print Spooler service is starting.System error 230 has occurred. The pipe state is invalid. It has no dependacies associated with it!
Ercélio Pedro MabotaAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Ercélio Pedro MabotaAuthor Commented:
i mean: the print spooler has no dependacies associated when i go to dependacies tab!
0
moon_blue69Commented:
on the services open print spooler and under recovories tab acan you choose restart for first second and subsequent failures and please check if the problem persists. Uninstall any print drivers installed restart the system and re-install with the updated driver from the manufacturers website.
0
Ercélio Pedro MabotaAuthor Commented:
Did as suggested...not working
0
C++ 11 Fundamentals

This course will introduce you to C++ 11 and teach you about syntax fundamentals.

moon_blue69Commented:
I assume then its a virus issue

 run malwarebytes

malwarebytes.org see if it fixes it



Use the kaspersky  tdss killer from http://support.kaspersky.com/viruses/solutions?qid=208280684

let it heal what it finds , but ignore  SPTD.SYS and then reboot
0
upalakshithaCommented:
run this in cmd  
       sc config spooler depend= RPCSS

then try to start the service
0
Ercélio Pedro MabotaAuthor Commented:
my antivirus is up to date
0
moon_blue69Commented:
Hi doesnt mean that you are fully protected. No ant-virus is fool proof even if you have it updated every second. Ps try this you might wonder about the infections you may have
0
Ercélio Pedro MabotaAuthor Commented:
Server scanned...no threats found!
0
moon_blue69Commented:
Did you try kaspersky?
0
Ercélio Pedro MabotaAuthor Commented:
yes...
0
butler1850Commented:
Sounds like you are using a driver for a printer that is not meant to have a print queue.    Host based printers (for example the HP 2600) are meant to have jobs sent directly from the PC spooling the process.  

See here for more details:  http://h20000.www2.hp.com/bizsupport/TechSupport/Document.jsp?lang=en&cc=us&objectID=c00374690
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Legacy OS

From novice to tech pro — start learning today.