how to configure dns slave

Dear Experts:

We have ubuntu linux ddns server for network 192.168.1.0/24 now that would like to configure dns slave for the network 192.168.11.0/24.
MPLS VPN HUB and Spoke
ubuntu linux ddns server is hosted at HUB location which is configured for 192.168.1.0/24 network now the ISP have implemented spoke network as 192.168.11.0/24 and the same has been configured to MPLS router 1900 series intrun this is terminated to fortigate 300 firewall/router

1. I am looking for how to configure the slave dns at spoke for the network 192.168.11.0/24
2. How to configure the exsiting ubuntu ddns server which is presently configured for 192.168.1.0/24 for the slave dns of the spoke network 11.0/24

Please help.
D_wathiAsked:
Who is Participating?
 
Gabriel OrozcoSolution ArchitectCommented:
Hi D_wathi

Slave zones are for domain names, not for networks.

in bind, a slave zone is defined as follows:

// named.conf fragment
zone "example.com" in {
    type slave;
    file "slave.example.com";
    masters {192.168.2.7; 10.2.3.15 port 1127; 2001:db8:0:1::15;};
};

As you see, the slave define the ip address of the master DNS server, and in the Master you need to add
  slaves { ip.of.your.slave.dns.server};

That's it.
0
 
Gabriel OrozcoSolution ArchitectCommented:
One more thing, you can see examples here:
http://www.zytrax.com/books/dns/ch6/
0
 
TobiasHolmCommented:
Redimido is right.

Regards, Tobias
0
How do you know if your security is working?

Protecting your business doesn’t have to mean sifting through endless alerts and notifications. With WatchGuard Total Security Suite, you can feel confident that your business is secure, meaning you can get back to the things that have been sitting on your to-do list.

 
D_wathiAuthor Commented:
Sir, Thank you very much , little more help please as per the below request

In the Hub location behind the firewall/router Ubuntu DDNS is serving as the master name sever for the network of   192.168.1.0/24 subnet, named configuration is attached for your reference.

1. HUB 192.168.1.0/24 and 192.168.1.244 as ddns server
With reference to the attached configuration please help me what additional statements or changes to be made for achieving the DNS slave as per the below different subnet at the spoke

2. spoke 192.168.11.0/24 subnet  and dns slave 192.168.11.100
Please tell me what all the statements required here at spoke I mean how the named.conf.local should be configured, i am little confused should point to the master server , please give me the statements .
namedconfig.txt
0
 
D_wathiAuthor Commented:
on the  named.conf  the statement is  masters {192.168.2.7; 10.2.3.15 port 1127; 2001:db8:0:1::15;};

I did not understand the   2001:db8:0:1::15; which is in masters above statement. Please help me.
0
 
TobiasHolmCommented:
masters {192.168.2.7; 10.2.3.15 port 1127; 2001:db8:0:1::15;};

This is a IPv6 address. You don't have to use a IPv6 address if you don't want to.

masters {192.168.2.7; 10.2.3.15 port 1127; 2001:db8:0:1::15;};

This is an example of specifying a port if a DNS server uses a non-standard port.

You could use this format (replace the IP with your master DNS):

masters {192.168.2.7;};

Regards, Tobias
0
 
D_wathiAuthor Commented:
Sir, Thanks , can you please tell me can will it be possible configure salve for different network  i,e 192.168.10. when the master is in the  192.168.1. network. Please help
0
 
TobiasHolmCommented:
Yes, it's no problem to have the slave in a different network, as long as you can reach it from your master server. You could use ping to verify that you can reach your slave DNS from your master DNS (if you have allowed ping in your network).

Regards, Tobias
0
 
D_wathiAuthor Commented:
Sir thank you very much, finally one last request, In the master server is it required to create a slave zones ( forward and reverse zone files), please suggest.
0
 
TobiasHolmCommented:
You don't have to create a zone file for the slave on the master, but you have to allow transfers. Read more here: https://help.ubuntu.com/community/BIND9ServerHowto

"First, on the primary master server, the zone transfer needs to be allowed. Add the allow-transfer option to the sample Forward and Reverse zone definition in /etc/bind/named.conf.local:"

Regards, Tobias
0
 
D_wathiAuthor Commented:
dns master and slave
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.