Want to win a PS4? Go Premium and enter to win our High-Tech Treats giveaway. Enter to Win

x
?
Solved

Can't join domain with netbios, must use fully qualified domain name?

Posted on 2012-03-19
5
Medium Priority
?
2,767 Views
Last Modified: 2012-06-27
Ever since we removed our WINS server, we are no longer able to join computers to the domain without typing the fully qualified domain name.  In the past we could just use the netbios name.  Is this normal or this away to resolve it?

We are running both 2003 and 2008 domain controllers, but in 2003 mode.
0
Comment
Question by:ohmErnie
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
5 Comments
 
LVL 37

Expert Comment

by:Neil Russell
ID: 37738120
Check your DNS settings. DNS Server must point to your AD controller ONLY and not to anywhere else. That is, the AD Controller running windows DNS
0
 
LVL 59

Accepted Solution

by:
Darius Ghassem earned 668 total points
ID: 37738126
You should be using domain.com when joining the domain not domain this is normal
0
 
LVL 3

Assisted Solution

by:IT-Shrek
IT-Shrek earned 668 total points
ID: 37738128
This behavior is by design until you enable netbios over TCP/IP and set your primary network suffix via GPO.

Shrek
0
 
LVL 11

Expert Comment

by:Sanjay Santoki
ID: 37738199
Hello,

As per my knowledge when you can access domain controller with FQDN and NetBIOS name. NetBIOS name should be the one you have configured during DCPROMO.

You can get it by running Get-ADDomain –Identity domainname command on windows 2008. I am not sure how to check it out on windows 2003.

Regards,
Sanjay Santoki
0
 
LVL 17

Assisted Solution

by:Premkumar Yogeswaran
Premkumar Yogeswaran earned 664 total points
ID: 37740536
Hi,

It is good to use FQDN to add the Workstation or server to the domain.

If you want to join to domain with netbios name?

Enable below setting in workstation or server

Goto TCP/IP properties -> advanced -> WINS tab -> Enable netbios over Tcp/ip

This will help you..

Regards,
Prem
0

Featured Post

Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Learn about cloud computing and its benefits for small business owners.
While rebooting windows server 2003 server , it's showing "active directory rebuilding indices please wait" at startup. It took a little while for this process to complete and once we logged on not all the services were started so another reboot is …
This tutorial will walk an individual through locating and launching the BEUtility application to properly change the service account username and\or password in situation where it may be necessary or where the password has been inadvertently change…
This tutorial will walk an individual through the process of transferring the five major, necessary Active Directory Roles, commonly referred to as the FSMO roles to another domain controller. Log onto the new domain controller with a user account t…

610 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question