Remote Desktop won't save passwords even though it's checked to save password

Just moved users over to Windows Server 2008R2 from Windows Server 2003. When I went to run remote desktop on the user's computer (they are running Windows XP SP3), I get the following error when trying to log into the server via Remote Desktop "The remote computer requires Network Level Authentication, which your computer does not support"     So I found a fix to that:  http://support.microsoft.com/kb/951608
I did choose the icon "Microsoft Fix It" and also tried fixing it manually on another PC that had same error message. It basically has me go into the registry and add some entries. So now I don't get the error anymore BUT it won't save my password for Remote Desktop and Windows. I click save password in the Remote Desktop program but it's like it doesn't save it, I need to enter it each time. I have researched and can't figure out the solution to this issue. Anyone have a solution???
MatterofaxAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Raymond PengSystems EngineerCommented:
Under the remote tab for Server 2008 (system properties), did you select the option to 'Allow connections from computers running any version of Remote Desktop'?  That's what's causing your original issue.

Try switching to that and see if issues persist with password saving.  It's probably better to revert back to your original settings without the registry tweaks.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
thomasdavisCommented:
Click options bottom left side, you will see this screen enter computer, username, and check allow me to save credentials. Also you can save connection settings to your desktop for a shortcut to that machine.
RDP
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Legacy OS

From novice to tech pro — start learning today.