Running drupal on MAMP gives max_allowed_packet error

Am running drupal on MAMP (on a Macbook Pro using OSX 10.7.3).
Keep getting errors:

Cannot set variable `max_allowed_packet` to `536870912` in your database configuration!
Probably you do not have proper privileges on the database server.

I have created a my.cnf file in the MAMP/Library directory (a copy of my-medium.cnf.  The only change I have made in this is to comment out the line

log-bin=mysql-bin

to avoid multiple error messages like the above.   The max_allowed packet as defined in the file is the default value and not 536870912.

I have disabled the update status module as I understand this can cause this problem.

Can anyone help me to solve it?
bogormanAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

torakeshbCommented:
Please see whats the current max_allowed_packet in mysql

(1) Loging to mysql as root user
(2) Type the command " SHOW VARIABLES; "


"Probably you do not have proper privileges on the database server." --> direct to privilege issues.

Check whether you mysql DB location have proper privileges for the mysql service user.
0
bogormanAuthor Commented:
Am using MAMP on my Macbook Pro.  If I select the Variables tab it shows 1,048,576 as the value of max_allowed_packet.  Strange as the error shows 536870912.   I have searched in Finder for this value (either 536870912 or 512 (MByte equivalent) and I cannot find any file with these as settings for max_allowed_packet, so it looks as though it is not being set by any of the files on my disk.  In my.cnf it is set as 1M (under [mysqld] and 16M under [mysqldump] - the values in my-medium.cnf.

If I click the Privileges tab, a few minutes ago it showed two users, now it shows an additional two (user names in red):

User                 Host            Password           Global Privileges                            Grant

Any                    %               --                       USAGE                                            No
Any                  localhost      No                     USAGE                                            No
bogorman        localhost      No                     SELECT, INSERT, UPDATE, DELETE
                                                                      CREATE, DROP, INDEX, ALTER         No
root                 localhost      Yes                     ALL PRIVILEGES                              Yes
0
bogormanAuthor Commented:
Am still having this problem. Thought I'd solved it by reloading the privileges - it went away for a while but it has now returned.    Any further thoughts on this?
I am a bit confused about several users.   Do I need all these?   The only one with Grant=Yes is root.   Is this significant?
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
bogormanAuthor Commented:
No one solved the problem.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
MySQL Server

From novice to tech pro — start learning today.