Solved

Cisco 3750 Metro 4 VLANs and 2 VLANs that need to go out a different port

Posted on 2012-03-19
5
361 Views
Last Modified: 2012-09-06
Hi EE people,

I'm not too familiar with the Cisco 3750 Metro and I'm having difficulty trying to get 6 VLANs that I need to split on a Cisco Metro 3750 iOS v.12.2

VLAN 69, 70 goes out of VLAN 4 port#gi.1/0/2

VLAN 73, 74 needs to go out VLAN 301 port#: fa1/0/12


Currently the configuration look as follows:

!
interface FastEthernet1/0/1
 description Uplink to Site-E OpteMAN
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 73
 switchport mode trunk
 bandwidth 10000
!
interface FastEthernet1/0/2
 description Uplink to Site-D OpteMAN
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 70
 switchport mode trunk
!
interface FastEthernet1/0/3
 description Uplink to Site-WA OpteMAN
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 69
 switchport mode trunk
!
interface FastEthernet1/0/4
 description Uplink to Site-WI OpteMAN
 switchport access vlan 74
 switchport mode access
 bandwidth 10000
!
interface FastEthernet1/0/12
 description Out-for-7374
 switchport access vlan 301
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 301
 switchport mode trunk
!
interface GigabitEthernet1/0/2
 description Uplink to CO
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface Vlan69
 description OpteMAN uplink to Site-WA #15L2XN000111-001
 no ip address
!
interface Vlan70
 description OpteMAN uplink to Site-D #15L2XN000114-001
 no ip address
!
interface Vlan73
 description OpteMAN uplink to Site-E #15L2XN000290-001
 ip address 206.15.225.33 255.255.255.252
!
interface Vlan74
 description OpteMAN uplink to Site-WI #15L2XN000129-001
 ip address 206.15.225.17 255.255.255.252
!
interface Vlan301
 description "Out-for-7374"
 ip address 172.30.1.3 255.255.255.0
!
interface Vlan999
description "Out-to-CO"
 ip address 172.27.4.3 255.255.255.0
!
ip default-gateway 172.27.4.1
ip classless
ip route 0.0.0.0 0.0.0.0 172.27.4.1
ip route 172.20.0.0 255.255.0.0 206.15.225.18
ip route 172.21.0.0 255.255.0.0 206.15.225.34
ip route 172.29.8.0 255.255.255.0 172.27.4.4
ip route 172.30.1.0 255.255.255.0 172.30.1.1
ip route 206.15.245.0 255.255.255.0 206.15.225.18

If anyone can help me, I'd appreciate it.

tecniq
0
Comment
Question by:tecniq77
  • 2
  • 2
5 Comments
 
LVL 10

Expert Comment

by:mat1458
ID: 37740788
I do not really understand what you want to do. Do you want to tunnel your VLAN into other VLAN? Or do you simply want to transport VLAN 69, 70 and 4 out of Gi1/0/2 and 73, 74 and 301 out of fa1/0/12
What is on the other side of Gi1/0/2 and Fa1/0/12? Do these ports connect to your own switches or are these provider switches? If you have any configuration of the interfaces on the other side of these ports this might help to understand what's necessary on your switch.

One thing that can be said is that you don't need the default-gateway statement.
0
 
LVL 17

Expert Comment

by:Garry-G
ID: 37740970
For one, "switchport access" and "switchport mode trunk" don't really go together ...

If all you want is to have multiple VLANs on a trunk, though limit them to certain VLANs and not everything, just extend your statement to:

int g1/0/2
switchport trunk allowed vlan 4,69,70

int fa1/0/12
switchport trunk allowed vlan 73,74,301

If one of the vlans need to be untagged, you can set that with "native vlan" option ...

OTOH, if you want QinQ, the config will need to look differently ...
0
 

Author Comment

by:tecniq77
ID: 38219740
Sorry for the late response... So basically, I wanted the traffic from VLAN 69 and 70 to go out the VLAN 4 port and VLAN 73,74 to go out of the VLAN 301 port.

Or if this makes better sense,

dump the default gateway....

route all the traffic from VLAN69,70 to VLAN4

route all the traffic from VLAN73,74 to VLAN301

The idea of Policy-Based Routing to shape the incoming traffic to go out specific interfaces.
0
 
LVL 17

Expert Comment

by:Garry-G
ID: 38220211
Are you talking about Layer 2 or Layer 3 forwarding? If you're going for L3, you will need to get some IPs up on all the VLANs ...
For L2, you'd have to configure bridge groups on the two groups of three VLANs each ...
0
 
LVL 10

Accepted Solution

by:
mat1458 earned 200 total points
ID: 38222405
Is there any need to communicate from Vlan 69,70 to 73,74? If not probably the easiest way is to use VRF that completely separate the routing domains. You could have a default route for each VRF then.
0

Featured Post

What Is Threat Intelligence?

Threat intelligence is often discussed, but rarely understood. Starting with a precise definition, along with clear business goals, is essential.

Join & Write a Comment

This article offers some helpful and general tips for safe browsing and online shopping. It offers simple and manageable procedures that help to ensure the safety of one's personal information and the security of any devices.
I recently attended Cisco Live! in Las Vegas, a conference that boasted over 28,000 techies in attendance, and a week of hands-on learning hosted by a solid partner with which Concerto goes to market.  Every year, Cisco displays cutting-edge technol…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

744 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

12 Experts available now in Live!

Get 1:1 Help Now