Exchange 2010 High Availability issues

Hello all.

i have the following design for Exchange site resilience

dsgn
ruhmail1,ruh-mail2 and dam-mail3  are members in the same DAG1.

the both  ruh-mail1  and ruh-mail2   replicating in the same site using the private connection

the dam-mail3  replicate from the production interface only  no other NIC  installed

dag
Test :-


I shutdown Ruh-mail1    the Second Server Ruh-Mail2  Mounted and  started then i shutdown   the ruh-mail2    now both ruh-mail1 and ruh-mail2   is down   and the dam-mail3 should be mounted  but the database  did not mounted i try to mount it manually  i face  this error

err

Please  dvise :( .
emiahmadAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Adam BrownSr Solutions ArchitectCommented:
This happens because you no longer have a Quorum. When more than half of the servers in a cluster fail, you lose quorum and the Cluster services on all servers will fail to start. In your situation, you would need to actually change the Quorum method to a File Share Witness quorum instead of a Node Majority Quorum and then evict the site 1 servers from the cluster for the secondary site DAG to mount any databases. There is a technique in Exchange 2010 called Datacenter Activation Coordination  (DAC) that helps with this. http://technet.microsoft.com/en-us/library/dd979790.aspx has a lot of information on this. Essentially, full site failover is considered by microsoft to be a Disaster Recovery issue. Your DAG will never fail over automatically to the second site in your setup. http://technet.microsoft.com/en-us/library/dd979790.aspx has info on DAC that you should go through. http://technet.microsoft.com/en-us/library/dd638137.aspx also has a lot of information you should go through regarding site resiliency.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
emiahmadAuthor Commented:
The current state is rough:-

no data base can mounted so the whole exchange is down

1
if i try to mount database manually result this

 2
0
Adam BrownSr Solutions ArchitectCommented:
Read my response above. DAGs run on top of Windows Cluster Services and much of their operation relies on the functionality and rules of clustering. One of those rules is that half the servers or more have to be up for the cluster to function. In your design, more than half the servers are not working. You can't automatically fail to the third server.
0
emiahmadAuthor Commented:
Dear acbrown2010  thanks.
0
emiahmadAuthor Commented:
latest updates .....

the following screen after the DAC and Node Majority Quorum configuration

1

the database not mounted completely , when i start the Ruh-MAil1  the Dam-Mail3 Database Mounted .

i try to acces  the mailbox  after Dam-Mail3 DB mounted for 10 minutes  it result this screen

2
So .... what i should to do .
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.