Avatar of stopm
stopmFlag for United Kingdom of Great Britain and Northern Ireland asked on

How to get 3G donlge to automatically connect

I have a netbook pc with 3G dongle. Is it possible to get the connection manger to automatically connect to the providers network on start up.
This is to simplify opearation for elderley user
Linux OS DevNetworking Hardware-OtherWireless Hardware

Avatar of undefined
Last Comment
stopm

8/22/2022 - Mon
Duncan Roe

What do you have to do just now to get it to connect?
At work we have a Linux system with a 3G modem which we start off inittab (could presumably change to started if that's what you have). Nothing fancy - only shell scripts.
Getting PPP configured right was the hard bit.
Darr247

What flavor/distro of linux is it?
ASKER
stopm

Sorry i think i put this in the wron category as it woul be a windows device. Also if i buy a netbook with 3G built in would that make it easier to automatically connect to network on power up
Experts Exchange has (a) saved my job multiple times, (b) saved me hours, days, and even weeks of work, and often (c) makes me look like a superhero! This place is MAGIC!
Walt Forbes
ASKER CERTIFIED SOLUTION
Darr247

Log in or sign up to see answer
Become an EE member today7-DAY FREE TRIAL
Members can start a 7-Day Free trial then enjoy unlimited access to the platform
Sign up - Free for 7 days
or
Learn why we charge membership fees
We get it - no one likes a content blocker. Take one extra minute and find out why we block content.
See how we're fighting big data
Not exactly the question you had in mind?
Sign up for an EE membership and get your own personalized solution. With an EE membership, you can ask unlimited troubleshooting, research, or opinion questions.
ask a question
ASKER
stopm

Thanks darr247 i need to give this go.
ASKER
stopm

Can you leave this question open as the netbook is givng me a "no sim detected" error so i cant test the above soloution.
Ay sugestions ref this error?????
ASKER
stopm

Hi Darr247

I finally got the sim to work in the netbook. Have set up connection as you sugested. I do actually want the 3G connection to come up as soon as the laptop is powered on so under connections tab i selected "always dial my default connection"
Also if i look at the Acer conection manager it has a dial number of *99# so i entered this in the phone number field.
If i try and test the dial up connection i configured by selecting connect to the internet under the internet options then select the dial up connection i get the message shown attached.

Note
The pc is stll connected to the broad band network while i am testing this as i should be able to get both connections up at the same time. It certainly works ok if i just use the conection manager. Both the 3G & wireless are showing up at the same time
connection-error.bmp
Get an unlimited membership to EE for less than $4 a week.
Unlimited question asking, solutions, articles and more.
Darr247

Change the number to just *99 and try it (without the # on the end).

Also, look in the Properties of the connection on the Connections tab, in the dialog on the far right in my first inline image, ensure the 3G modem is still selected (I've seen windows switch it to the regular phone modem by itself before).
ASKER
stopm

Thanks Darr247. After some playing around with the settings you sugested i found that if i right click on the 3 icon in the network connections pop up then there is a tab there which says always connect to the 3G network so this solved the problem of having to set up a dummy dial up. THanks anyway will award point to you for your assistance.
ASKER
stopm

See my last comment ref soloution
Your help has saved me hundreds of hours of internet surfing.
fblack61