Unable to Change IE Trusted Sites

I'm running up against a brick wall trying to change the sites listed in IE as trusted sites. On client machines in our domain the trusted sites are already configured and are grayed out from adding any additional sites.

I've tried finding where these are setup by opening Group Policy Management Editor and then editing our domain GPO however, I can't find it actually being set anywhere I look.

I've looked in:

User Configuration > Policies > Windows Settings > Internet Explorer Maintenance > Security > Security Zones & Content Ratings > Modify Settings > Trusted Sites > Sites

When I look here, it shows the sites that are added as trusted sites, but all of the options are grayed out so I can't make any adjustments.

Note: It may be of use to know that when I looked at the Internet Properties it says at the bottom "Some settings are managed by your system administrator" even though I'm looking at the group policy.

I've also looked in:

User Configuration > Administrative Templates > Windows Components > Internet Explorer > Internet Control Panel > Security Page > Site to Zone Assignment List

I've set this to "Not Configured" but it doesn't appear to have any effect on the site settings.

This is a Windows Server 2003/2008 hybrid environment and is at the 2003 functional level.

Where else could this be set that I'm missing here?

Thanks in advance for any help!
Who is Participating?
ThinkPaperConnect With a Mentor IT ConsultantCommented:
You will need to configure the group policy under Computer Configuration instead of User Configuration.

Computer Configuration/Policies/Administrative Templates/Windows Components/Internet Explorer

Sites to Zone Assignment List
1-Local, 2-Trusted, 3-Internet, 4-Restricted

When you configure the settings under User Configuration/Internet Explorer Maintenance, you are setting the DEFAULT settings for the computer (which is usually helpful when you are creating an image of the workstation). It does NOT enforce the settings after the fact.
oops pesky ee page not showing error meant double post
Free tool for managing users' photos in Office 365

Easily upload multiple users’ photos to Office 365. Manage them with an intuitive GUI and use handy built-in cropping and resizing options. Link photos with users based on Azure AD attributes. Free tool!

Raymond PengSystems EngineerCommented:
I'd check to see if all machines are patched and up to date with the latest service packs / windows updates.
BigchinganAuthor Commented:
The linked to solution may help, I will see. However, the trusted sites are still being populated from somewhere and I would like to find that out as I think it may be the answer for the problem as a whole.

The systems are updated so that is not the problem.
hirenvmajithiyaManager (System Administration)Commented:
Run RSoP.msc on client PC to check from where these settings are applied.

BigchinganAuthor Commented:

Thanks, this was helpful. It shows me the trusted sites are a result of a Group Policy. However, I still don't see those sites when I look at the group policy itself and the area is grayed out so that I cannot change anything.

Now that I'm able to see that these sites are in fact a result of group policy, is there a way to determine where that policy is set?

When I look at the "Security Zones Precedence" the only thing listed is Default Domain Policy. When I am looking at the settings that show those trusted sites, am I viewing the settings from the default domain policy or is it something else?

BigchinganAuthor Commented:
Also, just to note. The hotfix above was not the solution. The systems are running Windows 7 with all of the most recent updates and that solution is only for Windows Vista and earlier.
BigchinganAuthor Commented:
ThinkPaper, I believe you may have just provided the proper answer.

I've read countless things via Bing/Google and have yet to come across anything saying to use the computer configuration.

I'm going to make the changes here (which lists the other sites) and will then award the answer once it works. Thank you!!!
hirenvmajithiyaConnect With a Mentor Manager (System Administration)Commented:
The settings for the trusted sites are at two places. In Computer Configuration as well as in User Configuration.

In Computer configuration have a look at Computer Configuration > Administrative Tools > Windows Components > Internet Explorer > Internet Control Panel > Security Page and then trusted sites. Here you will see the Trusted Zone Sites. One more settings is
Then have a look at "Site to zone assignment list"

Ref: http://www.makeuseof.com/tag/configure-trusted-sites-internet-explorer-group-policy/

In User Configuration see the following :
User Configuration > Windows Settings > IE Maintenance > Security > Security
Another one is at User Configuration > Preferences > Control Panel Settings > Internet Settings
Ref: http://technet.microsoft.com/en-us/library/cc754649.aspx

I think this should help you out.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.