android not running

I tried my andriod hello world apps at work which has proxies for internet.

ANyway it worked fine at home and I havent touched it since, bit neither netbeans or eclipse hello world project works.

IN fact I un netbeans and dont get an error but no emulator appears?

The eclipse I get cant find adb.exe file and the android project is ful or errors..

However I havent touched this project and it woked fine at home!


For eclipse I get a location android sdk not set in preferences error and I set netwok conections to manual
jagguyAsked:
Who is Participating?
 
for_yanConnect With a Mentor Commented:
did you follow that

http://developer.android.com/sdk/installing.html

instruction strictly?
Did you download the SDK Starter package?

If your section Installing ADT does not work as they suggest in the beginning because eclipse cannot connect to outside, then still waht they suggest in the toublehasooting section
http://developer.android.com/sdk/eclipse-adt.html#troubleshooting

should work

Yesterday, I strictly followed all that (true, I didn't have any problems with connectivity though) and it all worked fine for me.

As I understand, proxies may play the role when you try to downloadf through Eclipse, eveything else seems to be mostly local until you start going outside with your ddevice, but that is far down the road

I'd still suggest to try again - install new eclips - classic version as they suggest and install sdk in a new place and maybe it will still work
0
 
IanThCommented:
so your android is connected to the wifi at work that has a internet proxy server

are the errors to do with the internet ie a url as that could be way

as why do you get errors if it works at home and no change has taken place
0
 
jagguyAuthor Commented:
>as why do you get errors if it works at home and no change has taken place
Well thats why I am asking the question. The errors are to do with not locating android sdk but I checked the setting and it is ok. This is weird .

wait wait...I did install eclipse and I did get a project to work and I did install the android sdk. I see no reason to do it all again as there must be something with the work proxies and eclipse.

It did work fine at home on this same laptop. NOw I dont see the point in yet yet again more and more fiddling for a problem that people are giving me a 'maybe solution'.

In my android sdk folder I can get the avd manager to load .
0
Free Tool: Site Down Detector

Helpful to verify reports of your own downtime, or to double check a downed website you are trying to access.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
jagguyAuthor Commented:
installing android sdk takes a long time.
is there a way to download the thing and not have an installer that continually downloads?

then I need t completely wip android sdk and eclipse from my computer
0
 
for_yanCommented:
It is of course your decision what to do, or not to do, however when I'm trying to undersatand I acnnot see at waht moment your network conenction (and therefore your proxies, etc ) should be important. If you bypass
Downloading the ADT Plugin
step directly from eclipse and instead go to the step 1 described in Troubleshooting section - then your proxies or any other specifics of your network connection should not play any role.
 If in general you can go to some web site from your computer and download zuip file form public internet site's such as Eclipse and android locations, then with this direct downloading (not from eclipse) there is no reason why it should not work
0
 
for_yanCommented:
>then I need t completely wip android sdk and eclipse from my computer
and you don;t neeed even to do tahtjust unzip your ecloispe to an new folder and unzip your sdk to a new folder
0
 
jagguyAuthor Commented:
download the android sdk takes 1-2 hours with the install.

Is the a complete download fr android sdk instead of the installer as this takes the time .
0
 
for_yanCommented:
don't know about time - that is all specific to network, traffic, etc,
sometimes I opne a webpage in three second, next time I can be openeing the same page on the same computer the whole minute; the same happens  with downloads; taht cannot be predicted.
0
 
jagguyAuthor Commented:
the installer http://developer.android.com/sdk/index.html

takes a long time because it is only 28 mb but downloads further files.

It would be much quicker if I could download the whole thing in one shot
0
 
for_yanCommented:
Don't spend time thinking how long it would take - start downloading.
Anyway even if you are successful and install everything today - you'll spend next couple of months mastering how to program it; it is really not important if it takes 2 hrs or 4 hrs to download
0
 
jagguyAuthor Commented:
here is a poblel already, when installing the android sdk I get

failed to fetch for some file addlist1..connection refused, then i get fetch successful for add-ons.

Is this normal and it takes a long time to fetch everything.

see the file I get? this cant be corect as something is stopping this download of android sdk.
so i turn off the firewall and the same problem
android.docx
0
 
jagguyAuthor Commented:
0
 
for_yanCommented:
the screenshot does not seem dramatic to me
why you are getting failed to fetch - can't understand that
0
 
jagguyAuthor Commented:
ok here is the solution

I need to set proxy when downloading android sdk in tools->options

that is the problem all along othewside I can never install android sdk
0
 
for_yanCommented:
I aslo noticed that  the "SDK and AVD Manager" but in my Eclipse they are separate.
But it was not such a problem - I guess what they refreerd tyow left part and right part are now split - and it still worked OK
0
 
for_yanCommented:
good, it finally works for you
0
 
jagguyAuthor Commented:
well when running hellow wold androind app I get the emulator up where is is a black screen with android and then it crashes and the whole computer reboots

DDMS files not found: C:\@backup\ATO\eclipse\platform-tools\adb.exe

still a problem somewhere
0
 
jagguyAuthor Commented:
hee ae some outouts with hello world android and the packages installed and yes I did install the plugin
and2.docx
0
 
for_yanCommented:
I think I also so such message, there were two lines with this DDMS lines not found
I think it was first time when I started from SDKManager.exe
But there was never computer reboot.
And then when I went to eclipse, it again started downloadoing and installing some pieces and it was already fine
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.