Inplace upgrade Blackberry BES v4.07 to v5.03 possible?


I hoping someone can tell me whether there is an in place upgrade path from BES v4.0.7.9 to v5.0.3 ?

This document says v4.1 SP7 is required but our supplier is saying this is not the case.

I would appreciate doco which describes the process of upgrading BES v4.07 to v5.03.

Who is Participating?
suriyaehnopConnect With a Mentor Commented:
I have this done previous year. Upgrade BES 4.0.1 to BES 5.0. To reduce the downtime, what we did is:

1. Prepare the new server
2. Copy the SIP from old server to new server

One more reason is BES 5.0 is using Microsoft SQL Express while BES 4.0 using non SQL format
Rob KnightConnect With a Mentor ConsultantCommented:

I'd stick with the RIM guidance, not what your supplier says. Whilst it MAY work, it isn't supported and a number of issues may crop up that result in a partially working environment or one which doesn't work at all.

Another option you could consider is using the BlackBerry Migration Kit, commission a new server running BES 5.0.3 and use the Enterprise Transporter to migrate users from the old to the new Environment.

If you look at the Compatibility Matrix here:

You'll see that 4.0.7 to 5.0.3 is a supported configuration.

More information on the Enterprise Transporter here:

I've just successfully migrated 1400+ users from BES 4.1.6 to 5.0.3 using this tool which can either be everything in one go, or using Live Mode, 20 at at time. Live Mode results in minimal disruption to the end users which may be an important consideration.

Hope this helps.

ajosephsonAuthor Commented:
Hey guys,, Thanks for the advice and links..

I'll config a mail new server and look into the migration tools etc.. thanks for the help.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.