Solved

Sharepoint 'Alert Me' function no longer working

Posted on 2012-03-20
15
431 Views
Last Modified: 2012-03-22
I am having a problem with the Sharepoint Alert Me function. It never sends off an email when its been setup.

I've tried the options from these two posts:
http://www.experts-exchange.com/OS/Microsoft_Operating_Systems/Server/MS-SharePoint/Q_24073062.html
http://www.experts-exchange.com/OS/Microsoft_Operating_Systems/Server/MS-SharePoint/Q_24392674.html

But they haven't fixed it.
Looking for some other ideas.
0
Comment
Question by:neolore
  • 8
  • 4
  • 3
15 Comments
 
LVL 38

Expert Comment

by:Justin Smith
Comment Utility
What version of SharePoint?  Are any emails getting out of your farm at all?  This could be an issue with your SMTP configuration or server.
0
 

Author Comment

by:neolore
Comment Utility
No emails at all.
Windows Server 2008 SP2 x64
Windows SharePoint Services 3.0
0
 
LVL 38

Expert Comment

by:Justin Smith
Comment Utility
THen this isn't an Alerts issue, it's a configuration issue.  What do you have specified for your OUtgoing Email server in Central Admin?  Is it a seperate server?  Is it Exchange?  Do you have relay enabled in Exchange for the SharePoint server?
0
 

Author Comment

by:neolore
Comment Utility
The same server also has exchange installed. Outgoing email server has its IP address.
There is also an internal relay setup for the subnet.
0
 
LVL 38

Expert Comment

by:Justin Smith
Comment Utility
Can you specify a server address rather than the IP in the outgoing email?
0
 

Author Comment

by:neolore
Comment Utility
Tried the full internal DNS name on port 25 and it didn't work
I also tried an external URL on port 25 and it also didn't work.
0
 
LVL 1

Expert Comment

by:ITDataCenter
Comment Utility
go to exchange system manager > your server > properties > diagnostic logging > MSexchangeTransport > increase the level of logging to maximum for NDR, SMTP protocal ,,all on this category.
try again and check the application log viewer (post the error/NDR)

is only alerting affected? what about site access requests?

i would suggest also to check WSS logs for any smtp error. hope this helps. andrea-
0
What Security Threats Are You Missing?

Enhance your security with threat intelligence from the web. Get trending threat insights on hackers, exploits, and suspicious IP addresses delivered to your inbox with our free Cyber Daily.

 

Author Comment

by:neolore
Comment Utility
Its Exchange 2007 SP1, so those options might be command line based.
What service logging level am I switching?

http://technet.microsoft.com/en-us/library/bb201670%28v=exchg.80%29.aspx
0
 
LVL 1

Expert Comment

by:ITDataCenter
Comment Utility
http://technet.microsoft.com/en-us/library/bb201661(v=exchg.80).aspx

MSExchangeTransport\SmtpReceive  at least.


or using the registry

http://blogs.technet.com/b/ferris/archive/2010/05/03/howto-increase-the-logging-levels-in-exchange-2003-2007-and-2010.aspx

is the domain name used on the wss sender (i.e. sharepoint@blabla.com) a valid smtp domain in the exchange organization? is the domain the same used on your mail users?
have you tried to change the wss sender address with the same domain name?
just excluding relay issues
0
 

Author Comment

by:neolore
Comment Utility
Ok increased logging level on MSExchangeTransport\SmtpReceive.

The wss sender is using the administrator email address for the domain.
0
 
LVL 1

Expert Comment

by:ITDataCenter
Comment Utility
ok. pls try testing wss alert or access request. if exchange has problems you may find the error logged on the windows application log viewer.
0
 

Author Comment

by:neolore
Comment Utility
Error:
SMTP rejected a (P1) mail from 'administrator@xxxx.org' with 'xxxx' connector. The user 'anonymous' does not have permissions to send as this address.
0
 

Author Comment

by:neolore
Comment Utility
There is an internal relay setup for the subnet, but the error is on the wrong connector.
Anonymous access is only enabled on the other connector.
0
 
LVL 1

Accepted Solution

by:
ITDataCenter earned 300 total points
Comment Utility
you may try one of the solutions on this kb, based on your needs.
the wss outgoing mail server can be reset accordingly to the ip address of the mail server /connector that allows anonymous connections. a dedicated policy/connector is probably the best choice to get this problem solved.

http://exchangepedia.com/2007/01/exchange-server-2007-how-to-allow-relaying.html
0
 

Author Comment

by:neolore
Comment Utility
I don;t know why our existing email relay connector with Anonymous access doesn't work. But your link helped me setup a new one.

Thank you.
0

Featured Post

Comprehensive Backup Solutions for Microsoft

Acronis protects the complete Microsoft technology stack: Windows Server, Windows PC, laptop and Surface data; Microsoft business applications; Microsoft Hyper-V; Azure VMs; Microsoft Windows Server 2016; Microsoft Exchange 2016 and SQL Server 2016.

Join & Write a Comment

There is one common problem that all we SharePoint developers share: custom solution deployment. This topic can't be covered fully in this short article, so all I want to do in this one is to review it from a development-to-operations perspectiv…
These days socially coordinated efforts have turned into a critical requirement for enterprises.
Here's a very brief overview of the methods PRTG Network Monitor (https://www.paessler.com/prtg) offers for monitoring bandwidth, to help you decide which methods you´d like to investigate in more detail.  The methods are covered in more detail in o…
You have products, that come in variants and want to set different prices for them? Watch this micro tutorial that describes how to configure prices for Magento super attributes. Assigning simple products to configurable: We assigned simple products…

772 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

11 Experts available now in Live!

Get 1:1 Help Now