Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 431
  • Last Modified:

SBS 2003 Needs restarting so client machine and server can access websites

Hi All,

I wonder if you can advise.
I have a SBS2003 Server with just one Win 7 machine connected to the domain now. Recently the internet has started playing up on the Win7 machine, saying it can't find the website. If you log onto the server at the same time you'll find that can't either.

There is a laptop that is connected to the Draytek wireless 2830 router and is not on the domain and that cna still get online with out any issues, so it appears to be a server issue.

I am thinking something to do with the DNS, but I am not sure where to begin...below is an IPCONFIG from the server



Windows IP Configuration



   Host Name . . . . . . . . . . . . : COMPANYNAME-SERVER

   Primary Dns Suffix  . . . . . . . : companynamenet.office

   Node Type . . . . . . . . . . . . : Unknown

   IP Routing Enabled. . . . . . . . : Yes

   WINS Proxy Enabled. . . . . . . . : Yes

   DNS Suffix Search List. . . . . . : companynamenet.office



Ethernet adapter Network Connection:



   Connection-specific DNS Suffix  . :

   Description . . . . . . . . . . . : Broadcom NetXtreme Gigabit Ethernet #2

   Physical Address. . . . . . . . . : 00-22-19-0B-42-1C

   DHCP Enabled. . . . . . . . . . . : Yes

   Autoconfiguration Enabled . . . . : Yes

   IP Address. . . . . . . . . . . . : 192.168.2.2

   Subnet Mask . . . . . . . . . . . : 255.255.255.0

   Default Gateway . . . . . . . . . : 192.168.2.1

   DHCP Server . . . . . . . . . . . : 192.168.2.1

   DNS Servers . . . . . . . . . . . : 192.168.16.2

   Primary WINS Server . . . . . . . : 192.168.16.2

   NetBIOS over Tcpip. . . . . . . . : Disabled

   Lease Obtained. . . . . . . . . . : 19 March 2012 21:05:09

   Lease Expires . . . . . . . . . . : 22 March 2012 21:05:09



Ethernet adapter Server Local Area Connection:



   Connection-specific DNS Suffix  . :

   Description . . . . . . . . . . . : Broadcom NetXtreme Gigabit Ethernet

   Physical Address. . . . . . . . . : 00-10-18-3A-83-C7

   DHCP Enabled. . . . . . . . . . . : No

   IP Address. . . . . . . . . . . . : 192.168.16.2

   Subnet Mask . . . . . . . . . . . : 255.255.255.0

   Default Gateway . . . . . . . . . :

   DNS Servers . . . . . . . . . . . : 192.168.16.2

   Primary WINS Server . . . . . . . : 192.168.16.2


Any advice would be really appreciated.

Many Thanks,

Graham.
0
brandstaruk
Asked:
brandstaruk
  • 13
  • 9
  • 6
4 Solutions
 
Darius GhassemCommented:
Well it seems like you have two network cards enabled but you should only need one. The server looks like it is not static but instead DHCP?

 DHCP Enabled. . . . . . . . . . . : Yes

You should not have SBS server DHCP enabled.

Make sure you have update DNS Forwarders listed from your ISP.

http://technet.microsoft.com/en-us/library/cc773370(v=ws.10).aspx
0
 
brandstarukAuthor Commented:
Thanks for the reply.

DHCP on the router is enabled but the address 192.168.2.2 for the server is reserved on there so it doesn't ever change.

The DNS Forwards have the DNS Servers for out ISP.

We have always had two NICs. One is outward facing for internet and then the other is the internet NIC. ... Don't have to have two but that is just how it is set up. Is there a step by step guide to changing it ?

Thanks.
0
 
plug1Commented:
On the main network adaptor change the DNS server to be 192.168.2.2, you dont need a WINS server. Disable the 2nd adaptor and reboot the server (probably not needed but wouldnt hurt).

You change these by opening the network connections control panel, right click each adaptor, select disabkle on the .16.2 one and select properties on the main one, then open up the tcpip properties and change the DNS settings to how Ive mentioned already.
0
What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

 
brandstarukAuthor Commented:
Thanks, I suppose the question is,

Will moving to just one NIC resolve the DNS issue?
If so I am happy to move, if not it seems a pointless excersize!

Thanks,

Graham.
0
 
plug1Commented:
I think it will yes. There's no reason for you to use 2 nic's in your current scenario.
0
 
Darius GhassemCommented:
yes that should stop the issues
0
 
brandstarukAuthor Commented:
Ok thanks, I will give it a go on Friday as I will be on site then, not sure it is something that would work remotely!
0
 
brandstarukAuthor Commented:
Would that then effectively make the touter the DHCP server rather than the server ... ?
0
 
plug1Commented:
The router already is the DHCP server from your notes above.
0
 
brandstarukAuthor Commented:
It is the DHCP server for everything outside the domain, the domain is controlled by the server
0
 
plug1Commented:
In that case easiest thing to do is simply change the DNS server on the main card from 192.168.16.2 to 127.0.01 which is a loopback address and makes the server look at itself. Can you give us an IP config from one of the client pc's on the domain?
0
 
Darius GhassemCommented:
Do not use 127.0.0.1 you should be using the correct IP address not loopback
0
 
plug1Commented:
Yawn.. use 192.168.2.2 then, but try both and you will see they both work.
0
 
Darius GhassemCommented:
They both work but the proper way is to use the correct IP address. If you move to multiple DCs you will need to have the IP address listed or you can see DNS issues.
0
 
plug1Commented:
The poster is using SBS so that's pretty irrelevant for this thread. Your right obviously in what your saying though.
0
 
brandstarukAuthor Commented:
Just to update, I haven't forgotten this question, but I have not been able to change the configuration from 2 NIC's to 1 NIC. The plan is to do it Tuesday afternoon so will respond letting you know the answer or if we need further assistance.

Thanks,

Graham.
0
 
brandstarukAuthor Commented:
Ok, so I have disabled the internal NIC. Rerun the Wizard and the computer and server are talking, I can connect to the internet on both.

It does seem to take a log time to log on but the real issue is that Outlook won't connect to exchange ... :-/  any ideas why moving to one NIc would do that?

Thanks
0
 
Darius GhassemCommented:
Check your DNS records to make sure you have the correct IP addresses listed in DNS.

Run dcdiag /fix and ipconfig /registerdns
0
 
brandstarukAuthor Commented:
DNS listed on the computer are the IP of the ISP DNS servers. DNS listed on the Server is the IP of the server.

I have also just noticed that if I try to open a mapped drive from PC to server I get an error "The system has detected a possible attempt to compromise security..."

:-/
0
 
Darius GhassemCommented:
Well that is the problem the clients should NOT be pointing to the ISP for DNS they should be pointing to the DC for DNS only
0
 
brandstarukAuthor Commented:
Ok! So ... I changed the DNS manually on the PC to the IP of the server .. Exchange connected and the mapped drives were happy to let me connect and logging on seemed quicker than before ...

Is setting it manually the correct way of doing it or should the server be telling the PC the DNS address ?  Bearing in mind that the DHCP is now the router..

Thanks

Graham
0
 
Darius GhassemCommented:
The DHCP on the router should be configured with the IP address of the SBS server only. You must configure this in the router. I would recommend though that you use the SBS server as DHCP server but if you don't want to then you need to change DNS IPs in router DHCP server config
0
 
brandstarukAuthor Commented:
This still hasn't resolved the problem. Just tried using the desktop to go to BBC site and I am getting a server not found :-(
Changing to one NIC hasn't helped.
0
 
brandstarukAuthor Commented:
I don't know if this makes any difference ... but

I have tried pinging www.google.co.uk / www.bbc.co.uk / www.itv.com

sometimes bbc / itv will fail and sometimes they will work, really random, google seems to always work .. well 99% of the time I guess. Does that point in any direction?

that is all from the PC
0
 
Darius GhassemCommented:
Post ipconfig /all

Configure your DNS server wit update forwarders which is your ISP DNS servers

http://technet.microsoft.com/en-us/library/cc773370(v=ws.10).aspx
0
 
brandstarukAuthor Commented:
Sorry Dariusg, I had missed that anyone had actually replied to this!!

It has been intermittent so it still isn't resolved. I ran a number of updates on the server to see if that resolved the issue but it didn't.

I will get ipconfigs asap but may not be until next week as I can't get onto the machines until then.

Thanks for the advice here, really need to get it sorted as it is very annoying!

Graham.
0
 
brandstarukAuthor Commented:
Ok this seems to be working now, at least the main user hasn't said otherwise so I will close this case.
Thanks very much for all the assistance.
Graham.
0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

  • 13
  • 9
  • 6
Tackle projects and never again get stuck behind a technical roadblock.
Join Now