• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1380
  • Last Modified:

Server 2008 R2 restarting automatically after updates, how to stop

Hi, I have a 2008 R2 server that has been restarting every few days after updates.  This tends to be a problem and makes a busy morning for me.

Question: is there a way to allow it to update, but let me choose when to restart, or maybee each Sunday AM.  I have users that leave files open and work at all hours of the night, so unplanned restarts are troublesom.

Thanks all, the error is blow.


Restart Required: To complete the installation of the following updates, the computer will be restarted within 15 minutes:
- Update for Microsoft .NET Framework 4 on XP, Server 2003, Vista, Windows 7, Server 2008, Server 2008 R2 for x64 (KB2600217)
0
Dan
Asked:
Dan
3 Solutions
 
ibrahim52Team LeaderCommented:
To enable automatic updates, type the command: "cscript scregedit.wsf / AU / 4"

    Stop and start the Windows Update service by using the command "net <stop/start> wuauserv"

    To check the current settings, you can use the command: "cscript scregedit.wsf / AU / v"

    Finally, if you want to disable the automatic update, use the same procedure using the command "cscript scregedit.wsf / AU / 1"

    You can also force the search for updates using the command (because the search for updates is set to 03h00): "wuauclt / detectnow"
0
 
ibrahim52Team LeaderCommented:
Check this outside, some helpful tools.

Referred Link :
http://ctxadmtools.musumeci.com.ar/VisualCore2008/VisualCore11_Beta2_Refresh.html
0
 
larry urbanDevOps EngineerCommented:
yes you can set it to download the update but let you install them later.

Right click on my computer, select properties. in the page that opens, go to the lower left hand corner and select "Windows Update.
In this window select "change settings". (upper left)
under important update, select "Download updates but let me choose whether to install them".

and click on OK.
0
 
IT-ShrekCommented:
Hello,

since both comments do not directly answer the question of the thread owner:

There is a group policy, that can disable automatic reboots after update installation, however, it is only working when a user is logged on. On a server system with no user logged in, there is no way with windows standard features to install the updates but do not restart the system. Microsoft strongly recommends to restart server systems immediately after update installations.

You can set Windows Update to automatic downloads and installations on a specified time like Sundays night.

However, with Microsoft System Center Configurations Manager (SCCM) there is a possibility to "push" Updates to the client and force no restart.

Shrek
0
 
DanOwnerAuthor Commented:
Thanks guys, I got info from all of you guys
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Cloud Class® Course: C++ 11 Fundamentals

This course will introduce you to C++ 11 and teach you about syntax fundamentals.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now