OpenSSH for Windows 7

I installed OpenSSH for Windows 7
OpenSSH and followed the quick guide.In CMD in the bin dir for OpenSSH, mkgroup -l > ..\etc\group and mkpasswd -l > ..\etc\passwd. Then net start opensshd. It says it starts successively. When I try to connect to it in putty it throws up a fatal error saying,"Network Error: Connection Refused." I'm connecting to 127.0.0.1 on the same computer. I even tried ssh in C:\Program Files (x86)\OpenSSH\bin, ssh Tyler@127.0.0.1. It says,   "ssh: connect to host 127.0.0.1 port 22: Connection refused." I even tried my local IP of 10.0.0.33 on another computer in putty. Both computers are running Windows 7 Home Premium. Both have passwords for the Windows account. I attached the group and passwd files below. They are normal computers connected via Wi-Fi on the same router. NOT hooked up to Domains or complicated stuff. Help. I looked even for an answer on the fourms here, but did not find any answers. Thanks. :)
group
passwd
LVL 1
TylerwinAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

arnoldCommented:
Run netstat -an |find ":22"
You have to make sure that host keys have been generate.
You may have to open port 22 in the advanced firewall settings.
0
TylerwinAuthor Commented:
I ran netstat -an |find ":22" and did not find anything. The host keys have been generated. I even disabled the firewall on my computer. When I try to restart the service in services.msc I get this error,"Windows could not start the OpenSSH service on Local Computer. Error 1067: The process terminated unexpectedly." I tried restarting the computer too. I don't know why this is happening.
pic.JPG
0
arnoldCommented:
What is your sshd_config file reflect for the port to which it should bind. Check advanced settings for firewall and add the sshd program to the allow.  Even though you have firewall disabled, it might still deny the service from binding to the privileged 22 port.
0
The Ultimate Tool Kit for Technolgy Solution Provi

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy for valuable how-to assets including sample agreements, checklists, flowcharts, and more!

TylerwinAuthor Commented:
Here is my sshd_config file in attachments. I don't know how to 'allow' the sshd program in the firewall. I'm using Norton Internet Security 2012.
sshd-config
0
TylerwinAuthor Commented:
Its not a program per-say, its a service running in windows that is running a executable at C:\Program Files (x86)\OpenSSH\bin\cygrunsrv.exe.
pic2.JPG
0
arnoldCommented:
The service might be being denied the ability to bind to port 22.
Does your system have any ani-virus app?
You could add that app to allow it to bind to port 22.
0
TylerwinAuthor Commented:
OK, how do I do that? I'm using Norton Internet Security 2012.
0
TylerwinAuthor Commented:
I even tried installing OpenSSH on another computer that has MSE and Windows firewall turned off and allowed the program to run through the firewall. I don't know why this is happining. I still get the same error msg.
0
arnoldCommented:
Uncomment the listen IPV4 and ipv6 entry in sshd_config

I do not have a cygwin setup in a windows 7 environment so it is not clear what is not working, based on your responses the binding to 0.0.0.0 port 22 is not occurring.
0
TylerwinAuthor Commented:
Can you tell me what to uncomment in sshd_config file? There is no ipv4 or ipv6 to uncomment.
0
arnoldCommented:
Port 22
#Protocol 2,1
Protocol 2
ListenAddress 0.0.0.0
#ListenAddress ::

Try that first.

Check whether your DDE settings are what prevents it from running.
See the log file
http://www.cs.technion.ac.il/~imaman/misc/openssh.html
C:\Program Files (x86)\OpenSSH\var\log\OpenSSHd.log
0
TylerwinAuthor Commented:
OK, on another computer thats running MSE and Windows Firewall both turned off I uninstalled OpenSSH and re-installed it. I ran mkgroup -l > ..\etc\group and mkpasswd -l > ..\etc\passwd. Then edited the sshd_config file just like you said. And It did the same error again. See picture below. Some times in services.msc when I start the OpenSSH service it runs for a second then shuts down.Then when I run it again it gives me the same error msg.
It would be nice if you could try installing OpenSSH in Windows 7 and try and get it running for yourself. Heres the link (http://sourceforge.net/projects/sshwindows/files/OpenSSH%20for%20Windows%20-%20Release/). And for some reason there is no log file where you specified.
pic3.png
0
arnoldCommented:
I've not set this up on win 7 so can not say for sure what is preventing it from running.
I'll see if I can setup on a test system.
0
TylerwinAuthor Commented:
Thanks. Let me know if you can get it running.
0
TylerwinAuthor Commented:
Nobody posted an answer here. So I found the solution. I installed cygwin and openssh on that, and it works. I'm not using the OpenSSH program but installing the package in cygwin.
Here's the video I made on how to do that. (http://youtu.be/DHAEsUL6rsw)
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
arnoldCommented:
Sorry it side tracked.
Glad to hear you've resolved the issue.
0
TylerwinAuthor Commented:
The program OpenSSH for Windows is old and doesn't work with Windows 7.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
VPN

From novice to tech pro — start learning today.