Solved

Configuring Port 443 for both OWA and RDWeb

Posted on 2012-03-20
5
3,303 Views
Last Modified: 2013-12-20
Hi All,

I have an exchange server which currently has OWA running on it. Our external IP has port 443 forwarded to the exchange server. This has been working great.

Now I am trying to setup RDWeb. I cannot get RDWeb access working without changing where port 443 is forwarded to.

How do I get both of these services to work without needing a second external IP address.
0
Comment
Question by:thorpey83
5 Comments
 
LVL 7

Expert Comment

by:hirenvmajithiya
ID: 37745753
I far as I know, you cannot run more than one services on single port. Because when you will configure new service on same port serving to other service, it will say you that the socket/port is occupied/not available.

Hiren
0
 
LVL 39

Expert Comment

by:Aaron Tomosky
ID: 37745828
One application port per ip. That's how ports work. Think of an ip like a street and ports are house numbers. Houses are applications. One address can only go to one house.
0
 

Accepted Solution

by:
gmulhern earned 500 total points
ID: 37745856
You haven't specified where you plan to install RDWeb so I'll assume it is a different box than the Exchange server (at least I *hope* it is). You also haven't said what you are using for NAT  but I'll assume something similar in capability to a Cisco ASA.

You can forward a different port on your external IP to 443 on the internal IP of your RDWeb box. This allows you to leave 443 on the external IP forwarding to 443 on the internal IP of your Exchange box.

This only requires a single external IP and you don't have to do anything special on the RDWeb configuration (as it will still be running on 443). The only difference is when connecting to your RDWeb gateway (from outside) the URL will have to specify the external port number that you chose when creating the second NAT rule.

external_IP:443   --->  internal_IP1:443  (this rule for Exchange)
external_IP:1443 --->  internal_IP2:443  (this rule for RDWeb)

You would connect to your RDWeb gateway with https://external_IP:1443
0
 

Expert Comment

by:manaralbawab
ID: 39039649
Hi there,

i'm using port 5443 for rdweb page for internal and external requests but my problem is from out side the requests goes to the mail system 443 while opening the published applications "the page opening very well on port 5443

- i did the NAT for this port

- i can see the name of the mail server in the certificate warning message so this means that the used port is 443

i need to change the port 443 "that holds the traffic while opening the published application" to 444

kindly advise ASAP
0

Featured Post

Is Your AD Toolbox Looking More Like a Toybox?

Managing Active Directory can get complicated.  Often, the native tools for managing AD are just not up to the task.  The largest Active Directory installations in the world have relied on one tool to manage their day-to-day administration tasks: Hyena. Start your trial today.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Possible fixes for Windows 7 and Windows Server 2008 updating problem. Solutions mentioned are from Microsoft themselves. I started a case with them from our Microsoft Silver Partner option to open a case and get direct support from Microsoft. If s…
This article lists the top 5 free OST to PST Converter Tools. These tools save a lot of time for users when they want to convert OST to PST after their exchange server is no longer available or some other critical issue with exchange server or impor…
To add imagery to an HTML email signature, you have two options available to you. You can either add a logo/image by embedding it directly into the signature or hosting it externally and linking to it. The vast majority of email clients display l…
A short tutorial showing how to set up an email signature in Outlook on the Web (previously known as OWA). For free email signatures designs, visit https://www.mail-signatures.com/articles/signature-templates/?sts=6651 If you want to manage em…

837 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question