SBS Exchange 2007: larger than the maximum acceptable message size error message

I am poping email on my exchange 2007 SBS server. Some user reported they couldn't receive some emails. Checked the event viewer and found the following message:

One or more messages (5) were left in the 'jay@abc.com' account on the POP3 server 'pop.xyz.com' because they are larger than the maximum acceptable message size (the largest message is 23393702 bytes). You can either connect to the POP3 account and retrieve or delete the messages manually, or increase the maximum acceptable message size in Exchange Server.

I went to to EMC, Organization configuration -> Hub Transport -> Global setting -> I unchecked the Max receive and send limits, also restarted the transport service, but I am still getting the same message....
okamonAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Rob WilliamsCommented:
You have to change it in several places.  See the following link for details.
http://blog.lan-tech.ca/2011/10/27/quickie-changing-message-size-limits-on-sbs-std-2008-and-2011/
Within the link there is a link to the Technet article which you should also read if using the POP connector.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
ltswebCommented:
Take a look at http://support.microsoft.com/kb/2222370

You may need to restart system attendant also.
0
Rob WilliamsCommented:
I should add that the POP connector is really intended only as a temporary solution, though you can contiue to use it instead of SMTP delivery.  However if you do so and large messages are common you should extend the time period that the POP connector checks for e-mail, otherwise it may not finish when it then starts the next cycle which can cause complications.
0
Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

okamonAuthor Commented:
thanx RobWill. But can you tell me why it says Global setting, but it actually didn't work as globly (as what I did in the beginning)?
0
Rob WilliamsCommented:
I am sorry I am not sure I understand your question. Are you assuming Global means all settings?  I am afraid it doesn't.
0
SurajCommented:
0
okamonAuthor Commented:
I meant in Organization configuration -> Hub Transport -> Global setting -> I unchecked the Max receive and send limits

The global setting shouldn't override whatever it define in server setting?
0
Rob WilliamsCommented:
No, as mentioned you have to change it in three locations.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.