Solved

pst File Error

Posted on 2012-03-21
18
370 Views
Last Modified: 2013-02-28
I have a problem opening an Outlook 2007 pst file.
The file has reached its maximum size of 20GB.
I ran a scanpst on the file and there are no errors.
When I attach the file to outlook, it tells me that the file was not closed porperly and it scans the file, which takes quite a number of minutes.
There are no errors.
When I try to expand the contents of the file I get the message.
'The file M:\user\Arcihve.pst cannot be accessed because another workstation has modified it. Close and the restart all mail-enabled applications. You might need to restart your computer.'
I have restarted the computer.
There is no other user using the file.
Any ideas ?
0
Comment
Question by:josephwalsh
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 6
  • 2
  • 2
  • +5
18 Comments
 
LVL 30

Expert Comment

by:IanTh
ID: 37746735
in domain admin right click on the archive and take ownership

imho you cannot extend the pst beyond 20gb you can add another pst
0
 
LVL 3

Expert Comment

by:Charlie2012
ID: 37746739
It is likly the file has not closed properly on teh file server it is located holding the session and file open. You need to log onto the file server that your M:\ share is located.

Right click my computer (computer in 2008) and choose manage.

On 2008 locate share and storage management then on the right select manage sessions.

Locate the file M:\user\Archive.pst and then on the right select close selected session.

On 2003 select shared folders from computer manager then select sessions.

Locate the M:\user\Archive.pst right click and select close session.
0
 
LVL 4

Expert Comment

by:PietMuis
ID: 37746794
Copy the file to your c drive and attempt to open it then, once scanned move it back to the network.
0
Online Training Solution

Drastically shorten your training time with WalkMe's advanced online training solution that Guides your trainees to action. Forget about retraining and skyrocket knowledge retention rates.

 
LVL 5

Author Comment

by:josephwalsh
ID: 37746851
Charlie2012,
The file is not open on the server share.
The server was also restarted.
When I open outlook the session manager on the server shows two open files (by me) while it scans the .pst file for problems.
When finished scanning I have 0 files open.
There were no  other files open on the server.

PietMuis,
I had copied it to the local computer and I have the same problem.
0
 
LVL 19

Expert Comment

by:NerdsOfTech
ID: 37747656
1. Change registry Size limits for Office 2007:
http://support.microsoft.com/kb/832925

-or-

2. UPGRADE to outlook 2010 to increase the default supported limit to 50 GB
0
 
LVL 19

Expert Comment

by:NerdsOfTech
ID: 37747666
3. DELETE some of those messages and/or start a new archive data file!

:)
0
 
LVL 8

Expert Comment

by:chcw
ID: 37748314
Your file is too large that it is close to the 20GB limit of Outlook 2007. Although 2007 can be modified to handle files larger than 20GB, it is very likely that after the file size reaches that limit, there will be various problems.

You may try to modify the registry by following the instructions below:

http://support.microsoft.com/kb/832925

and see if you can expand the contents of the file. If yes, then you need to create several new PST files, and copy the contents of your original PST file to the new ones, which is splitting the original PST file.

If this still does not work, then you can try some third-party tools, below is a list:

http://www.datanumen.com/aor/compare.htm
0
 
LVL 5

Author Comment

by:josephwalsh
ID: 37748347
chew,

I had already read the Microsoft article and changed the registry entries, but that did not work.
I will look at the third party tool you mention.
0
 
LVL 30

Expert Comment

by:IanTh
ID: 37748736
I said you can use a new pst did you read it
0
 
LVL 5

Author Comment

by:josephwalsh
ID: 37749413
IanTh,

I am logged on as administrator, and I have taken ownership of the file.
I cannot open the pst file in order to move items to another pst file and then compact it.
0
 
LVL 47

Expert Comment

by:apache09
ID: 37750554
If you have manageed to copy the PST to your local drive.
make sure you dont not copy it to your Document folder, just incase its being re-directed over the network

Try saving a copy on the root of the C:\ Drive or even in a new location such as
C:\Source

Then Rename the File

Call it anything
XYZ.PST

Open OUtlook
Make sure all of your Other PSTs are disconnected

Once done, try opening the PST

Can you open it, if you go into the properties and try to compact it now.

Once you have sucessfully campacted it, you can put it back into use FOR REFERENCE PURPOSES ONLY

If you continue to use the PST, again allowing it to grow in size, it may become unusable or corrupt again.

What you need to do is name is accrodingly User Emails 2011

Then make a new pst and call it Emails 2012

Use this new PST for the Working PST.

At this point you could start moving emails out of the 2011 pst in to the new 2012 PST in order to reduce the size of the 2011 PST making it a little bit more dependable

Now if after you copy, rename, If you still cannot access the PST, its likely it has become corrupt.

You could use a tool like ScanPSt to try and repair it
However, in my expereince I find this to not work more often than it does work.

Your only recourse would be to restore the PST file from a date and time in which it last worked.

However, this would only work had you taken measures to backup the PST on a regular basis.
0
 
LVL 5

Author Comment

by:josephwalsh
ID: 38325378
The pst file still will not open.
0
 
LVL 5

Author Comment

by:josephwalsh
ID: 38521062
I still have no solution.
0
 
LVL 47

Expert Comment

by:apache09
ID: 38523865
If you still cant open it

Where is:

M:\user\Arcihve.pst

This is on the network right?

On ocassion the Server that hosts tyhe shared file location can have a locked record, saying a user has it open even when they dont

There are two ways to resolve

1 RDP to the Server
Right click on My COmputer>Manage
Go to the open Files
File the file that a user apparantly has open
Right click on it and end the session

The try to open it

If this doest work, or it the session isnt there

the second way to remove the connection is to restart the server,
If no one is connected to the file, it will close the connection, and come up available on the restart

Have seen this happen on Servers that have had a maasive amount of Up time before being restarted. Especially Server 2003
0
 
LVL 5

Author Comment

by:josephwalsh
ID: 38665749
All servers and workstations have been rebooted, but still cannot access the pst file.
0
 
LVL 16

Accepted Solution

by:
terencino earned 500 total points
ID: 38691015
Solutions (or workarounds) others have found:
1. disable Windows Search on Outlook File > Options > Search > Indexing Options > Modify and uncheck or exclude Microsoft Outlook. The in Advanced Options, go to File types and exclude PST.

2. Disable backup products (eg Windows backup, Carbonite, Crashplan etc, exclude PST from server backup).

3, Disable antivirus products

Hope that helps
...Terry
0

Featured Post

Efficient way to get backups off site to Azure

This user guide provides instructions on how to deploy and configure both a StoneFly Scale Out NAS Enterprise Cloud Drive virtual machine and Veeam Cloud Connect in the Microsoft Azure Cloud.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article describes how to import an Outlook PST file to Office 365 using a third party product to avoid Microsoft's Azure command line tool, saving you time.
Ever visit a website where you spotted a really cool looking Font, yet couldn't figure out which font family it belonged to, or how to get a copy of it for your own use? This article explains the process of doing exactly that, as well as showing how…
This video shows how to remove a single email address from the Outlook 2010 Auto Suggestion memory. NOTE: For Outlook 2016 and 2013 perform the exact same steps. Open a new email: Click the New email button in Outlook. Start typing the address: …
CodeTwo Sync for iCloud (http://www.codetwo.com/sync-for-icloud?sts=6554) automatically synchronizes your Outlook 2016, 2013, 2010 or 2007 folders with iCloud folders available via iCloud Control Panel. This lets you automatically sync them with…

689 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question