Solved

No Paste Special feature between two Excel files

Posted on 2012-03-21
14
597 Views
Last Modified: 2012-05-08
When I open two Excel files and try to copy/paste using the Paste Special as values from file A to file B I lose the Paste Special features.  To get around that issue I close the file B, then open through the file A then I can get the paste special options showing again to do my pasting as values, formulas etc. This is not how Excel should be supporting copy paste between two files and I should be able to use the clipboard between any number of Excel files open.  Needless to say that in the middle of the crunch this really gets annoying.  To fix this issue I went to Task Manager and made sure that there was not more than one Excel.exe session is showing and that was not the case.  What would be the recommended solution to this problem?  I use Excel 2010.

Thank you
0
Comment
Question by:trusxlsol
  • 7
  • 2
  • 2
  • +2
14 Comments
 
LVL 3

Expert Comment

by:DaFranker
ID: 37748407
Although it's for a different and older version (obviously if you check the datestamps on those posts), this thread here shows a gradual solution to the same problem (or at least what seems to be the same problem).

Try what's suggested in that thread. Worked for me in both Excel 2002 and 2007.
0
 

Author Comment

by:trusxlsol
ID: 37752835
As it was described on the thread I checked the XLStart folder in Program Files (XP Pro), this folder is actually empty.  As an Excel Add-In I use Essbase. I have been using Essbase for a long time and never had this problem until last month.
0
 

Author Comment

by:trusxlsol
ID: 37756700
When I open two Excel files they start in two separate instances whereas they both should be under one instance.  Hence paste special options are not working, in fact some other features such as moving a tab from one to another is not working either due to the same problem. They work only if I close one of the files and reopen but this time from within the other file. How can I get Excel opening individual files as one instance as it is suppose to be doing?
0
 
LVL 80

Expert Comment

by:byundt
ID: 37799277
Do you use Skype?

A recent update to Skype causes problems when you paste from the clipboard. The cure is to remove the Click to Call feature from Skype. See http://social.technet.microsoft.com/Forums/en-US/excel/thread/0cffef67-afca-45ad-b75d-3eeb4a859983
0
 

Author Comment

by:trusxlsol
ID: 37800778
No I do not use Skype on my work laptop it is not even installed anyways.
0
 
LVL 23

Expert Comment

by:JSRWilson
ID: 37805379
Are you starting Excel and using File > Open (or New)? And if you do are there two instances?
0
Threat Intelligence Starter Resources

Integrating threat intelligence can be challenging, and not all companies are ready. These resources can help you build awareness and prepare for defense.

 
LVL 80

Expert Comment

by:byundt
ID: 37805782
Have you checked the boxes for Show windows in taskbar or Ignore other applications? If so, try checking the first and unchecking the second. In Excel 2010, you find them in File...Options...Advanced menu item. Excel 2007 is similar (push the Office icon button at top left to start).

These checkboxes affect whether Excel tries to launch in two separate instances or a single instance.
0
 

Author Comment

by:trusxlsol
ID: 37805797
Let's say I have file A is open and I need to open the File B so I can copy then do paste special from A to B.  If I open the File B by double clicking on it while the File A is open then Paste Special features are not available. But if I open the File B by selecting File>Open on File A then I have the Paste Special options are available because in this case both files are in the same instance. So in the first case File B is opening as a different instance hence clipboard is not available.  Normally when I open File A, b, C etc. all these files should be opening in the same Excel instance.
0
 

Author Comment

by:trusxlsol
ID: 37805944
byundt,

I did check and uncheck both Show windows in taskbar  and ignore other applications options under advance options and tried to copy and paste special each time I checked/unchecked.  This did not help as I still do not have the special paste features available when pasting.
0
 
LVL 50

Accepted Solution

by:
jcimarron earned 500 total points
ID: 37807419
0
 

Author Comment

by:trusxlsol
ID: 37943333
The above source actually helped, thank you!
0
 

Author Closing Comment

by:trusxlsol
ID: 37943344
Thanks!
0
 
LVL 50

Expert Comment

by:jcimarron
ID: 37943348
trusxlsol--Glad to hear the good news!
0

Featured Post

How to run any project with ease

Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
- Combine task lists, docs, spreadsheets, and chat in one
- View and edit from mobile/offline
- Cut down on emails

Join & Write a Comment

The new Microsoft OS looks great, is easier than ever to upgrade to, it is even free.  So what's the catch?  If you don't change the privacy settings, Microsoft will, in accordance with the (EULA) you clicked okay to without reading, collect all the…
This article will guide you to convert a grid from a picture into Excel format using Microsoft OneNote and no other 3rd party application.
The viewer will learn how to create two correlated normally distributed random variables in Excel, use a normal distribution to simulate the return on different levels of investment in each of the two funds over a period of ten years, and, create a …
This Micro Tutorial demonstrates in Microsoft Excel how to consolidate your marketing data by creating an interactive charts using form controls. This creates cool drop-downs for viewers of your chart to choose from.

707 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

18 Experts available now in Live!

Get 1:1 Help Now