Solved

Regsvr32

Posted on 2012-03-21
17
3,215 Views
Last Modified: 2012-03-28
When I try to register a .dll file ( for example regsvr32 shdocvw.dll) I often get the message
"the module shdocvw.dll was loaded but the entry point dllregistryserver was not found"

I am running the command as Administrator.

What should I do to effect the registration?
0
Comment
Question by:jcimarron
  • 8
  • 5
  • 2
  • +2
17 Comments
 
LVL 59

Expert Comment

by:LeeTutor
ID: 37748890
This Microsoft article explains the usage and error messages of Regsvr32:

http://support.microsoft.com/kb/249873
0
 
LVL 50

Author Comment

by:jcimarron
ID: 37749009
LeeTutor--The explanation given is
"Regsvr32.exe was unable to find the required entrypoint in the module specified in the command line. This can occur if the entrypoints are not properly exported from the module or if the module is not a .DLL or .OCX file."

I still do not understand what to do.
0
 

Expert Comment

by:Skiff_Rat
ID: 37749447
You can try to place the dll into the Win\system32 folder and then run as administrator from there.  That has work for me in the past.
0
 
LVL 59

Expert Comment

by:LeeTutor
ID: 37749501
Sorry, had to be gone for an hour or so.  I assumed the error message meant that the shdocvw.dll was somehow either corrupt or a wrong version.  Why are you trying to register that DLL?  Are you sure it is a proper Win7  DLL?  What version is it?  (Find it in the Windows\System32 folder, right click it, select Properties and click on the Details tab.  On my Windows 7 Ultimate machine, the version is  6.1.7601.17514)   Also, is your computer a 32-bit or 64-bit machine?  If 64 bit, then there are two versions of regsvr32.exe, one in the Windows\System32 folder -- which is the 64-bit version -- and one in the Windows\Syswow64 folder -- and that is the 32-bit version.
0
 
LVL 50

Author Comment

by:jcimarron
ID: 37749781
Skiff_Rat and LeeTutor--
OK, I will come clean.  Registering .dll's such as shdocvw.dll is often given as part of the fix for many problems.  
For example
http://windows7forums.com/windows-7-support/20191-internet-explorer-8-new-tab-connecting.html
People in such threads often report that they get the same error message I do when trying to register a dll, but no one ever tells them how to proceed with the registration probably since the registration was not the original problem..
I do not have such a "original" problem at the moment, but I know in the past, when I did, I could not register several of the .dll's.  
I tried today and it still was not possible because of the cited error.   Mshtml.dll and browseui.dll give the same error message.  (FWIW--Actxprxy.dll and urlmon.dll are registered successfully.)

My purpose is to get to the bottom of this error and therefore be able to register such dll's when necessary in the future.

Having said that here are answers to your questions.
Shdocvw.dll is already in C:\Windows\System32.  It is version 6.1.7601.17514.  I run Win 7 Ultimate 64 bit SP1.  (The other .dll's mentioned are also in System32.)
When running Command Prompt as an Adminstrator, the command line automatically given is
C:\Windows\system32>  which I build to  C:\Windows\system32>regsvr32 shdocvw.dll and click Enter.

I tried C:\Windows\SysWOW64>regsvr32 shdocvw.dll but got the same error message.

As mentioned early, MS does give an "explanation" of the error in the link LeeTutor provided, but I cannot understand it any better than I can understand the error, itself.
0
 
LVL 10

Expert Comment

by:CSI-Windows_com
ID: 37750494
shdocvw.dll is under Windows Resource Protection (WRP) - you can verify this because it has the account "Trusted Installer" as the only account with full control.

This also means that the COM registration keys for the file will be under Windows Resource Protection as well.

So in this particular case there is no need to try to re-register the file.  Maybe you are following Windows XP instructions for fixing a specific type of error?
0
 
LVL 50

Author Comment

by:jcimarron
ID: 37753289
CSI-Windows_com--Thanks for your response.

"Maybe you are following Windows XP instructions for fixing a specific type of error?"

I am following the instructions for a Win 7 problem.  
http://windows7forums.com/windows-7-support/20191-internet-explorer-8-new-tab-connecting.html
mentioned above.  See http:#a37749781
These instructions also appear in several MS KB articles, though they may apply to Win XP and not Win 7.  ( See http://support.microsoft.com/default.aspx?scid=kb;en-us;281679  )

Does your response mean that these .dll's are protected if they are part of Win 7 but not Win XP?
I had the same (similar) problem when running Win XP.  Perhaps the error message was different then, but the net result was that the .dll could not be registered.
0
 
LVL 10

Expert Comment

by:CSI-Windows_com
ID: 37753586
XP couldn't protect registry keys, so you could re-register protected DLLs.

Regsvr32.exe is lied to by AppCompat when registering protected DLL reg keys ( wrpmitigation shim can be seen in compat admin).

However, that results in a success message. Maybe MS removed the DLL removed the registration function since you can't update it anyway?

In any case, even if you received a success, it isn't likely that anything is being updated.
0
Find Ransomware Secrets With All-Source Analysis

Ransomware has become a major concern for organizations; its prevalence has grown due to past successes achieved by threat actors. While each ransomware variant is different, we’ve seen some common tactics and trends used among the authors of the malware.

 
LVL 50

Author Comment

by:jcimarron
ID: 37753680
CSI-Windows_com--
It is probably not fair to ask why so many fixes say to re-register these keys if nothing is accomplished.
0
 
LVL 10

Accepted Solution

by:
CSI-Windows_com earned 500 total points
ID: 37754230
It's definitely fair to ask!  (I would).

Legacy fixes, like urban legends, end up being propagated long beyond their applicability .  

However, there is the small off chance that Microsoft protected the file and not the COM registrations.

So I double checked by downloading RegDLLView (http://www.nirsoft.net/utils/registered_dll_view.html)

Below are the 52 COM interfaces it registers (on Windows 7 x64) - I checked a couple and they are protected (only TrustedInstaller has full permissions).  Try deleting one as an elevated admin.

I also used DLL Export Viewer (http://www.nirsoft.net/utils/dll_export_viewer.html) on shdocvw.dll (x64 and 32-bit) and it indeed does not have the function DLLRegisterServer which used by Regsvr32.exe. (http://msdn.microsoft.com/en-us/library/windows/desktop/ms682162(v=vs.85).aspx)

The above and below info should allow you to verify what I am claiming!

Functions in shdocvw.dll

AddUrlToFavorites      
DllCanUnloadNow      
DllGetClassObject      
DllGetVersion      
DllRegisterWindowClasses      
DoAddToFavDlg      
DoAddToFavDlgW      
DoFileDownload      
DoFileDownloadEx      
DoOrganizeFavDlg      
DoOrganizeFavDlgW      
DoPrivacyDlg      
HlinkFindFrame      
HlinkFrameNavigate      
HlinkFrameNavigateNHL      
ImportPrivacySettings      
OpenURL      
SetQueryNetSessionCount      
SetShellOfflineState      
SHAddSubscribeFavorite      
SHGetIDispatchForFolder      
SoftwareUpdateMessageBox      
URLQualifyA      
URLQualifyW            

COM Class IDs registered by shdocvw.dll

Check the permissions to these keys under HKLM\Software\Classes\CLSID (as well as HKLM\Software\wow6432Node\Classes\CLSID on 64bit)

{00C6D95F-329C-409A-81D7-C46C66EA7F33}      DefaultLocation            
{0142E4D0-FB7A-11DC-BA4A-000FFE7AB428}      Biometrics            
{025A5937-A6BE-4686-A844-36FE4BEC8B6D}      Power Options            
{05D7B0F4-2121-4EFF-BF6B-ED3F69B894D9}      Taskbar            
{1206F5F1-0569-412C-8FEC-3204630DFB70}      Credential Manager            
{14074E0B-7216-4862-96E6-53CADA442A56}      Library Icon Extract Extension            
{17CD9488-1228-4B2F-88CE-4298E93E0966}      Set User Defaults            
{1F3427C8-5C10-4210-AA03-2EE45287D668}      User Pinned            
{241D7C96-F8BF-4F85-B01F-E2B043341A4B}      Workspaces Center            
{2559A1F0-21D7-11D4-BDAF-00C04F60B9F0}      Search            
{2559A1F1-21D7-11D4-BDAF-00C04F60B9F0}      Help and Support            
{2559A1F2-21D7-11D4-BDAF-00C04F60B9F0}      Windows Security            
{2559A1F3-21D7-11D4-BDAF-00C04F60B9F0}      Run...            
{2559A1F5-21D7-11D4-BDAF-00C04F60B9F0}      E-mail            
{2559A1F7-21D7-11D4-BDAF-00C04F60B9F0}      Set Program Access and Defaults            
{3080F90D-D7AD-11D9-BD98-0000947B0257}      Show Desktop            
{3080F90E-D7AD-11D9-BD98-0000947B0257}      Window Switcher            
{36EEF7DB-88AD-4E81-AD49-0E313F0C35F8}      Windows Update            
{4026492F-2F69-46B8-B9BF-5654FC07E423}      Windows Firewall            
{4125DD96-E03A-4103-8F70-E0597D803B9C}      Microsoft Attachment Services            
{4336A54D-038B-4685-AB02-99BB52D3FB8B}      Public Folder            
{58E3C745-D971-4081-9034-86E34B30836A}      Speech Recognition            
{60632754-C523-4B62-B45C-4172DA012619}      User Accounts            
{67CA7650-96E6-4FDD-BB43-A8E774F73A57}      HomeGroup Control Panel            
{68B07BFF-CB50-4D60-A7D5-02B1A523BC8C}      SearchConnector Icon Extract Extension            
{78F3955E-3B90-4184-BD14-5397C15F1EFC}      Performance Information and Tools            
{896664F7-12E1-490F-8782-C0835AFD98FC}      Libraries delegate folder that appears in Users Files Folder            
{8E908FC9-BECC-40F6-915B-F4CA0E70D03D}      Network and Sharing Center            
{90F8C90B-04E0-4E92-A186-E6E9C125D664}      Property Labels            
{93412589-74D4-4E4E-AD0E-E0CB621440FD}      Font Settings            
{96AE8D84-A250-4520-95A5-A47A7E3C548B}      Parental Controls            
{9C60DE1E-E5FC-40F4-A487-460851A8D915}      AutoPlay            
{9FE63AFD-59CF-4419-9775-ABCC3849F861}      System Recovery            
{B155BDF8-02F0-451E-9A26-AE317CFD7779}      delegate folder that appears in Computer            
{B98A2BEA-7D42-4558-8BD1-832F41BAC6FD}      Backup And Restore            
{BB06C0E4-D293-4F75-8A90-CB05B6477EEE}      System            
{BB64F8A7-BEE7-4E1A-AB8D-7D8273F7FDB6}      Action Center CPL            
{C555438B-3C23-4769-A71F-B6D3D9B6053A}      Display            
{C58C4893-3BE0-4B45-ABB5-A63E4B8C8651}      Troubleshooting            
{C73F6F30-97A0-4AD1-A08F-540D4E9BC7B9}      CLSID_AutoListPropertyStore            
{D20EA4E1-3957-11D2-A40B-0C5020524153}      Administrative Tools            
{D34A6CA6-62C2-4C34-8A7C-14709C1AD938}      Common Places FS Folder            
{D555645E-D4F8-4C29-A827-D93C859C4F2A}      Ease of Access            
{D9EF8727-CAC2-4E60-809E-86F80A666C91}      Secure Startup            
{DFFACDC5-679F-4156-8947-C5C76BC0B67F}      delegate folder that appears in Users Files Folder            
{E7DE9B1A-7533-4556-9484-B26FB486475E}      Network Map            
{E95A4861-D57A-4BE1-AD0F-35267E261739}      Windows SideShow            
{E9950154-C418-419E-A90A-20C5287AE24B}      Sensors            
{EB124705-128B-40D4-8DD8-D93ED12589A4}      WPL property store            
{ED50FC29-B964-48A9-AFB3-15EBB9B97F36}      printhood delegate folder            
{ED834ED6-4B5A-4BFE-8F11-A626DCB6A921}      Personalization Control Panel            
{EF4D1E1A-1C87-4AA8-8934-E68E4367468D}      WebCheck
0
 
LVL 50

Author Comment

by:jcimarron
ID: 37755283
CSI-Windows_com--
Thanks for the lead to DLLView.  I ran DLLView in both 32 and 64 bit versions and looked to see what was reported for
browseui.dll
shdocvw.dll
mshtml.dll
actxprxy.dll
urlmon.dll  
(as "representative" .dll's)

All except for browseui.dll were shown in both DLLView screens.   Browseui.dll is, however, installed on my PC in System32 and SysWOW64 folders.

shdocvw.dll, mshtml.dll, urlmon.dll and actxprxy.dll were reported as registered in both DLLView screens.    Registration dates shown were some months in the past, so the "success" registering actxprxy.dll and urlmon.dll using regsvr32  seems meaningless.
 
As you remember shdocvw.dll, mshtml.dll and browseui.dll seemingly "could not be registered" using regsvr32 as reported per the original post.

So, it seems regsvr32 may not accomplish much these days and your comment about "legacy" fixes may be the answer.  Browseui.dll seems somewhat other than normal.

I am going to leave this thread open for a few more days in case anyone else has ideas.  

P.S.  Neither of the URL's posted in your profile work for me.  ("IE cannot display the webpage".  I also tried http://www.csi-windows.com/blog )
0
 
LVL 3

Expert Comment

by:jakeedwards
ID: 37755861
rename all instances of shdocvw.dll in your system to shdocvwbackup.dll

 Make sure there is only ONE shdocvw.dll file and that is in the system32 folder of windows directory.

check path statement in enviromental variables and make sure all system folders are there

reboot the system and register.
0
 
LVL 50

Author Comment

by:jcimarron
ID: 37767197
jakeedwards--Since shdocvw.dll is shown as registered by RegDLLView I guess there is not much need to worry about registering it anymore.

CSI-Windows_com & jakeedwards-- RegDLLView says it can register browseui.dll .  I am not sure I detect any problems because browseui.dll is not registered (per DLLView) so I will hold off on that.

Thanks to you both.  I'll reach a decision on Wednesday.
0
 
LVL 10

Expert Comment

by:CSI-Windows_com
ID: 37767285
Your previous post altered me to some web server problems we were experiencing - they were resolved over the weekend.  The URLs work now.
Thanks.
0
 
LVL 10

Expert Comment

by:CSI-Windows_com
ID: 37767307
BTW Browseui.dll does not have function names, but uses ordinal references (numbered references) so it gets the same error that there is no DLLRegisterServer function.

Not all dll are registered as COM objects (and therefore have registry keys that DLLRegView can find).  They can be loaded manually by specific commands in a programming language or referenced in Import Address Tables (IATs) of other DLLs or EXEs by the ordinal number.

You can use CFF Explorer in Explorer Suite (http://ntcore.com/exsuite.php) and view the "Export Directory" node to see the exported ordinal references.
0
 
LVL 50

Author Comment

by:jcimarron
ID: 37768014
CSI-Windows_com--Re your websites.  Yes, they are working now.  You are welcome.  But glad to hear only alerted you and not altered you.
Now how do I get points from you?  :)
0
 
LVL 50

Author Closing Comment

by:jcimarron
ID: 37777612
CSI-Windows_com--
Thanks.  I learned alot and understand the registering of .dll files better now.
0

Featured Post

How to run any project with ease

Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
- Combine task lists, docs, spreadsheets, and chat in one
- View and edit from mobile/offline
- Cut down on emails

Join & Write a Comment

If you get continual lockouts after changing your Active Directory password, there are several possible reasons.  Two of the most common are using other devices to access your email and stored passwords in the credential manager of windows.
When you start your Windows 10 PC and got an "Operating system not found" error or just saw  "Auto repair for startup". After a while, you have entered a loop for Auto repair which does not fix anything and you will be in a  panic as all your work w…
This Micro Tutorial will teach you the basics of configuring your computer to improve its speed. It will also teach you how to disable programs that are running in the background simultaneously. This will be demonstrated using Windows 7 operating…
This Micro Tutorial will give you a introduction in two parts how to utilize Windows Live Movie Maker to its maximum capability. This will be demonstrated using Windows Live Movie Maker on Windows 7 operating system.

760 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

18 Experts available now in Live!

Get 1:1 Help Now