Solved

Sharepoint automatic logons not working

Posted on 2012-03-21
17
620 Views
Last Modified: 2012-07-14
Hello,
I recently setup a sharepoint(WSS) site with our hosting provider. I am trying to allow users to logon and have their credentials saved, so they don't have to enter every time they go to the site. The sharepoint site has a checkbox to allow them to sign in automatically(see image)
However, every time I select this option it doesn't sign me in automatically.
I called the hosting provider. They told me it has to do with my internet explorer security.
I have searched all over google for settings to allow this to work. I still cannot get it to work. My users are on a domain. The sharepoint site is on the internet. I have added the site to trusted sites, selected autologon with current credentials, and without. I have tried many suggestions with no luck. I fairly sure someone on this site has run into a similar issue. Please help before I pull all my hair out. All suggestions are greatly appreciated
Thank you
splogin.bmp
0
Comment
Question by:jhillbos
  • 9
  • 8
17 Comments
 
LVL 12

Expert Comment

by:NormanMaina
ID: 37749042
Take these steps:
1.Add the URL of the site to the Intranet sites list in Internet Explorer.
2.On the security settings under the Intranet zone(you have to click customize) -scroll to the bottom and make sure that you enable enable automatic logon
(see image)
Intranet.jpg
0
 
LVL 12

Expert Comment

by:NormanMaina
ID: 37749071
if your organization has a domain -you can enforce these settings through a GPO -across the organization.So you dont have to go to each users computer to change the settings.
0
 

Author Comment

by:jhillbos
ID: 37749272
Norman,
I have tried that with no success. I tried it again a few minutes ago. its a No go. any other suggestions.

If i can get it to work on one, I would love to create a GPO for domain. Do you think the issue lis with current GPO on domain? Its pretty close to default.
0
 
LVL 12

Expert Comment

by:NormanMaina
ID: 37749362
Yes the issue could be with the GPO - you can also try putting the site on the Trusted Sites zone and then change the security settings for that zone to automatic logon with current credentials.

The other thing, ask your hosting provider the authentication type that they are using for the SharePOitn site.
The suggestion above assumes Integrated Authentication using NTLM.
I dont know how hosted your SharePoint site is configured-but with Integrated Authentication -it means that SharePoint with pick user credentials from your AD.

If its not windows authentication you are using then what you need to do is to save the users password on first logon in Internet explorer.
http://www.mediacollege.com/microsoft/internet-explorer/autocomplete.html
0
 

Author Comment

by:jhillbos
ID: 37749525
I have tried trusted site with automatic login with current credentials. It didn't work. I think because im not using the same credentials as AD. So its not NTLM.
The host told me I needed to adjust my IE settings. I believe I have adjusted just about everything. I also tried adding a managed credentials setting to my user account in the control panel for the sharepoint domain address.
I can see the cookie that the browser created for the SP site, but it doesn't seem to do anything.
I know im jumping around a bit.
Maybe this will help a little. If I log on to site and close browser, I can get back on the site again. It times out after about 15 min.
0
 
LVL 12

Expert Comment

by:NormanMaina
ID: 37749607
OK, then you need to change the setting from automatic logon -because that uses the windows logged in credentials.

What you need the browser to do is just remember the username and password for that site.Thats all.
0
 

Author Comment

by:jhillbos
ID: 37749665
I set it as autologin only for intranet zones. That also didn't work. I havent tried the other two settings yet. I figured they weren't an option. How can I get the browser to remember user and password for only that site.
0
 

Author Comment

by:jhillbos
ID: 37753026
Ok. So it appers by simply clicking on the automatic login box on the sharepoint site it creates a cookie that allows me to bypass login, but this cookie times out after 30 min. I have contacted the hosting provider and opened a ticket requesting the default cookie expiration to be increased to a week or more if they'll allow it. I will post the results ASAP.
I really hope this will solve my issue.
Thank you Norman for your insight. If nothing else, I got a nice crash course in browser security.
Of course if the cookie solution doesn't work, I'll be back to square one!!
0
Comprehensive Backup Solutions for Microsoft

Acronis protects the complete Microsoft technology stack: Windows Server, Windows PC, laptop and Surface data; Microsoft business applications; Microsoft Hyper-V; Azure VMs; Microsoft Windows Server 2016; Microsoft Exchange 2016 and SQL Server 2016.

 
LVL 12

Expert Comment

by:NormanMaina
ID: 37753174
When you login to any site with your browser - a cookie is created.Some sites create cookies as you browse them to locally store preferances,images etc to boost performance.

Internet explorer security settings controls /regulates this behavious because it can be emulated by malicious software/code.
0
 

Author Comment

by:jhillbos
ID: 37753199
so would you agree that this 30 min timeout period could be the root of my problem?
0
 
LVL 12

Expert Comment

by:NormanMaina
ID: 37753232
was it the same in the begginin?,you did not state that in your question.

But yes that could be the problem -cookie expiry period.
0
 

Author Comment

by:jhillbos
ID: 37753323
I am new to sharepoint and IIS settings. You are right though, I really wasn't sure how to post this question. I should have posted the 30 min timeout, I thought it was irrelevent at the time.
0
 
LVL 12

Expert Comment

by:NormanMaina
ID: 37753811
With all the new info you have now -its so clear in your mind what the problem is.

Wasnt that the objective in the fist place?
0
 

Author Comment

by:jhillbos
ID: 37753838
Yes. It will be clearer in hindsight. haha.
Thanks Norman
0
 

Accepted Solution

by:
jhillbos earned 0 total points
ID: 37765854
Well, It seems the hosting provider is unable/unwilling to change the IIS cookie expiration for me. Once again I am back where I started. There must be another way. Anyone?
0
 
LVL 12

Expert Comment

by:NormanMaina
ID: 37766313
You can try this cookie manager:
-Ive not tried it,actually googled to see if this was possible or not.My first reactionw as that you cant edit cookies -but hey,try and see if this works.

 https://addons.mozilla.org/en-US/firefox/addon/cookies-manager-plus/
0
 

Author Closing Comment

by:jhillbos
ID: 38185437
Nobody gave me an answer
0

Featured Post

Is Your Active Directory as Secure as You Think?

More than 75% of all records are compromised because of the loss or theft of a privileged credential. Experts have been exploring Active Directory infrastructure to identify key threats and establish best practices for keeping data safe. Attend this month’s webinar to learn more.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Guacamole cut and paste issue 3 46
server DNS address could not be found 22 124
Which browser works with XP 16 103
Add Context Menu Item 4 43
I recently found myself in a Corporate Situation where the client had requested blocking access to any and all websites except his own Domain? Easy? I am sure this would be your answer but their requirement was, this has to be done without using…
Introduction If you're like most people, you have occasionally made a typographical error when you're entering information into an online form.  And to your consternation, the browser remembers the error, and offers to autocomplete your future entr…
This Micro Tutorial will demonstrate how to add subdomains to your content reports. This can be very importing in having a site with multiple subdomains.
How to create a custom search shortcut to site-search Experts Exchange using Google in the Firefox browser. This eliminates the need to type out site:experts-exchange.com whenever you want to search the site. Launch your Bookmark Menu: Press 'Ctrl +…

914 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

20 Experts available now in Live!

Get 1:1 Help Now