Errors Importing PST files into Exchange 2010

I have circa 200 PST files that I am trying to import to an Exchange 2010 server. I am receiving a lot of "Couldn't connect to the target mailbox" errors both when i create the Import Requests and when I try to resume failed ones. When i was creating the requests I would start getting the error, then wait a few minutes and try again, in which case things would work for a little bit, then i would get the error again. It looks as if there is a limit how many requests i can have so the few first ones run, then the subsequent ones fail. We are not having a CAS Array, this is a single-server installation. Any ideas? I include the exact error below. Thanks!

Couldn't connect to the target mailbox.
    + CategoryInfo          : NotSpecified: (60:Int32) [Resume-MailboxImportRequest], RemotePermanentException
    + FullyQualifiedErrorId : 86B989C,Microsoft.Exchange.Management.RecipientTasks.ResumeMailboxImportRequest
criskritAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

James HaywoodCommented:
Have you tried the PST import tool from Microsoft?

http://www.microsoft.com/download/en/details.aspx?displaylang=en&id=28767
criskritAuthor Commented:
The problem seems related to a limit of maximum simultaneous Import Requests. Is there a way to specify/change this? Also is it possible to specify limits for Active and Queued Import Requests? I wouldn't want to have too many Active requests (too much load on the server) but i would like to be able to Queue all 200+ Import Requests so that i don't have to check back every few minutes. thanks!
James HaywoodCommented:
This file 'C:\Program Files\Microsoft\Exchange Server\V14\Bin\MSExchangeMailboxReplication.exe.config' contains the settings:

Maxactivemovespersourcemdb = 5
Maxactivemovespertargetmdb=2
Maxactivemovespersourceserver=50
Maxactivemovespertargetserver=5
Maxtotalmovespermrs=100

These throttle the amount you can do at any one time. You can edit the settings to increase the throughput.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Big Business Goals? Which KPIs Will Help You

The most successful MSPs rely on metrics – known as key performance indicators (KPIs) – for making informed decisions that help their businesses thrive, rather than just survive. This eBook provides an overview of the most important KPIs used by top MSPs.

criskritAuthor Commented:
unfortunately i have already done this and it doesn't seem to work. I have setup 50 active requests but the server will not accept more than 20. Also this still doesn't queue the non-active ones... :-(
Any (other) ideas?
James HaywoodCommented:
What settings have you tried with this file?
criskritAuthor Commented:
here is the full thing:

<MRSConfiguration
    MaxRetries = "60"
    MaxCleanupRetries = "5"
    MaxStallRetryPeriod = "00:15:00"
    RetryDelay = "00:00:30"
    MaxMoveHistoryLength = "100"
    MaxActiveMovesPerSourceMDB = "50"
    MaxActiveMovesPerTargetMDB = "50"
    MaxActiveMovesPerSourceServer = "50"
    MaxActiveMovesPerTargetServer = "50"
    MaxTotalMovesPerMRS = "500"
    FullScanMoveJobsPollingPeriod = "00:10:00"
    MinimumTimeBeforePickingJobsFromSameDatabase = "00:00:04"
    ServerCountsNotOlderThan = "00:10:00"
    MRSAbandonedMoveJobDetectionTime = "01:00:00"
    BackoffIntervalForProxyConnectionLimitReached = "00:30:00"
    DataGuaranteeCheckPeriod = "00:00:10"
    DataGuaranteeTimeout = "00:30:00"
    DataGuaranteeLogRollDelay = "00:01:00"
    EnableDataGuaranteeCheck = "true"
    DisableMrsProxyCompression = "false"
    DisableMrsProxyBuffering = "false"
    MinBatchSize = "100"
    MinBatchSizeKB = "256" />
James HaywoodCommented:
Can you show the command/script you are using? thanks
criskritAuthor Commented:
I am grouping PST by first initial, so the following repeats for all letters of the alphabet:

Dir \\mailseiu1\OST-to-PST\PSTs\import_pending\a*.pst | %{ New-MailboxImportRequest -Name PSTimport_A -BatchName ImportPstFiles -BadItemLimit 50 -Mailbox $_.BaseName -FilePath $_.FullName}
criskritAuthor Commented:
any more suggestions on this?
James HaywoodCommented:
Sorry I've been waiting for an Exchange Admin friend to get back to me. The only other suggestion is to run the imports in batches of 10
criskritAuthor Commented:
i ended up importing the PSTs in batches of 20 (this seems to be the max) and i wrote a ps1 script where i spaced out the imports with "wait" commands in order to give time for previous imports to complete. A bit primitive but it works.

if there are no suggestions then i will close this question. Not sure how/where to award it, this looks more like a bug in Exchange config...
criskritAuthor Commented:
The Expert's comment is in the right direction but doesn't really resolve the issue as this seems like a glitch in the Exchange configuration as mentioned in my last comment along with the workaround i used.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.