Solved

No access to OWA since public IP address change.

Posted on 2012-03-21
9
1,814 Views
Last Modified: 2012-04-09
I recently needed to change our static public IP address for our domain so our network could use a new fibre link rather than an older slower copper one. Our Exchange server 2010 on an SBS 2011 DC had worked and run OWA fine until the change-over. Now my users can't log in remotely athough OWA works fine internally.

I also changed the router from a Netgear FVS318 to a Cisco-branded Lynksys RV042 for a VPN to a branch office and have forwarded both ports 80 & 443 on the router to the Exchange server but externally only port 443 appears to be open and traffic can't pass through 80 to the server. Our ISP has confirmed they are not blocking port 80 and I can telnet the server on 80 from the internal network.

Looking at the IIS Manager i notice that there is a question mark over the globe for 'Default Web Site' and there doesn't seem to be a clue as to what the ? mark is referring to.

Would the server be blocking access via HTTP to port 80 from the router? Could there be an issue with the bidings. Or could I have a fault with the router?
0
Comment
Question by:astgpaul
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 3
  • 2
  • +1
9 Comments
 
LVL 7

Assisted Solution

by:micropc1
micropc1 earned 125 total points
ID: 37749669
My first thought would be an issue at the gateway. Have you checked your NAT configuration and firewall settings?
0
 
LVL 37

Expert Comment

by:Neil Russell
ID: 37749701
What you dont mention is have you changed your external DNS records that point at your webmail ?
This will need to point to your new external IP and not the old one.
0
 
LVL 47

Assisted Solution

by:David
David earned 250 total points
ID: 37749871
A few things
 - make sure all those registry settings and configuration files don't have the IP number hardwired in any of the OWA services.

You might also create another OWA instance (been years, I THINK you can do this) that uses the domain name, and just see if that instance works.  If it does, then you are home free.

Purge all arp tables & DNS stuuff
0
Salesforce Made Easy to Use

On-screen guidance at the moment of need enables you & your employees to focus on the core, you can now boost your adoption rates swiftly and simply with one easy tool.

 

Author Comment

by:astgpaul
ID: 37749965
Thanks for all coming back so quickly. I'm wondering if this is a certificate issue. If I try to connect using https I get a warning about an insecure site, accept the warning, register the exception and then get a 404 Not Found 'The requested URL /owa was not found on this server'
0
 
LVL 37

Assisted Solution

by:Neil Russell
Neil Russell earned 125 total points
ID: 37750288
I repeat as you have not answered. Have you updated your external DNS records and confirmed that replication/propergation has taken place?

do you get the correct IP address if you try

PING yourwebmailserver.yourdomin.com  from an EXTERNAL computer?
0
 

Author Comment

by:astgpaul
ID: 37750378
Neilsr - I have considered your comments about the dns records and I'm going to look into this when the domain hosting company open in the morning (I'm in the UK).

Thanks - I'll let you know.
0
 
LVL 47

Accepted Solution

by:
David earned 250 total points
ID: 37750398
If you can get to a unix box do this, assuming your domain is xyz.co.uk and dns is ns0.myisp.com


nslookup
set host ns0.myisp.com
set type=any
xyz.co.uk.

This will reveal everything that the DNS server is putting out there, including the MX records and the TTL.

You can then repeat by doing another set host  and use a different name server, to see what any nameserver of your choice is presenting.  Maybe one of your internal machines or the sbs server itself is wrong.
0
 

Author Closing Comment

by:astgpaul
ID: 37822880
Thanks to those that provided suggestions. It would appear the router can't port forward 443 while also handling VPN.
0
 
LVL 47

Expert Comment

by:David
ID: 37822997
Really? What router is that.  (So I can be sure to avoid that POS)
0

Featured Post

On Demand Webinar: Networking for the Cloud Era

Ready to improve network connectivity? Watch this webinar to learn how SD-WANs and a one-click instant connect tool can boost provisions, deployment, and management of your cloud connection.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Read this checklist to learn more about the 15 things you should never include in an email signature.
Check out this step-by-step guide for using the newly updated Experts Exchange mobile app—released on May 30.
To add imagery to an HTML email signature, you have two options available to you. You can either add a logo/image by embedding it directly into the signature or hosting it externally and linking to it. The vast majority of email clients display l…
This video discusses moving either the default database or any database to a new volume.

717 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question