Solved

Cisco IP Phone Issues

Posted on 2012-03-21
16
666 Views
Last Modified: 2012-07-19
We have around 50 phones on our network and are having an interesting issue.  There are two users on the network that are both using CP-7962 phones and when they call everyone inside and outside they have no problems except when calling each other.  I have checked IP and they are different.  When calling each other it does not dial and instead goes directly to the other person's voicemail.
 
Cisco Unity Express V7.0
0
Comment
Question by:David_Blumberg
  • 8
  • 5
  • 3
16 Comments
 
LVL 20

Expert Comment

by:José Méndez
ID: 37750282
CME?
0
 
LVL 1

Author Comment

by:David_Blumberg
ID: 37750809
Not sure what you mean but it's running cme 7.0 on a 2821 integrated services router
0
 
LVL 20

Expert Comment

by:José Méndez
ID: 37751073
There are two callmanager versions, not just CME, so I wanted to be sure what software you were dealing with. Are they sharing the same ephone-dn? If those are different, are they single-line, dual-line or octo-line?
0
 
LVL 5

Expert Comment

by:Yohei0815
ID: 37751780
Hi it would make sense to see a SIP trace of the call. Can you provide one with wireshark.
Just one side is needed. make a call between both participants to trigger the error condition.
There are a few ideas that come to my mind: Call forwarding for a specific user. Call barring. Or the config of one phone only has a certain codec allowed, which is not allowed for the other hence the box answers the call. eg the following scenario
User A codecs G.729 for voice
User B codec G.722 for voice
The voicebox may have g.711 and works for both participants.
There could be some mismatch for one phone.
0
 
LVL 1

Author Comment

by:David_Blumberg
ID: 37752024
Here is the config (minus other phones and network info that is non-essential


!
!
aaa authentication login default local
aaa authentication login userauth local
aaa authorization network groupauth local 
!
!
aaa session-id common
clock timezone EST -5
clock summer-time EDT recurring
!
dot11 syslog
ip source-route
!
!
ip cef
no ip dhcp use vrf connected
ip dhcp excluded-address 172.20.10.1 172.20.10.49
ip dhcp excluded-address 172.20.0.1 172.20.0.49
ip dhcp excluded-address 172.20.10.106
!
ip dhcp pool voice
   network 172.20.10.0 255.255.255.0
   option 150 ip 172.20.10.1 
   dns-server 66.155.216.122 207.59.153.242 66.251.35.130 
   domain-name xxx.com
      default-router 172.20.10.1 
!

ip inspect name firewall https
ip inspect name firewall ftp
ip inspect name firewall tcp
ip inspect name firewall dns
ip inspect name firewall ipsec-msft
ip inspect name firewall isakmp
ip inspect name firewall udp
ip inspect name firewall pptp
ip inspect name firewall pop3
ip inspect name firewall icmp
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
voice service voip 
 allow-connections h323 to h323
 allow-connections h323 to sip
 allow-connections sip to h323
 allow-connections sip to sip
 no supplementary-service sip moved-temporarily
 no supplementary-service sip refer
 sip
  bind control source-interface Loopback0
  bind media source-interface Loopback0
  no update-callerid
!
!
!
!
!
!
!
!
!
!
voice class custom-cptone jointone
 dualtone conference
  frequency 600 600
  cadence 200 50 200 50
!
voice class custom-cptone leavetone
 dualtone conference
  frequency 900 900
  cadence 200 50 200 50
!
!
!
!
!
!
!
!
!
voice translation-rule 100
 rule 15 /^9/ //
!

!
voice translation-profile sip-outbound
 translate calling 101
 translate called 100
!
!
voice-card 0
 dspfarm
 dsp services dspfa
!

!
username administrator privilege 15 secret 5 $1$X7lC$QG3RLFKOgRtgL9H1.7KAV1
archive
 log config
  hidekeys

crypto keyring dmvpnspokes 
  pre-shared-key address 0.0.0.0 0.0.0.0 key ButlerPSK!
!
crypto isakmp policy 10
 encr 3des
 hash md5
 authentication pre-share
 group 2
!
crypto isakmp client configuration group RemoteAccess
 key ButlerPSK
 pool vpn-pool
 acl 190
 netmask 255.255.255.0
crypto isakmp profile DMVPN
   keyring dmvpnspokes
   match identity address 0.0.0.0 
crypto isakmp profile VPNClient
   match identity group RemoteAccess
   client authentication list userauth
   isakmp authorization list groupauth
   client configuration address respond
!
!
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac 
!
crypto dynamic-map outside-dyn-map 10
 description To 192.168.2.0/24
 set transform-set ESP-3DES-MD5 
 set isakmp-profile DMVPN
 match address 150
crypto dynamic-map outside-dyn-map 65535
 set transform-set ESP-3DES-MD5 
 set isakmp-profile VPNClient
!
!
crypto map outside-map 65535 ipsec-isakmp dynamic outside-dyn-map 
!
!
!
!
class-map match-any voice-rtp
 match protocol rtp
 match ip dscp ef 
class-map match-any call-control
 match protocol sip
 match ip dscp af41 
!
!
policy-map voip
 class voice-rtp
    bandwidth percent 80
 class call-control
    bandwidth percent 5
 class class-default
    fair-queue
!
!
!
!
!

interface GigabitEthernet0/0.20
 description Voice
 encapsulation dot1Q 60
 ip address 172.20.10.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly
 ip policy route-map policymap
!
interface Service-Engine0/0
 ip unnumbered GigabitEthernet0/0.20
 ip nat inside
 ip virtual-reassembly
 service-module ip address 172.20.10.2 255.255.255.0
 service-module ip default-gateway 172.20.10.1
!

!
interface Serial0/0/0
 no ip address
 encapsulation frame-relay IETF
 max-reserved-bandwidth 100
 service-policy output voip
!
-relay interface-dlci 502 IETF   
!
ip local pool vpn-pool 192.168.10.1 192.168.10.19
ip forward-protocol nd

ip route 172.20.10.2 255.255.255.255 Service-Engine0/0

!
access-list 10 permit 172.20.0.0 0.0.255.255
access-list 100 deny   ip 192.168.0.0 0.0.255.255 192.168.0.0 0.0.255.255
access-list 100 deny   ip 172.20.0.0 0.0.255.255 192.168.0.0 0.0.255.255
access-list 100 deny   ip 172.20.0.0 0.0.255.255 172.20.0.0 0.0.255.255
access-list 100 permit ip 172.20.0.0 0.0.255.255 any
access-list 100 permit ip 192.168.0.0 0.0.255.255 any
access-list 101 permit tcp 192.168.1.0 0.0.0.255 any eq www
access-list 101 permit udp 192.168.1.0 0.0.0.255 any eq domain
access-list 111 permit tcp any any eq www
access-list 111 permit udp any any eq domain
access-list 150 remark L2L IPSec Rule
access-list 150 permit ip 192.168.0.0 0.0.15.255 192.168.2.0 0.0.0.255
access-list 150 permit ip 172.20.0.0 0.0.255.255 192.168.2.0 0.0.0.255
access-list 190 remark Client IPSec Rule
access-list 190 permit ip 192.168.0.0 0.0.15.255 192.168.10.0 0.0.0.255
access-list 190 permit ip 172.20.0.0 0.0.255.255 192.168.10.0 
access-list 199 deny   ip any any log
!
!
!
!
route-map outside-nat permit 10
 match ip address 100
 match interface Serial0/0/0.501
!
route-map WWWOnly permit 10
 match ip address 101
!
route-map policymap permit 10
 match ip address 111
 set ip default next-hop 98.191.81.33
!
!
!
tftp-server flash:Analog1.raw
tftp-server flash:Analog2.raw
tftp-server flash:AreYouThere.raw
tftp-server flash:AreYouThereF.raw
tftp-server flash:Bass.raw
tftp-server flash:CallBack.raw
tftp-server flash:Chime.raw
tftp-server flash:Classic1.raw
tftp-server flash:Classic2.raw
tftp-server flash:ClockShop.raw
tftp-server flash:CTU.raw
tftp-server flash:DarkSide.raw
tftp-server flash:DistinctiveRingList.xml
tftp-server flash:Drums1.raw
tftp-server flash:Drums2.raw
tftp-server flash:FilmScore.raw
tftp-server flash:HarpSynth.raw
tftp-server flash:HelpMe.raw
tftp-server flash:Jamaica.raw
tftp-server flash:KotoEffect.raw
tftp-server flash:MusicBox.raw
tftp-server flash:Piano1.raw
tftp-server flash:Piano2.raw
tftp-server flash:Pop.raw
tftp-server flash:Pulse1.raw
tftp-server flash:Ring1.raw
tftp-server flash:Ring2.raw
tftp-server flash:Ring3.raw
tftp-server flash:Ring4.raw
tftp-server flash:Ring5.raw
tftp-server flash:Ring6.raw
tftp-server flash:Ring7.raw
tftp-server flash:RingList.xml
tftp-server flash:Sax1.raw
tftp-server flash:Sax2.raw
tftp-server flash:Vibe.raw
tftp-server flash:apps37sccp.1-3-2-0.bin
tftp-server flash:apps45.8-4-1-23.sbn
tftp-server flash:B016-1-0-3.SBN
tftp-server flash:cnu45.8-4-1-23.sbn
tftp-server flash:cvm45sccp.8-4-1-23.sbn
tftp-server flash:dsp45.8-4-1-23.sbn
tftp-server flash:jar45sccp.8-4-1-23.sbn
tftp-server flash:SCCP45.8-4-2S.loads
tftp-server flash:term45.default.loads
tftp-server flash:term65.default.loads
tftp-server flash:apps75.8-4-1-23.sbn
tftp-server flash:cnu75.8-4-1-23.sbn
tftp-server flash:cvm75sccp.8-4-1-23.sbn
tftp-server flash:dsp75.8-4-1-23.sbn
tftp-server flash:jar75sccp.8-4-1-23.sbn
tftp-server flash:SCCP75.8-4-2S.loads
tftp-server flash:term75.default.loads
!
control-plane
!
!
!
ccm-manager fax protocol cisco
!
mgcp fax t38 ecm
!
sccp local GigabitEthernet0/0.20
sccp ccm 172.20.10.1 identifier 1 version 7.0 
sccp
!
sccp ccm group 1
 associate ccm 1 priority 1
 associate profile 2 register xcodedsp
 associate profile 1 register confdsp
!
dspfarm profile 2 transcode  
 codec g711ulaw
 codec g711alaw
 codec g729ar8
 codec g729abr8
 codec ilbc
 maximum sessions 6
 associate application SCCP
!
dspfarm profile 1 conference  
 codec g711ulaw
 codec g711alaw
 maximum conference-participants 16
 maximum sessions 4
 conference-join custom-cptone jointone
 conference-leave custom-cptone leavetone
 associate application SCCP
!
!
dial-peer voice 5000 voip
 description Voicemail
 destination-pattern 50.
 session protocol sipv2
 session target ipv4:172.20.10.2
 session transport udp
 dtmf-relay rtp-nte
 codec g711ulaw
!
dial-peer voice 1000 voip
 description Default dial-peer
 translation-profile outgoing sip-outbound
 destination-pattern 9T
 session protocol sipv2
 session target ipv4:10.255.255.5
 session transport udp
 dtmf-relay rtp-nte
 codec g711ulaw
 ip qos dscp af41 signaling
!
dial-peer voice 1001 voip
 description Local dial-peer
 translation-profile outgoing sip-outbound
 destination-pattern 9[2-9]......
 session protocol sipv2
 session target ipv4:10.255.255.5
 session transport udp
 dtmf-relay rtp-nte
 codec g711ulaw
 ip qos dscp af41 signaling
!
dial-peer voice 1002 voip
 description Long Distance dial-peer
 translation-profile outgoing sip-outbound
 destination-pattern 91..........
 session protocol sipv2
 session target ipv4:10.255.255.5
 session transport udp
 dtmf-relay rtp-nte
 codec g711ulaw
 ip qos dscp af41 signaling
!
dial-peer voice 1003 voip
 description 411/911 dial-peer
 translation-profile outgoing sip-outbound
 destination-pattern 9[49]11
 session protocol sipv2
 session target ipv4:10.255.255.5
 session transport udp
 dtmf-relay rtp-nte
 codec g711ulaw
 ip qos dscp af41 signaling
!
dial-peer voice 2000 voip
 description xxx
 session protocol sipv2
 session target ipv4:10.255.255.5
 session transport udp
 incoming called-number xxx
 dtmf-relay rtp-nte
 codec g711ulaw
 ip qos dscp af41 signaling
!
dial-peer voice 2001 voip
 description xxx
 session protocol sipv2
 session target ipv4:10.255.255.5
 session transport udp
 incoming called-number xxx
 dtmf-relay rtp-nte
 codec g711ulaw
 ip qos dscp af41 signaling
!
dial-peer voice 2002 voip
 description PMO
 session protocol sipv2
 session target ipv4:10.255.255.5
 session transport udp
 incoming called-number xxx
 dtmf-relay rtp-nte
 codec g711ulaw
 ip qos dscp af41 signaling
!
dial-peer voice 2003 voip
 description Leasing Office
 session protocol sipv2
 session target ipv4:10.255.255.5
 session transport udp
 incoming called-number xxx
 dtmf-relay rtp-nte
 codec g711ulaw
 ip qos dscp af41 signaling
!
dial-peer voice 2004 voip
 description Leasing Fax
 session protocol sipv2
 session target ipv4:10.255.255.5
 session transport udp
 incoming called-number xxx
 dtmf-relay rtp-nte
 codec g711ulaw
 ip qos dscp af41 signaling
!
dial-peer voice 2005 voip
 description 2nd Floor Fax
 session protocol sipv2
 session target ipv4:10.255.255.5
 session transport udp
 incoming called-number xxx
 dtmf-relay rtp-nte
 codec g711ulaw
 ip qos dscp af41 signaling
!
dial-peer voice 2006 voip
 description 12th Floor Fax
 session protocol sipv2
 session target ipv4:10.255.255.5
 session transport udp
 incoming called-number xxx
 dtmf-relay rtp-nte
 codec g711ulaw
 ip qos dscp af41 signaling
!
dial-peer voice 2007 voip
 description PMO Fax
 session protocol sipv2
 session target ipv4:10.255.255.5
 session transport udp
 incoming called-number xxx
 dtmf-relay rtp-nte
 codec g711ulaw
 ip qos dscp af41 signaling
!
dial-peer voice 2008 voip
 description Leasing 2nd Number
 session protocol sipv2
 session target ipv4:10.255.255.5
 session transport udp
 incoming called-number xxx
 dtmf-relay rtp-nte
 codec g711ulaw
 ip qos dscp af41 signaling
!
dial-peer voice 2009 voip
 description Backup Line 1
 session protocol sipv2
 session target ipv4:10.255.255.5
 session transport udp
 incoming called-number xxx
 dtmf-relay rtp-nte
 codec g711ulaw
 ip qos dscp af41 signaling
!
dial-peer voice 2010 voip
 description Backup Line 2
 session protocol sipv2
 session target ipv4:10.255.255.5
 session transport udp
 incoming called-number xxx
 dtmf-relay rtp-nte
 codec g711ulaw
 ip qos dscp af41 signaling
!
dial-peer voice 2011 voip
 description Backup Line 3
 session protocol sipv2
 session target ipv4:10.255.255.5
 session transport udp
 incoming called-number xxx
 dtmf-relay rtp-nte
 codec g711ulaw
 ip qos dscp af41 signaling
!
dial-peer voice 2012 voip
 description Backup Line 4
 session protocol sipv2
 session target ipv4:10.255.255.5
 session transport udp
 incoming called-number xxx
 dtmf-relay rtp-nte
 codec g711ulaw
 ip qos dscp af41 signaling
!
dial-peer voice 2013 voip
 description Backup Line 5
 session protocol sipv2
 session target ipv4:10.255.255.5
 session transport udp
 incoming called-number xxx
 dtmf-relay rtp-nte
 codec g711ulaw
 ip qos dscp af41 signaling
!
dial-peer voice 2014 voip
 description PMO Backup Line
 session protocol sipv2
 session target ipv4:10.255.255.5
 session transport udp
 incoming called-number xxx
 dtmf-relay rtp-nte
 codec g711ulaw
 ip qos dscp af41 signaling
!
dial-peer voice 5001 voip
 description MWI dial-peer
 session protocol sipv2
 session target ipv4:172.20.10.2
 session transport udp
 incoming called-number 800[01]...
 dtmf-relay rtp-nte
 codec g711ulaw
!
!
presence
 presence call-list
!
!
!
telephony-service
 sdspfarm units 2
 sdspfarm transcode sessions 6
 sdspfarm tag 1 confdsp
 sdspfarm tag 2 xcodedsp
 authentication credential administrator xxx
 em logout 0:0 0:0 0:0 
 codec g722-64
 max-ephones 58
 max-dn 192
 ip source-address 172.20.10.1 port 2000
 max-redirect 20
 service phone g722CodecSupport 2
 service dnis overlay
 service dnis dir-lookup
 timeouts interdigit 15
 system message Xxx
 url services http://172.20.10.2/voiceview/common/login.do 
 url authentication http://172.20.10.1/CCMCIP/authenticate.asp  
 load 7916-12 B016-1-0-3
 load 7916-24 B016-1-0-3
 load 7937 apps37sccp.1-3-2-0
 load 7945 SCCP45.8-4-2S
 load 7965 SCCP45.8-4-2S
 load 7975 SCCP75.8-4-2S
 time-zone 12
 voicemail 500
 max-conferences 8 gain -6
 moh music-on-hold.au
 web admin system name admin secret 5 $1$dc7X$/j0/k3ELp0QNeI7U5Vl2B0
 dn-webedit 
 time-webedit 
 transfer-system full-consult
 transfer-pattern 9T
 secondary-dialtone 9
 after-hours pstn-prefix 4 1
 night-service code *1111
 night-service weekday 17:30 08:30

 create cnf-files version-stamp 7960 Sep 13 2010 08:50:39
!
!
ephone-template  1
 conference drop-mode local
 conference add-mode creator
 softkeys hold  Newcall Resume Select Join
 softkeys idle  Redial Cfwdall Dnd Pickup Gpickup
 softkeys seized  Redial Cfwdall Endcall Gpickup Meetme Pickup
 softkeys connected  Hold Trnsfer Confrn Endcall TrnsfVM Park ConfList Select Join
!
!
ephone-dn  1
 number 8000...
 mwi on
!
!
ephone-dn  2
 number 8001...
 mwi off
!
!


!
ephone-dn  31  dual-line
 number 311 no-reg primary
 label User 1
 description 311
 name User 1
 call-forward busy 500
 call-forward noan 500 timeout 20
!
!

!
ephone-dn  90
 number 301 no-reg primary
 pickup-group 575
 label user 2
 description user 2
 name user 2
 call-forward busy 500
 call-forward noan 500 timeout 20
 hold-alert 30 originator
!
!
ephone-dn  91
 number *301 no-reg primary
 label Intercom
 name user 2
 intercom *301 no-mute label "Intercom"
!
!
0
!
ephone-dn  131
 number *311 no-reg primary
 label Intercom
 name user 1
 intercom * no-mute
!
!

!

!
!
ephone  21
 device-security-mode none
 mac-address 0026.9944.25CF
 ephone-template 1
 username "user2"
 codec g722-64
 type 7962
 button  1:90 2:100 3m23 4m24
 button  5m30 6:91
!
!
!

!
!
ephone  31
 device-security-mode none
 description user 1
 mac-address 0027.0D3E.CAB7
 ephone-template 1
 username "user 1" password 
 codec g722-64
 type 7975
 button  1:31 2:131 3m23 4m24
 button  5m90
!
!
!

line con 0
line aux 0
line 194
 no activation-character
 no exec
 transport preferred none
 transport input all
 transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
line vty 0 4
 privilege level 15
 transport input telnet
line vty 5 15
 privilege level 15
 transport input ssh
!
scheduler allocate 20000 1000
ntp update-calendar
ntp server 192.168.1.5
end

rtr-but-tower-2821# exit
0
 
LVL 5

Expert Comment

by:Yohei0815
ID: 37752052
well,
i dont know your whole infrastructure. but i see that ephone21,31 have only g722 enabled.
But in your global config under dspfarm i see no transcoding rule for that codec. Make a call between the two phones and provide a trace. Sip and RTP should be included if possible.
Best would be a working case and a non-working case. Wading through your config only brings  forth guesswork.
0
 
LVL 1

Author Comment

by:David_Blumberg
ID: 37752180
What is the best way to do a trace if we dont have sniffer pro?
0
 
LVL 20

Expert Comment

by:José Méndez
ID: 37752188
debug ccsip messages
0
IT, Stop Being Called Into Every Meeting

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

 
LVL 1

Author Comment

by:David_Blumberg
ID: 37752887
When enabled the debug ccsip messages did not show anything
0
 
LVL 20

Expert Comment

by:José Méndez
ID: 37753400
add <term mon> if you are telneting or sshing into the device
0
 
LVL 1

Author Comment

by:David_Blumberg
ID: 37753616
enclosed, thank you
cisco.log
0
 
LVL 20

Expert Comment

by:José Méndez
ID: 37753873
The call connects and then is disconnected by one of the phoens:

BYE sip:352xxxxxxx@10.255.255.5:5060;transport=udp SIP/2.0Reason: Q.850;cause=16Date: Thu, 22 Mar 2012 16:40:03 GMTFrom: <sip:352xxxxxxx@10.1.0.1:5060>;tag=65720DCC-1B0BTimestamp: 1332434450Content-Length: 0User-Agent: Cisco-SIPGateway/IOS-12.xTo: "xxx" <sip:352xxxxxxx@10.255.255.5>;tag=10479656Call-ID: 1308986430-53296434@SIPVia: SIP/2.0/UDP 10.1.0.1:5060;branch=z9hG4bK1872C58CSeq: 101 BYEMax-Forwards: 70

Reviewing cause 16 reveals that

Indicates that the call is being cleared because one of the users involved with the call has requested that the call be cleared.

http://www.cisco.com/en/US/docs/ios/12_3/vvf_c/voice_troubleshooting/old/vts_appa.html#wp1007443

Why don't you try a firmware upgrade?
0
 
LVL 1

Author Comment

by:David_Blumberg
ID: 37753915
The call was cleared because you could not hear anything, user1 calling anyone but user2 hears fine and vice versa.
0
 
LVL 5

Accepted Solution

by:
Yohei0815 earned 500 total points
ID: 37753931
so one way audio right ?
Then its probably a firewall issue with closed RTP ports.
0
 
LVL 1

Author Comment

by:David_Blumberg
ID: 37753932
Could it from this:

rtr-but-tower-2821#
Mar 22 16:41:48.006: %SEC-6-IPACCESSLOGP: list 199 denied tcp 94.245.127.15(55132) -> xxx.xxx.xxx.xxx(46099), 2 packets  
Mar 22 16:42:48.008: %SEC-6-IPACCESSLOGP: list 199 denied tcp 94.245.127.15(27464) -> xxx.xxx.xxx.xxx(46099), 2 packets  
rtr-but-tower-2821#exit

That is causing the issues, here is access-list config

access-list 199 permit esp any any
access-list 199 permit udp any host "router ip address" eq isakmp
access-list 199 permit udp any host "router ip address" eq non500-isakmp
access-list 199 permit tcp any host "router ip address" eq 22
access-list 199 permit tcp any host "router ip address" eq telnet
access-list 199 permit tcp any host "router ip address" eq 8080
access-list 199 permit tcp any host "router ip address" ack
access-list 199 permit tcp any host "router ip address" established
access-list 199 permit udp any eq domain host "router ip address"
access-list 199 permit tcp any host "email server ip address" eq smtp
access-list 199 permit tcp any host "email server ip address" eq 3389
access-list 199 permit tcp any host "email server ip address" eq 443
access-list 199 permit tcp any host "email server ip address" eq 143

access-list 199 permit icmp any any
access-list 199 deny   ip any any log
!
0
 
LVL 1

Author Comment

by:David_Blumberg
ID: 37753937
Yohei0815:  both of these phones are on the same switch on the internal network and all other phones work as well.
0

Featured Post

How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

Join & Write a Comment

Suggested Solutions

The point of this post is to give you a copy/paste installation solution to setting up Asterisk 1.6 on Ubuntu 9.04 (or similar) server. # Setup the system apt-get install subversion apt-get install make apt-get install linux-source kernel-p…
Hey there Heard about jingle, the add on for XMPP that enables point to point audio between two XMPP clients. No server config necessary. Actually quite a cool feature. However, how good is it if you can not use those voice capabilities to do a P…
In this seventh video of the Xpdf series, we discuss and demonstrate the PDFfonts utility, which lists all the fonts used in a PDF file. It does this via a command line interface, making it suitable for use in programs, scripts, batch files — any pl…
Polish reports in Access so they look terrific. Take yourself to another level. Equations, Back Color, Alternate Back Color. Write easy VBA Code. Tighten space to use less pages. Launch report from a menu, considering criteria only when it is filled…

744 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

12 Experts available now in Live!

Get 1:1 Help Now