Windows 2008 R2 Moving Virtual memory

Hi,

I have tried to move pagefile.sys from C to D but for some reason it just stays in C...

In Virtual Memory settings, I performed the following steps:

- unchecked "Automatically manage paging file..."
- selected C then "No paging file"
- clicked on SET

- then selected D
- selected "System Managed Size"
- Click on SET.

I was prompted to reboot the server, server rebooted. I now see two paging files, one is C for 34 gig and one in D.

Why the paging file is not removed from C and how can I remove it from C? or is there a way to reduce the size to its original size.

The paging file just increased to 34 gig when I initially had an issue with a software that was causing memory leak. So since the software was using all the memory, windows increased the size of pagefile.sys, the software was fixed so I got lots of RAM available now. Shouldn't windows now reduce the size?

Thanks
ezzadinAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Lee W, MVPTechnology and Business Process AdvisorCommented:
Go to the Virtual Memory configuration screen and select C: so that it's highlighted.  Click on the radio button for "No paging file" and click the set button.  If you don't see this, please post a screen shot using the attach file feature here.
0
ezzadinAuthor Commented:
Hi,

Thanks, but as you can see I already mention that in my post. I have done that but the paging file is still in C.
0
PaulNSWCommented:
if it still says that C has no paging file, try deleting it manually

If it's really not in use, you will be able to delete it
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Creating Active Directory Users from a Text File

If your organization has a need to mass-create AD user accounts, watch this video to see how its done without the need for scripting or other unnecessary complexities.

ezzadinAuthor Commented:
Hi Paul,

I never tried to deleted it since there is a little lock on the file. So I'm assuming it is locked and Windows won't allow me to delete it.

I will give that a try.

Thanks.
0
CarlosDominguezCommented:
- uncheck "Automatically manage paging file..."

- first select D
- select "Custom size"
- specify size of pagefile based on the amount of physical memory (x2 is a good rule).
- Click on SET.

- select C
- select "No paging file"
- click on SET.

Restart.
If you see the pagefile.sys file in C: and you also see the pagefile.sys file in D: with the size specified, and you see these options set in the virtual memory configuration, then it seems like you can try to manually delete the C:\pagefile.sys
0
ezzadinAuthor Commented:
It deleted the file manually and that worked.

Thanks for your help.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2008

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.