InstallShield: Update DLLs with the same version numbers

Hi All,

I have a Quick patch to update installation system files and cannot force it to overwrite existing DLLs with the same versions, even if the Overwrite Any Existing Files checkbox checked.

How could I do it? We have several 3rd party DLLs with the same version numbers and need to select a right one for some installation updates.

Please help.

Thanks
orgrau9Asked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

lisfolksCommented:
What version of InstallShield are you using?
0
orgrau9Author Commented:
2010
0
lisfolksCommented:
Have you tried putting a letter 'a' in the REINSTALLMODE value? That is supposed to make InstallShield ignore its normal versioning rules.

Make sure you check out this information as well in order to avoid it asking for a prior setup CD:
Preventing a Patch from Requiring Access to the Original Installation Source
0
orgrau9Author Commented:
Where is that setting in Quick Patch of Installshield 2010? I think it is not applicable as was replaced by Overwrite Any Existing Files checlbox.
0
lisfolksCommented:
It is a command line option. Take a look at this (for InstallShield Express 2010) -
Applying a QuickPatch

The Overwrite Any Existing Files checkbox is supposed to allow overwriting only specific files, whereas the REINSTALLMODE property makes everything overwrite - so if that's not what you want, this wouldn't be good anyway. However, either way, it looks like a lot of people are having similar issues (not that this is very helpful, but at least you know, if you didn't before, that you're not alone ;)

Oh, yeah, you would need to add a letter 'a' to the default 'omus' value to make it do the overwrite.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Installation

From novice to tech pro — start learning today.