Disable Advanced filter option in Excel

I protect the Excel by hide some rows using protecting worksheet function.

However it was found when the user select "Advanced Filter" function, they can unhide all rows in the worksheet

any ways to prevent this?? Help...pls
hkgalAsked:
Who is Participating?
 
David_HagermanConnect With a Mentor Commented:
Poor form to cancel the request when you haven't solved the problem as per your comment " but when another user open it, still appear "Advanced Filter". "

Here is an article that steps it out.
http://www.accountingweb.co.uk/anyanswers/excel-prevent-hidden-columns-being-seen 

Also I have tried this on Excel 2003 between two machine and users can not un-hide the hidden sheet.
0
 
David_HagermanCommented:
0
 
hkgalAuthor Commented:
it's already password protected....but users can still select the choice "advanced filter"....
0
Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
David_HagermanCommented:
When you selected protection did you de-select the options below

Select Locked Cells
Select unlocked cells

Also what version office are you using as i have tested this in office 2010
0
 
hkgalAuthor Commented:
office 2003

I try this command on workbook_open():

Application.CommandBars("Data").Controls("Filter").Controls("Advanced Filter...").Enabled = False

but when another user open it, still appear "Advanced Filter"...
0
 
hkgalAuthor Commented:
I've requested that this question be deleted for the following reason:

I have solved by my own
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.