SBS 2011 RDP Certificate Subject Error

Just finished migrating an SBS 2003 to SBS 2011.  When remote users access Remote Desktop through RWA they get the following error:
Your computer can't connect to the remote computer because the remote desktop gateway server address requested and the certificate subject name do not match.

We are using a self-issued certificate.  The access url is mail1.(companyweb).org/remote and the certificate subject line shows remote.(companyweb).org/remote.  This worked on the SBS 2003 but not after the migration.
chapton_computer_servicesAsked:
Who is Participating?
 
Cliff GaliherCommented:
SBS 2008 and SBS 2011 use the RDGateway service to provide the remote desktop magic for RWA. one security item of RDGateway that SBS 2003 didn't have is that the certificate name MUST match the URL use to access RWA. The URL is defined when you run the "Internet Address Wizard" from the SBS console. It will default to remote.<some-company>.com, but if you choose the "advanced" option (available partway through e wizard) you can then change the leading remote.* to mail1.* and will will be right in your world again. But is does mean you will have to re-run the wizard.

-Cliff
0
 
chapton_computer_servicesAuthor Commented:
Worked as promised.  Thank you Cliff!
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.