Solved

Excel Formula Returning #VALUE "=RIGHT(1952,1)"

Posted on 2012-03-22
8
238 Views
Last Modified: 2012-03-22
"=RIGHT(1952,1)"

Works in a new workbook...but in my existing workbook it displays #VALUE...

Not sure what could be causing this.  Some setting?

Thanks.
0
Comment
Question by:Tonicacent
  • 4
  • 3
8 Comments
 
LVL 70

Expert Comment

by:KCTS
ID: 37753671
RIGHT is use to take the rightmost part of a string, since 1952 is a number you are getting this error.

=RIGHT("1952",1) would work and return a "2" in this case - is that what you want ?
0
 

Author Comment

by:Tonicacent
ID: 37753737
Thanks that does work.  I was just confused because it works fine without quotations in other 97-2003 xls workbooks....anyone no more headache.  Thanks.
0
 

Author Comment

by:Tonicacent
ID: 37753769
now I have a problem with this formula...

=RIGHT(YEAR(AB33),2)

AB33 = 04/10/1952

returns #VALUE

This is just so frustrating, because this works just fine in any other workbook....im going to have to copy everything over to a new workbook.
0
Netscaler Common Configuration How To guides

If you use NetScaler you will want to see these guides. The NetScaler How To Guides show administrators how to get NetScaler up and configured by providing instructions for common scenarios and some not so common ones.

 
LVL 81

Expert Comment

by:byundt
ID: 37753826
Your formula is working in my copy of Excel 2010, both when AB33 contains text that looks like a date and also when it contains a date formatted as mm/dd/yyyy

Is the calculation mode in your workbook set to Manual (see File...Options...Formulas menu item)?

Does your default date format put the day before the month?  dd/mm/yyyy

If you could post a workbook that illustrates the problem, it would be very helpful in trying to resolve the issue.
0
 

Author Comment

by:Tonicacent
ID: 37753880
Here is the file im working in...removed all data except the part im struggling with.
NewComp-Template-test.xls
0
 
LVL 81

Accepted Solution

by:
byundt earned 365 total points
ID: 37753943
In File...Options...Advanced menu item, go to the very bottom of the right pane and uncheck the option for Transition formula evaluation
0
 

Author Comment

by:Tonicacent
ID: 37753961
nice.  Thank you byundt
0
 
LVL 81

Expert Comment

by:byundt
ID: 37753984
It's a good thing you were able to post a sample workbook--I'd have never figured it out otherwise.

Brad
0

Featured Post

Efficient way to get backups off site to Azure

This user guide provides instructions on how to deploy and configure both a StoneFly Scale Out NAS Enterprise Cloud Drive virtual machine and Veeam Cloud Connect in the Microsoft Azure Cloud.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Which version of Microsoft Project does my client need? 3 114
Oart.dll 2 54
How to choose which Outlook 2013 calender will receive an event? 1 34
MS office 2010 activation 4 42
PaperPort has a feature called the "Send To Bar". It provides a convenient, drag-and-drop interface for using other installed software, such as Microsoft Office. However, this article shows that the latest Office 2016 apps (installed with an Office …
This article will show you how to use shortcut menus in the Access run-time environment.
The viewer will learn how to use a discrete random variable to simulate the return on an investment over a period of years, create a Monte Carlo simulation using the discrete random variable, and create a graph to represent the possible returns over…
The viewer will learn how to  create a slide that will launch other presentations in Microsoft PowerPoint. In the finished slide, each item launches a new PowerPoint presentation and when each is finished it automatically comes back to this slide: …

823 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question