?
Solved

Cannot connect via RDP to windows server 2008 R2 Enterprise SP1

Posted on 2012-03-22
6
Medium Priority
?
906 Views
Last Modified: 2012-03-27
I cannot connect to server 2008 via RDP from other machines. Windows firewall is off. Also check inbound rules and added allow remote desktop 3389

I get this error when I try to connect “The client could not connect to the remote computer. Remote Connections might not be enabled or the computer might be too busy to accept connections.”

Please advise. Thanks
0
Comment
Question by:tech2010
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
6 Comments
 
LVL 37

Expert Comment

by:Neil Russell
ID: 37753413
Did you ENABLED remote desktop on the server? By default it is disabled on 2008 R2.
0
 
LVL 37

Expert Comment

by:Neil Russell
ID: 37753425
Open server manager and look at Remote Desktop: setting.
0
 

Expert Comment

by:pulantai
ID: 37753427
Hi there, perhaps network firewall is blocking the RDP port?
Can you run TELNET from your client to the server?
Example --> telnet <server 2008 IP> <port number>
Sample --> telnet 192.168.10.5 3389

Hope this helps

EDIT - Please ensure remote dekstop services in the server 2008 is enable in the first place :)
0
Use Case: Protecting a Hybrid Cloud Infrastructure

Microsoft Azure is rapidly becoming the norm in dynamic IT environments. This document describes the challenges that organizations face when protecting data in a hybrid cloud IT environment and presents a use case to demonstrate how Acronis Backup protects all data.

 
LVL 1

Expert Comment

by:jdbreding
ID: 37753509
I agree with Neilsr.  To verify, click start, right click on Computer, left click properties, on left side, click on remote settings.  By default, Don't allow connections to this computer is selected.  To allow connections, you must choose one of the other two available options.
0
 

Accepted Solution

by:
tech2010 earned 0 total points
ID: 37753549
Guys, remote desktop on the server is already enabled.

But I now have resolved it, remote desktop service was disabled :) so started the service and worked fine. thanks anyway.
0
 

Author Closing Comment

by:tech2010
ID: 37770416
fixed from my investigation.
0

Featured Post

On Demand Webinar: Networking for the Cloud Era

Did you know SD-WANs can improve network connectivity? Check out this webinar to learn how an SD-WAN simplified, one-click tool can help you migrate and manage data in the cloud.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Always backup Domain, SYSVOL etc.using processes according to Microsoft Best Practices. This is meant as a disaster recovery process for small environments that did not implement backup processes and did not run a secondary domain controller that ne…
For anyone that has accidentally used newSID with Server 2008 R2 (like I did) and hasn't been able to get the server running again because you were unlucky (as I was) and had no backups - I was able to get things working by doing a Registry Hive rec…
This tutorial will walk an individual through the process of transferring the five major, necessary Active Directory Roles, commonly referred to as the FSMO roles to another domain controller. Log onto the new domain controller with a user account t…
Sometimes it takes a new vantage point, apart from our everyday security practices, to truly see our Active Directory (AD) vulnerabilities. We get used to implementing the same techniques and checking the same areas for a breach. This pattern can re…
Suggested Courses

764 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question