Solved

Linux SSH not working

Posted on 2012-03-22
5
482 Views
Last Modified: 2012-03-22
Hi all,

I had ssh working, but it seems to have stopped.  I restarted the service and that is running.  DOes someone know how to install another ssh client or maybe what I should check for?

I believe this occured after I installed vsftpd

Thanks
0
Comment
Question by:Jack_son_
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 2
5 Comments
 
LVL 31

Expert Comment

by:farzanj
ID: 37753985
Which Linux distribution are you using?  Version?

If ssh stopped, it has to do with ssh server not client.  It doesn't have anything to do with vsftpd as well so I am a little confused to as what you are actually trying to do.

If it is a problem of service not starting by itself after rebooting, the solution should be simple enough but is distribution dependent.

Redhat familly command would be
chkconfig sshd on

Ubuntu family
update-rc.d sshd defaults
0
 

Author Comment

by:Jack_son_
ID: 37754588
Debian, newest release, I thing its 6.03;  I did reboot and that didnt work either.....

the service is starting but for some reason i cant access the server from ssh any longer.   are there any logs to show where the issue may be?
0
 
LVL 31

Accepted Solution

by:
farzanj earned 500 total points
ID: 37754694
I did not tell you to reboot.  I said it appears that sshd doesn't start after reboot.

Issue command to check
netstat -antpu | grep 22

See if there are any sshd daemons listening

Issue command
Ubuntu family
update-rc.d sshd defaults

And reboot again to see if it works after reboot
0
 

Author Comment

by:Jack_son_
ID: 37754850
I did run this command and it is not listening on these ports; here is the error when trying to start the service:  sshd/var/run/sshd must be owned by root and nt group or world writable
0
 

Author Closing Comment

by:Jack_son_
ID: 37754935
Hi Farzanj-

with the help above I found it was a permission issue.  So this helped me find the issue.  I then applied these commands to fix the permissions:

chown root:root /var/empty/sshd
chmod 711 /var/empty/sshd
/etc/init.d/sshd start
0

Featured Post

Secure Your WordPress Site: 5 Essential Approaches

WordPress is the web's most popular CMS, but its dominance also makes it a target for attackers. Our eBook will show you how to:

Prevent costly exploits of core and plugin vulnerabilities
Repel automated attacks
Lock down your dashboard, secure your code, and protect your users

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Over the last ten+ years I have seen Linux configuration tools come and go. In the early days there was the tried-and-true, all-powerful linuxconf that many thought would remain the one and only Linux configuration tool until the end of times. Well,…
I. Introduction There's an interesting discussion going on now in an Experts Exchange Group — Attachments with no extension (http://www.experts-exchange.com/discussions/210281/Attachments-with-no-extension.html). This reminded me of questions tha…
Learn several ways to interact with files and get file information from the bash shell. ls lists the contents of a directory: Using the -a flag displays hidden files: Using the -l flag formats the output in a long list: The file command gives us mor…
Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.
Suggested Courses

623 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question