Issues with SBS2003 and default app pool

Hi Guys,
Our main sbs2003 server crashed and we had to recover from a backup image (vmware vmdk) file. The server seems to be running fine except that the default app pool keeps crashing/stopping and I cannot get OWA and RWW to work. The only other change I made was uninstalling symantec backup exec to free up space. Also- the wsus app pool is also not functioning. Attached is the error message that keeps coming up in the application event logs.
I even tried creating a new app pool and migrating the remote website (which is the most critical) but that app pool stops working as well
williamstechnologygroupOwnerAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

williamstechnologygroupOwnerAuthor Commented:
not sure if the file attached will try again
iis-error.txt
williamstechnologygroupOwnerAuthor Commented:
will this help or hurt??





Re: Installed VS2010, ASP.NET Apps fail to run

May 02, 2010 04:09 AM|LINK


Try reregistering with iis from the command prompt. This file located on the windows/Microsoft .NET/
 

aspnet_regiis -r
PaulD77Commented:
This sounds like something is up with your ISAPI filters.  Try these 2 steps...

To perform a test browse by using IIS Manager:

1.Click Start, click Control Panel, and then click Administrative Tools.
2.Right-click Internet Information Services (IIS) Manager and select Run as administrator.
3.In the Connections pane, expand the computer name.
4.Expand Sites.
5.Select the Web site or application that is using the ISAPI filter that you want to verify.
6.In the Actions pane, click the link under Browse. If the Web page appears, the ISAPI filter is functional.

Verify that an application pool worker process is running for a Web site or application

To verify that an application pool worker process is running:

1.Click Start, click Control Panel, and then click Administrative Tools.
2.Right-click Internet Information Services (IIS) Manager and select Run as administrator.
3.In the Connections pane, select the computer name.
4.In Features View, under the Feature Name column heading, double-click the Worker Processes management feature. A list of currently active application pools and worker processes will appear.
5.Examine the application pool corresponding to the Web site or application that uses the ISAPI filter. The State column for the worker process will indicate Running if the worker process is running.
Protecting & Securing Your Critical Data

Considering 93 percent of companies file for bankruptcy within 12 months of a disaster that blocked access to their data for 10 days or more, planning for the worst is just smart business. Learn how Acronis Backup integrates security at every stage

williamstechnologygroupOwnerAuthor Commented:
I am using SBS2003 which contains IIS6.0 The second step does not sound like version 6, attached is a screenshot of my IIS status of the app pools
I did try to browse from step one and get a screen that say "service unavailable"
iis-screen-shot.pdf
PaulD77Commented:
williamstechnologygroupOwnerAuthor Commented:
not sure how this is going to help me. but i believe this is the worker process
W3SVC-WP
PaulD77Commented:
Was hoping you can see if any process was running.  Let me ask, did you check the built in IIS security group and make sure the proper info is in there?
williamstechnologygroupOwnerAuthor Commented:
I tried to run aspnet_regiis -r and received the following error- This application has failed to start because MSVCR1---CLR0400.dll was not found. reinstaling the application may fix this problem
should i reinstall .net framework 4.0 on my sbs server??
williamstechnologygroupOwnerAuthor Commented:
yes- security is fine..
PaulD77Commented:
yes, did you recover .net or fresh install after recovery? either way, try a fesh install
williamstechnologygroupOwnerAuthor Commented:
i did have some problems with Quickbooks 2012 as well and had to uninstall- not sure if the .net used in the qbooks 2012 db manager had anything to do with it???
williamstechnologygroupOwnerAuthor Commented:
when you say fresh install, do i go to add remove programs and uninstall or is it ok to just install over the top??
PaulD77Commented:
to be safe i would complete uninstall it and do a fresh install, .net should find all your applications that rely on it during the install, keep in mind any other hosted apps will go down too if people are working on them

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
williamstechnologygroupOwnerAuthor Commented:
Thanks- I finally researched and found a .net framework cleanup utility which removed the .net4.0- I then reinstalled and everything is working again.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
SBS

From novice to tech pro — start learning today.