?
Solved

Issue with OWA and Outlook 2007 on new 2010 Exchange

Posted on 2012-03-22
8
Medium Priority
?
1,695 Views
Last Modified: 2012-03-23
I'm having issue with Outlook 2007, it asks for credentials when stated.
 
This doesn’t affect Outlook 2003 and 2010 users.
On the OWA side, when going into anything under “Options” like shown in the picture. It pops a new page and prompts for credentials.  After credentials are supplied, I’m having “bad request” error. I also tried resetting IE. In this case it will not prompt me for credentials for the first time and load the page but clicking on anything within the page will pop the error: “The session has expired. Please sign in and try again”.
 
I’m running Exchange 2010, which was migrated from 2003 about 1 month ago.
I did reset EWS directory using EMS followed by iisreset/noforce and also tried to enable Anonymous Authentication on EWS without positive result. I have valid SAN certificate from Digicert which covers both internal and external FQDN. Auto-discover works fine. Tested using "Test E-mail AutoConfiguration" feature in Outlook.
 

 
Any advice will be greatly appreciated.
 
Thank you

PomaH
owa-options.jpg
0
Comment
Question by:pomah1
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 4
8 Comments
 
LVL 9

Expert Comment

by:Dan Arseneau
ID: 37754097
Sounds a like Autodiscover.  Outlook 2003 doesn't use it, Outlook 2010 is more forgiving.
0
 
LVL 1

Author Comment

by:pomah1
ID: 37754129
Test E-mail Autoconfiguration Log:
SNTP=user@company.com
Attempting URL https://mail1.company.internal/autodiscover/autodiscover.xml found throug SCP
Autodiscover to https://mail1.company.internal/autodiscover/autodiscover.xml starting
GetLastError=12044; httpStatus=0
GetLastError=12015; httpStatus=401
GetLastError=0 httpStatus=401
GetLastError=0 httpStatus=200
Autodicover to https://mail1.company.internal/autodiscover/autodiscover.xml succeeded (0x00000000)
0
 
LVL 9

Expert Comment

by:Dan Arseneau
ID: 37754175
Make sure IIS is set to ignore Client Certificates.
0
Enterprise Mobility and BYOD For Dummies

Like “For Dummies” books, you can read this in whatever order you choose and learn about mobility and BYOD; and how to put a competitive mobile infrastructure in place. Developed for SMBs and large enterprises alike, you will find helpful use cases, planning, and implementation.

 
LVL 1

Author Comment

by:pomah1
ID: 37754244
Will this affect OWA in any way?
0
 
LVL 9

Expert Comment

by:Dan Arseneau
ID: 37754260
No.  By default, the setting should be "Ignore".
0
 
LVL 1

Author Comment

by:pomah1
ID: 37754275
I have set to "accept"
Is this needs to be done for"default website" or any particular vDir?
0
 
LVL 9

Accepted Solution

by:
Dan Arseneau earned 1500 total points
ID: 37754290
You shouldn't have any issues setting it to ignore for the entire site unless there is some other component on the Exchange server that set it.  Then a iisreset /noforce will be in order.

Edit: Please check the RpcWithCert site.  It should be set to Required but that's it.
0
 
LVL 1

Author Comment

by:pomah1
ID: 37759201
Thank you,

that took care of Outlook 2007 prompts for credentials. But issue with OWA where Options page wouldn't load still exists.



Pomah
0

Featured Post

What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

A list of top three free exchange EDB viewers that helps the user to extract a mailbox from an unmounted .edb file and get a clear preview of all emails & other items with just a single click on mailboxes.
This article will help to fix the below errors for MS Exchange Server 2013 I. Certificate error "name on the security certificate is invalid or does not match the name of the site" II. Out of Office not working III. Make Internal URLs and Externa…
To show how to generate a certificate request in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.:  First we need to log into the Exchange Admin Center. Navigate to the Servers >> Certificates…
how to add IIS SMTP to handle application/Scanner relays into office 365.
Suggested Courses
Course of the Month14 days, 16 hours left to enroll

770 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question