RPC over HTTP configuration issues

I am trying to setup RPC over HTTP on my Exchange 2003 (single server setup)
I have followed the instructions from http://www.petri.co.il/how-can-i-configure-rpc-over-https-on-exchange-2003-single-server-scenario.htm.

When I run the test https://www.testexchangeconnectivity.com
I get to the point when it tries to ping 6001 Attempting to ping RPC endpoint 6001 (Exchange Information Store) on server exchange01.contoso.local.
  The attempt to ping the endpoint failed.
I allowed for port 6001-6002, 6004 to route the traffic to my exchange server.


Any ideas?
LVL 27
yo_beeDirector of Information TechnologyAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Dan ArseneauDevOps EngineerCommented:
Double check to make sure you installed the services.  Add/Remove Programs - Networking Services - RPC over HTTP Proxy.
0
R--RCommented:
Check this from EE

http://www.experts-exchange.com/Software/Server_Software/Email_Servers/Exchange/Q_27040316.html

Did you used RPCnofrontend utility given in petri article?

Check 443 is opened and external URL is mached to the URL in IIS.

Also try tto configure outlook and check.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
czteckCommented:
If you go the peti page  under the section titled "Configure the RPC proxy server to use specific ports"  like halfway down the page you'll see a link for

 "RPCNoFrontEnd"

  It's a little exe that sets all the registry entries for you.  I found that the hardest part to do this was setting the proper external name.  Whatever you use to access from the Internet.

Once that is done make sure you have your certificate.  If it's a valid one, great nothing else needs to be done.  If you decide to go with a self signed one.  you'll have to put it in the trusted root authority on all the machines you wish to run Outlook over the internet (Outlook Anywhere)
0
yo_beeDirector of Information TechnologyAuthor Commented:
To all that have replied:

1: RPC over HTTP has been enabled:

2: My SSL cert is valid one from Verisign and it has been working with my Active Sync fine and the IIS URL does not match my external URL

3: I manually created the ValidPorts:
exchange01:6001-6002;exchange01.contoso.local:6004;Webmail.contoso.com:6001-6002;Webmail.contoso.com:6004
0
yo_beeDirector of Information TechnologyAuthor Commented:
Here was my first mistake.
3: I manually created the ValidPorts:
exchange01:6001-6002;exchange01.contoso.local:6004;Webmail.contoso.com:6001-6002;Webmail.contoso.com:6004

I ran the tool and then reran the online test saw that it was failing at the NSPI part.
So it was a two deal issue.
It turned out that the Service\NDTS\   value {ncacn_http:6004} was never created.
Once I created this key everything started to work smoothly.

I am not sure why I never implimented this prior.

Thanks all
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.