Solved

Cannot Change Resolution In BackTrack 5 R2 x64

Posted on 2012-03-22
15
3,772 Views
Last Modified: 2012-04-17
Hello All -

I just installed BackTrack 5 R2 x64 Gnome alongside Windows 7 x64 on my laptop.  I've used many linux distros before, but it's been a while since I've used BackTrack.  I found that it is built on Ubuntu now, though.

Anyways, I start the GUI mode (startx) and get to the desktop.  The resolution is in 1024x768.  When I go to Monitors to change it, 1024 is my only option.  I believe this is because it also lists my monitor as being "Unknown".

My laptop is a Samsung Series 9 NP900X3A and I'm using the built in Intel HD video (3000?).  It's standard resolution is 1366x786.

What I've tried so far to resolve issue...
- Tried changing it via Monitors in GUI - only 1 resolution listed
- Installed & ran "Hardware Drivers" package - said i wasn't using any proprietary drivers
- Used pico to edit /etc/X11/xorg.conf and set all 4 resolutions to 1366x786.  I logged off then back in.  Still, 1024 was my only option. :(
- Updated, then upgraded all packages - nogo

Any ideas?  Thanks!
0
Comment
Question by:BzowK
  • 8
  • 7
15 Comments
 
LVL 87

Expert Comment

by:rindi
Comment Utility
In a Terminal use gtf together with your needed resolution and refresh rate to get the correct parameters for that resolution. Then use xrandr --newmode to add those parameters to the new resolution. After that use xrandr --addmode  to add that mode to your diplay output. Once that is done you should be able to use the proper resolution. If that works it may help to add those commands to a script which you would then run after you have loaded the GUI.
0
 

Author Comment

by:BzowK
Comment Utility
Thanks -

I did some searching for more details, but am stuck at a point.

Here's where I'm at (not very far :))...
- Opened new terminal
- Ran gtf 1366 786 60
- For the xrandr line, I started with xrandr --newmode, but that's where I got lost.  I used this link among others to try to figure it out.  

The sample it gave for the command was...
root@bt:-# xrandr --newmode "1440x900_59.90"  106.29  1440 1520 1672 1904  900 901 904 932  -HSync +Vsync I understand it all until the 106.29 comes in.  

Given that I'm wanting 1366x786 and the display is a standard laptop LCD, could you hint at what I should specifically use?

Thanks!
0
 
LVL 87

Expert Comment

by:rindi
Comment Utility
What output do you get when you run the gtf command?
0
 

Author Comment

by:BzowK
Comment Utility
Nothing - just another prompt...
0
 
LVL 87

Expert Comment

by:rindi
Comment Utility
You mean when you run

gtf 1366 786 60

nothing output?

Normally you should get all those numbers which you posted with your xrandr sample.

Also, what output do you get when you run

xrandr --prop

And, delete the xorg.conf file, that is normally not needed, unless you are using legacy nvidia drivers.
0
 

Author Comment

by:BzowK
Comment Utility
Okay, I was wrong - sorry -

I type gtf 1366 786 60 and get the following return...

 # 1368x786 @ 60.00 Hz (GTF) hsync: 48.84 kHz; pclk: 87.91 MHz
  Modeline "1368x786_60.00"  87.91  1368 1440 1584 1800  786 787 790 814  -HSync +Vsync


When I type xrandr --prop I get...

Screen 0: minimum 1024 x 768, current 1024 x 768, maximum 1024 x 768
default connected 1024x768+0+0 0mm x 0mm
   1024x768        0.0*


Does that help?
0
 
LVL 87

Expert Comment

by:rindi
Comment Utility
The first part yes. Put this into xrandr:

xrandr --newmode "1366x786@60" 87.91  1368 1440 1584 1800  786 787 790 814  -HSync +Vsync

After that you normally have to add that mode to the output used, the problem is I don't know the name of that (usually it is shown when you use xrandr --prop and has a name similar to VGA1 or DVI1 etc). Maybe you'll need to google some more on xrandr if it doesn't work right away.
0
Do You Know the 4 Main Threat Actor Types?

Do you know the main threat actor types? Most attackers fall into one of four categories, each with their own favored tactics, techniques, and procedures.

 

Author Comment

by:BzowK
Comment Utility
okay - just ran the line above you just mentioned, then ran xrandr --prop again.  This time, I got more results.  I attached a screenshot or copy/pasted below...

Screenshot
root@bt:~# xrandr --newmode "1366x786@60" 87.91  1368 1440 1584 1800  786 787 790 814  -HSync +Vsync

root@bt:~# xrandr --prop
Screen 0: minimum 1024 x 768, current 1024 x 768, maximum 1024 x 768
default connected 1024x768+0+0 0mm x 0mm
   1024x768        0.0*
  1366x786@60 (0x120)   87.0MHz
        h: width  1368 start 1440 end 1584 total 1800 skew    0 clock   48.3KHz
        v: height  786 start  787 end  790 total  814           clock   59.4Hz

root@bt:~#
0
 

Author Comment

by:BzowK
Comment Utility
Also... after Googling a bit, I think it's named "default"
0
 

Author Comment

by:BzowK
Comment Utility
Okay, I used the instructions on the link below to try to get xrandr working.

http://www.ubuntugeek.com/how-change-display-resolution-settings-using-xrandr.html

After the step which was supposed to change the resolution, though, I get "xrandr: screen cannot be larger than 1024x768 (desired size 1368x768)"

Below are the steps I took to get to that point:

1. Ran xrandr
Output: Screen 0: minimum 1024 x 768, current 1024 x 768, maximum 1024 x 768
default connected 1024x768+0+0 0mm x 0mm
   1024x768        0.0*

2. Ran cvt 1366 768

3. Ran xrandr --newmode "1368x768_60.00"   85.25  1368 1440 1576 1784  768 771 781 798 -hsync +vsync

4. Ran xrandr --addmode default 1366x768_60.00

5. Ran xrandr --output default --mode 1366x768_60.00

After step 5 was run, was when I got the output "xrandr: screen cannot be larger than 1024x768 (desired size 1368x768)"

I obvioulsy know this screen runs that resolution as it does in Windows.

Any ideas?  Thanks!
0
 
LVL 87

Expert Comment

by:rindi
Comment Utility
I'll try looking at it tomorrow. A Star Wars movie is being shown in a couple of minutes on TV, and being a Star wars junkie I'll be watching that (and will probably fall asleep during the first commercial break...
0
 

Author Comment

by:BzowK
Comment Utility
Hope it's one of the first 3 (as filmed).  Honestly, though, the chronological first three weren't all that bad - kinda enjoyed Episode III.  Hate that Binks thing... :)
0
 
LVL 87

Expert Comment

by:rindi
Comment Utility
It's Episode 6 (that was the 3rd originally), and it is also my favorite. There are so many strange characters in it, and it is also the funniest of them.
0
 
LVL 87

Accepted Solution

by:
rindi earned 500 total points
Comment Utility
It looks like the drivers are wrong. According to a backtrack forum guide you must first add the proper repo to the system:

add-apt-repository ppa:xorg-edgers/ppa

Then run apt-get update
and after that apt-get upgrade

When the updates have been made, reboot and check if your resolution is available.

The Link to the backtrack forum guide is below:

http://www.backtrack-linux.org/forums/showthread.php)t=42763
0
 

Author Comment

by:BzowK
Comment Utility
I'm checking - I'll update you soon.  Thanks
0

Featured Post

How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

Join & Write a Comment

Suggested Solutions

Introduction We as admins face situation where we need to redirect websites to another. This may be required as a part of an upgrade keeping the old URL but website should be served from new URL. This document would brief you on different ways ca…
This article will explain how to establish a SSH connection to Ubuntu through the firewall and using a different port other then 22. I have set up a Ubuntu virtual machine in Virtualbox and I am running a Windows 7 workstation. From the Ubuntu vi…
Learn several ways to interact with files and get file information from the bash shell. ls lists the contents of a directory: Using the -a flag displays hidden files: Using the -l flag formats the output in a long list: The file command gives us mor…
Learn how to get help with Linux/Unix bash shell commands. Use help to read help documents for built in bash shell commands.: Use man to interface with the online reference manuals for shell commands.: Use man to search man pages for unknown command…

763 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

7 Experts available now in Live!

Get 1:1 Help Now