Cannot Change Resolution In BackTrack 5 R2 x64

Hello All -

I just installed BackTrack 5 R2 x64 Gnome alongside Windows 7 x64 on my laptop.  I've used many linux distros before, but it's been a while since I've used BackTrack.  I found that it is built on Ubuntu now, though.

Anyways, I start the GUI mode (startx) and get to the desktop.  The resolution is in 1024x768.  When I go to Monitors to change it, 1024 is my only option.  I believe this is because it also lists my monitor as being "Unknown".

My laptop is a Samsung Series 9 NP900X3A and I'm using the built in Intel HD video (3000?).  It's standard resolution is 1366x786.

What I've tried so far to resolve issue...
- Tried changing it via Monitors in GUI - only 1 resolution listed
- Installed & ran "Hardware Drivers" package - said i wasn't using any proprietary drivers
- Used pico to edit /etc/X11/xorg.conf and set all 4 resolutions to 1366x786.  I logged off then back in.  Still, 1024 was my only option. :(
- Updated, then upgraded all packages - nogo

Any ideas?  Thanks!
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

In a Terminal use gtf together with your needed resolution and refresh rate to get the correct parameters for that resolution. Then use xrandr --newmode to add those parameters to the new resolution. After that use xrandr --addmode  to add that mode to your diplay output. Once that is done you should be able to use the proper resolution. If that works it may help to add those commands to a script which you would then run after you have loaded the GUI.
BzowKAuthor Commented:
Thanks -

I did some searching for more details, but am stuck at a point.

Here's where I'm at (not very far :))...
- Opened new terminal
- Ran gtf 1366 786 60
- For the xrandr line, I started with xrandr --newmode, but that's where I got lost.  I used this link among others to try to figure it out.  

The sample it gave for the command was...
root@bt:-# xrandr --newmode "1440x900_59.90"  106.29  1440 1520 1672 1904  900 901 904 932  -HSync +Vsync I understand it all until the 106.29 comes in.  

Given that I'm wanting 1366x786 and the display is a standard laptop LCD, could you hint at what I should specifically use?

What output do you get when you run the gtf command?
Big Business Goals? Which KPIs Will Help You

The most successful MSPs rely on metrics – known as key performance indicators (KPIs) – for making informed decisions that help their businesses thrive, rather than just survive. This eBook provides an overview of the most important KPIs used by top MSPs.

BzowKAuthor Commented:
Nothing - just another prompt...
You mean when you run

gtf 1366 786 60

nothing output?

Normally you should get all those numbers which you posted with your xrandr sample.

Also, what output do you get when you run

xrandr --prop

And, delete the xorg.conf file, that is normally not needed, unless you are using legacy nvidia drivers.
BzowKAuthor Commented:
Okay, I was wrong - sorry -

I type gtf 1366 786 60 and get the following return...

 # 1368x786 @ 60.00 Hz (GTF) hsync: 48.84 kHz; pclk: 87.91 MHz
  Modeline "1368x786_60.00"  87.91  1368 1440 1584 1800  786 787 790 814  -HSync +Vsync

When I type xrandr --prop I get...

Screen 0: minimum 1024 x 768, current 1024 x 768, maximum 1024 x 768
default connected 1024x768+0+0 0mm x 0mm
   1024x768        0.0*

Does that help?
The first part yes. Put this into xrandr:

xrandr --newmode "1366x786@60" 87.91  1368 1440 1584 1800  786 787 790 814  -HSync +Vsync

After that you normally have to add that mode to the output used, the problem is I don't know the name of that (usually it is shown when you use xrandr --prop and has a name similar to VGA1 or DVI1 etc). Maybe you'll need to google some more on xrandr if it doesn't work right away.
BzowKAuthor Commented:
okay - just ran the line above you just mentioned, then ran xrandr --prop again.  This time, I got more results.  I attached a screenshot or copy/pasted below...

root@bt:~# xrandr --newmode "1366x786@60" 87.91  1368 1440 1584 1800  786 787 790 814  -HSync +Vsync

root@bt:~# xrandr --prop
Screen 0: minimum 1024 x 768, current 1024 x 768, maximum 1024 x 768
default connected 1024x768+0+0 0mm x 0mm
   1024x768        0.0*
  1366x786@60 (0x120)   87.0MHz
        h: width  1368 start 1440 end 1584 total 1800 skew    0 clock   48.3KHz
        v: height  786 start  787 end  790 total  814           clock   59.4Hz

BzowKAuthor Commented:
Also... after Googling a bit, I think it's named "default"
BzowKAuthor Commented:
Okay, I used the instructions on the link below to try to get xrandr working.

After the step which was supposed to change the resolution, though, I get "xrandr: screen cannot be larger than 1024x768 (desired size 1368x768)"

Below are the steps I took to get to that point:

1. Ran xrandr
Output: Screen 0: minimum 1024 x 768, current 1024 x 768, maximum 1024 x 768
default connected 1024x768+0+0 0mm x 0mm
   1024x768        0.0*

2. Ran cvt 1366 768

3. Ran xrandr --newmode "1368x768_60.00"   85.25  1368 1440 1576 1784  768 771 781 798 -hsync +vsync

4. Ran xrandr --addmode default 1366x768_60.00

5. Ran xrandr --output default --mode 1366x768_60.00

After step 5 was run, was when I got the output "xrandr: screen cannot be larger than 1024x768 (desired size 1368x768)"

I obvioulsy know this screen runs that resolution as it does in Windows.

Any ideas?  Thanks!
I'll try looking at it tomorrow. A Star Wars movie is being shown in a couple of minutes on TV, and being a Star wars junkie I'll be watching that (and will probably fall asleep during the first commercial break...
BzowKAuthor Commented:
Hope it's one of the first 3 (as filmed).  Honestly, though, the chronological first three weren't all that bad - kinda enjoyed Episode III.  Hate that Binks thing... :)
It's Episode 6 (that was the 3rd originally), and it is also my favorite. There are so many strange characters in it, and it is also the funniest of them.
It looks like the drivers are wrong. According to a backtrack forum guide you must first add the proper repo to the system:

add-apt-repository ppa:xorg-edgers/ppa

Then run apt-get update
and after that apt-get upgrade

When the updates have been made, reboot and check if your resolution is available.

The Link to the backtrack forum guide is below:

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
BzowKAuthor Commented:
I'm checking - I'll update you soon.  Thanks
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux Distributions

From novice to tech pro — start learning today.