Solved

DHCP, VLANS, and Linksys E4200

Posted on 2012-03-22
8
1,209 Views
Last Modified: 2012-10-22
Hello,
   Here's the setup:
1) Windows Server 2008 R2
2) CIsco 3750-G Switch configured for multicasting on VLAN 200 (192.168.1.0/24)
3) Linksys E4200 at addres 192.168.1.1 running dhcp

The situation is that no wireless clients are receiving DHCP addresses. Do I need to setup something on the port the Linksys router is plugged into. Does it need to be routed through that port to a different subnet?
0
Comment
Question by:JesusFreak42
  • 5
  • 3
8 Comments
 
LVL 2

Expert Comment

by:byt3
ID: 37755631
What vlan is the port the Linksys E4200 plugged into and what vlan is the server 2008 r2?  

Are any other devices running a DHCP service on that same subnet?
0
 

Author Comment

by:JesusFreak42
ID: 37755639
What vlan is the port the Linksys E4200 plugged into and what vlan is the server 2008 r2?  
They are both on VLAN 200

Are any other devices running a DHCP service on that same subnet?
No.

The VLAN question might be the total wrong question, but I did read someplace that someone was having a similar issue. They had not solved it, but it seemed to have to do with the VLANS. The confusing thing to me is that the switch is not between the wireless clients and the router. I used to have DHCP running on the 2008 server, but because of this issue I moved it to the router. It didn't help. Does the wireless default to VLAN 1 or something?
0
 
LVL 2

Expert Comment

by:byt3
ID: 37755668
I just realized that since DHCP is on the router then the wireless clients should get IP addresses even if the router isn't on the correct VLAN.

If you'd rather have the DHCP on the 2008 R2 server (which I know I would prefer) then you can do the following:

1. Plug one of the LAN ports of the router into the Cisco switch

2. Configure that port as switchport access mode then set it to VLAN 200

3. Turn DHCP off on the router

4. Make sure the port that the Server is plugged into is also on VLAN 200 in switchport access mode (servers are capable of communicating on more than one VLAN, but you have to add a utility to do this. By default they don't)

5. Turn on and configure DHCP on the 2008 R2 server.
0
 

Author Comment

by:JesusFreak42
ID: 37755681
Just out of curiousity, I have never worked with Multicasting before. Would this affect anything?
0
Efficient way to get backups off site to Azure

This user guide provides instructions on how to deploy and configure both a StoneFly Scale Out NAS Enterprise Cloud Drive virtual machine and Veeam Cloud Connect in the Microsoft Azure Cloud.

 
LVL 2

Expert Comment

by:byt3
ID: 37755684
It could if your multicasting subnet is on a different VLAN.  Are you using multicasting for workstation imaging? Like a ghostcast server or M$ WDS?
0
 

Author Comment

by:JesusFreak42
ID: 37755701
Two things:
First, here is the config that I have on the switch (edited out some security settings)
Using keyboard-interactive authentication.
Password:

Prototype#sh run
Building configuration...

Current configuration : 5157 bytes
!
version 15.0
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname Prototype
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
clock timezone UTC -5 0
clock summer-time UTC recurring
system mtu routing 1500
ip routing
ip domain-name prototype
ip name-server 192.168.1.10
!
!
!
ip multicast-routing distributed
!
!

!
!
!
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
ip ssh version 2
!
!
!
!
!
!
interface GigabitEthernet0/1
 description Video 1
 switchport access vlan 200
!
interface GigabitEthernet0/2
 description Video 2
 switchport access vlan 200
!
interface GigabitEthernet0/3
 description Video 3
 switchport access vlan 200
!
interface GigabitEthernet0/4
 description Video 4
 switchport access vlan 200
!
interface GigabitEthernet0/5
 description Video 5
 switchport access vlan 200
!
interface GigabitEthernet0/6
 description Video 6
 switchport access vlan 200
!
interface GigabitEthernet0/7
 description Video 7
 switchport access vlan 200
!
interface GigabitEthernet0/8
 description Video 8
 switchport access vlan 200
!
interface GigabitEthernet0/9
 description Video 9
 switchport access vlan 200
!
interface GigabitEthernet0/10
 description Video 10
 switchport access vlan 200
!
interface GigabitEthernet0/11
 description Video 11
 switchport access vlan 200
!
interface GigabitEthernet0/12
 description Video 12
 switchport access vlan 200
!
interface GigabitEthernet0/13
 description Video 13
 switchport access vlan 200
!
interface GigabitEthernet0/14
 description Video 14
 switchport access vlan 200
!
interface GigabitEthernet0/15
 description Video 15
 switchport access vlan 200
!
interface GigabitEthernet0/16
 description Video 16
 switchport access vlan 200
!
interface GigabitEthernet0/17
 description Video 17
 switchport access vlan 200
!
interface GigabitEthernet0/18
 description Video 18
 switchport access vlan 200
!
interface GigabitEthernet0/19
 description Video 19
 switchport access vlan 200
!
interface GigabitEthernet0/20
 description Video 20
 switchport access vlan 200
!
interface GigabitEthernet0/21
 description Internet
 switchport access vlan 200
!
interface GigabitEthernet0/22
 description Computer 1
 switchport access vlan 200
!
interface GigabitEthernet0/23
 description Computer 2
 switchport access vlan 200
!
interface GigabitEthernet0/24
 description Computer 3
 switchport access vlan 200
!
interface GigabitEthernet0/25
 description Computer 4
 switchport access vlan 200
!
interface GigabitEthernet0/26
 description Computer 5
 switchport access vlan 200
!
interface GigabitEthernet0/27
 description Computer 6
 switchport access vlan 200
!
interface GigabitEthernet0/28
 description Computer 7
 switchport access vlan 200
!
interface Vlan1
 ip address 192.168.3.1 255.255.255.0
 ip pim sparse-dense-mode
!
interface Vlan200
 ip address 192.168.1.2 255.255.255.0
 ip pim sparse-dense-mode
!
ip default-gateway 192.168.1.1
ip http server
ip http authentication local
ip http secure-server
!
!
ip route 0.0.0.0 0.0.0.0 192.168.1.1
!
logging esm config
!
!
!

!
end

Open in new window

So as you can see, this is pretty simple. Everything is on one multicasting VLAN.

Second, the use of the switch is that we are streaming video over 20 of the ports, and then feeding the video into several workstations and servers also attached to the switch. One port is for the router.
0
 
LVL 2

Expert Comment

by:byt3
ID: 37755723
If your server has an address on the 192.168.1.x subnet and the wireless clients need to communicate with that server then both the server and your router must be on the same VLAN and my suggestion will work for you.
0
 
LVL 2

Accepted Solution

by:
byt3 earned 500 total points
ID: 37755734
If your server has a 192.168.3.x address and your wireless clients are supposed to be on that subnet too, then put both the server and the router on VLAN 1 instead of 200.

If your server has more than one IP address and is on different subnets, then I'd need more information about your setup.
0

Featured Post

Is Your Active Directory as Secure as You Think?

More than 75% of all records are compromised because of the loss or theft of a privileged credential. Experts have been exploring Active Directory infrastructure to identify key threats and establish best practices for keeping data safe. Attend this month’s webinar to learn more.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
SD - WAN 2 43
Cisco Firewall setup within a managed office 8 72
Shoretel Edge Gateway 5 43
NAS with google authentication 6 61
If your business is like most, chances are you still need to maintain a fax infrastructure for your staff. It’s hard to believe that a communication technology that was thriving in the mid-80s could still be an essential part of your team’s modern I…
David Varnum recently wrote up his impressions of PRTG, based on a presentation by my colleague Christian at Tech Field Day at VMworld in Barcelona. Thanks David, for your detailed and honest evaluation!
Here's a very brief overview of the methods PRTG Network Monitor (https://www.paessler.com/prtg) offers for monitoring bandwidth, to help you decide which methods you´d like to investigate in more detail.  The methods are covered in more detail in o…
In this tutorial you'll learn about bandwidth monitoring with flows and packet sniffing with our network monitoring solution PRTG Network Monitor (https://www.paessler.com/prtg). If you're interested in additional methods for monitoring bandwidt…

911 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

26 Experts available now in Live!

Get 1:1 Help Now