HELP!!! After migrating from WSS 3.0 to SharePoint Foundation 2010 users cannot upload like they once did.

Hi, I need more help with SharePoint.  I have no training and that is why.  I have stumbled around and thanks to the great gurus here I was able to migrate the content database from WSS 3.0 to SharePoint Foundation 2010.

However, all the sites are there and the Site Permissions in the home Site Settings includes everyone from the old WSS 3.0, I am receiving calls that some users can view but not upload content.  And others cannot view the content.

They receive an error:

File Not Found.
Correlation ID: c54213a2-0655-4327-a72c-727f9aebd053
Data & Time: 3/22/2012  2:00:37 PM


So, I guess I am wondering what all exactly is contained in the content database?  Permissions for each site in the database?

If so, why are these users not able to perform the same tasks as before (view, contribute, etc.)?

I have verified that they the same Permission Levels on the new SharePoint Foundation 2010 as they did in the WSS 3.0.

Not sure where to begin with the troubleshooting of this since I have no clue about SharePoint.


Thanks in advance.
rsnellmanIT ManagerAsked:
Who is Participating?
 
rsnellmanConnect With a Mentor IT ManagerAuthor Commented:
OK, I figured out the issue.  It had to do with AAM (Alternate Access Mapping).  I added the necessary URL's and made sure that my end users weren't using any old shortcuts to the SharePoint and now they are good to go.

Thanks to all.
0
 
Justin SmithSr. System EngineerCommented:
How did you do the upgrade to Foundation?  Database attach?

Yes, permissions are stored in the content database, along with the content.

Can you go into Central ADmin - Web App Management - Configure quotas and locks (under site collection admin) and verify the site isn't locked.
0
 
rsnellmanIT ManagerAuthor Commented:
I performed the migration as you directed.  I believe it was an attached by using the stsadm command line tool.


As for the Configure Quotas & Locks, the Site Lock Information: Not locked.
0
Creating Active Directory Users from a Text File

If your organization has a need to mass-create AD user accounts, watch this video to see how its done without the need for scripting or other unnecessary complexities.

 
rsnellmanIT ManagerAuthor Commented:
OK, I am getting a little more info from the end users.

One is trying to make changes to their Excel spreadsheet that resides on the SharePoint and says insufficient priviledges to make changes to it.

Another is having same issue but with a Word document that resides on the SharePoint.

Any other suggestions of what I might try?


Also, I had this thought, since the content database resides on a remote SQL server now, what ports does the SharePoint use in these situations other than port 80?  I am wondering if for some reason that the Server 2008 R2 Windows Firewall is blocking this in some way.  Just a thought.


Thanks.
0
 
rsnellmanIT ManagerAuthor Commented:
All files, sites are there, but when end users attempt to make changes to those existing files (docs, spreadsheets, etc.) they come up as Read-Only.  How do I change this?

I am about to just revert back to the old WSS 3.0 for now.

Arghhhh.
0
 
Justin SmithSr. System EngineerCommented:
What version of office are you guys using?
0
 
rsnellmanIT ManagerAuthor Commented:
Mostly, Office 2010 but may be some lingering Office 2007 out there.
0
 
Justin SmithSr. System EngineerCommented:
So, it's normal for the OFfice Docs to open in Read ONly mode.  There should be a tool bar right under the ribbon with a button to Edit.  If it's not there, you may look at http://support.microsoft.com/kb/2018958
0
 
rsnellmanIT ManagerAuthor Commented:
OK, my SharePoint Admin (who has no training with Sharepoint either) is able to grant permissions to sites if the users send requests notices to him through the SharePoint site that is denying them access.  However when he attempts to go through his account to the site, it denies him access to grant permissions to users to that site.

However, I have just found out that if he uses the IP as the URL he experiences these denials, but if he uses the server's name instead of the IP as the URL he seems to be able to do what he needs to do (upload documents, modify existing documents, grant permissions to sites, etc.)

Does this make any sense to you?
0
 
Justin SmithSr. System EngineerCommented:
No, none of this makes sense.  Ive not seen any of this during an upgrade.

When you created the web application in 2010, are you sure you used all the correct URL's/Alternate access mappings from the 2007 web app?
0
 
rsnellmanIT ManagerAuthor Commented:
Don't know what you mean?  Here is an overview of what I did to migrate from WSS 3.0 to SharePoint Foundation 2010.

- WSS 3.0 resides on Server 2003 R2 x32 with default database (SQL 2005 Express Edition)

- SharePoint Foundation 2010 resides on Server 2008 R2 with remote database (SQL 2005 x64 SP4)

- SQL 2005 x64 SP4 resides on Server 2008 R2.


I already had the WSS 3.0 built & running just fine (obvious) then built the SQL 2005 server running Server 2008 R2.  It hosts other databases and they all work fine.

Then I built a new seperate physical server running Server 2008 R2.  Installed the SharePoint Foundation 2010 and setup a Farm uses the remote SQL server as my database server.

Then I wasn't sure how to migrate over the SharePoint Configurations & IIS configurations, so I basically installed with mostly default settings and then brought both SharePoint Central Admin consoles side by side (dual monitor displays) and went through each section, part by part and compared, making changes where needed to be.

After that I performed the migration/upgrade of the current WSS 3.0 content database as directed by you.  Everything seemed to carrying over, sites, permissions (users & groups), shared documents, etc.  However, I don't use this or access it.  I only built the WSS 3.0 & then gave the reigns over to our SharePoint Admin who no longer is here.  So, our new webmaster/sharepoint admin has no clues about sharepoint or how to fix it.

I think that about covers the basics.
0
 
rsnellmanIT ManagerAuthor Commented:
Now, I have just had the SharePoint Admin try out all the functions he performed on the former WSS 3.0 server by uses the servername in the URL rather than the IP.

You see, since the WSS 3.0 was an experiment/testing phase to see if it would meet needs at our organization, we never put the effort into adding the name to our ISP DNS records, so we just told everyone to access it using the IP.

Also, when I migrated over from the WSS 3 server, I changed it to DHCP and then used the static IP it had for the new SharePoint Foundation server.  It seemed to work because people could get to it with the IP, but they don't have all the previous functions (uploading docs/files, etc.)

Now that we are going to a more permanent solution, I am planning on adding a GoDaddy SSL cert to the SharePoint once it is finalized in the migration process.  So, using the name or a name will be fine.


However, still doesn't make sense why that works and the IP doesn't.  It is more of a I need to know now so I can make sure it doesn't occur again.
0
 
rsnellmanIT ManagerAuthor Commented:
Say does Kerberos have anything to do with SharePoint?  If I recall, if Windows uses the IP rather than the machine name, Kerberos is not utilized.  Correct?


It seems to be working with the machine name and not the IP.  So, we have that resolved, but again, I am more curious of why that occured.

Thanks again.
0
 
Justin SmithSr. System EngineerCommented:
It's not going to use Kerberos for anything, unless told to do so.  You can use Kerberos for user authentication, but you have to specifiy that.
0
 
rsnellmanIT ManagerAuthor Commented:
With the old WSS 3.0 it was configured so users had to login (authenticate) before gaining access to anything with sharepoint, even the home page.  Because we only wanted to use sharepoint as an Intranet site for the time being.

I cannot recall how it was configured whether it was set to use kerberos or not.
0
 
dmogheCommented:
I would suggest  to check:
1.  if the issue is same on the server?
2. Have you tried with a new web application?
3. If it works, have you tried to export/ import the site from the non-working to the new web application and check the behavior?
4. What do you see in the ULS logs? Can you share the ULS logs with the co-relation id?
0
 
rsnellmanIT ManagerAuthor Commented:
This is the solution to this issue.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.