[Last Call] Learn about multicloud storage options and how to improve your company's cloud strategy. Register Now

x
?
Solved

Force Exchange 2007 to send from a specific IP

Posted on 2012-03-23
9
Medium Priority
?
966 Views
Last Modified: 2012-05-14
I have a single 2k8 R2 VPS with Exchange 2007.  The server has two public IPs assigned to it's NIC. One IP has an SSL cert and reverse DNS set up on it for the purpose of Exchange using it.  I thought things were going well until I discovered that it wasn't sending via that IP.

Is there a way I can configure Exchange to send using that IP?
0
Comment
Question by:David Williamson
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 5
  • 4
9 Comments
 
LVL 6

Expert Comment

by:KalluSureshKumar
ID: 37758036
Set-SendConnector but looks like it is used only on Edge servers. But you may try.

Set-SendConnector <Connector name>  -SourceIPAddress <IP Address>

SourceIPAddress: This parameter specifies the local IP address to use as the endpoint for an SMTP connection to a remote messaging server. The default IP address is 0.0.0.0. This value tells the server to use any available local IP address. This parameter is only valid for Send connectors that are configured on Edge Transport servers.

http://technet.microsoft.com/en-us/library/aa998294(v=exchg.80).aspx

Otherwise try changing the Network binding order.

http://theregime.wordpress.com/2008/03/04/how-to-setview-the-nic-bind-order-in-windows/
0
 
LVL 2

Author Comment

by:David Williamson
ID: 37758070
Thank you, I'll try that.  Do you think that setting this could disrupt my email functionality, and if so, how will I be able to undo it?  Is there a way I can see how the parameter is set before changing it?
0
 
LVL 2

Author Comment

by:David Williamson
ID: 37758133
I went ahead and set the parameter, but it appears to still be using the "other" public IP.  I'll try the binding order next.
0
Does Powershell have you tied up in knots?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

 
LVL 6

Accepted Solution

by:
KalluSureshKumar earned 2000 total points
ID: 37758146
By default IP address is set to 0.0.0.0 . You can also verify default setting by running

Get-Sendconnector <connector name> |fl

and verify what is set for SourceIPAddress.

To revert the settings you can run the same command

Set-SendConnector <connector name > -SourceIPAddress <Default value which you saw from the above command>

But above description clearly says "This parameter is only valid for Send connectors that are configured on Edge Transport servers."

So this is just a trial method on HUB if you dont have Edge.

Otherwise try changing the Binding
0
 
LVL 2

Author Comment

by:David Williamson
ID: 37758149
In looking up the binding link, it appears that that only applies to the NIC, not the IP assigned to the NIC.  Any other ideas?
0
 
LVL 6

Expert Comment

by:KalluSureshKumar
ID: 37758220
You said

I thought things were going well until I discovered that it wasn't sending via that IP.

Is the NIC card for which above statement is assigned on the TOP if yes. please move the other NIC on the top from which you would like to send e-mail from.
0
 
LVL 6

Expert Comment

by:KalluSureshKumar
ID: 37758255
Sorry my above statement is not clear..

I am talking about binding order. Is the NIC for which IP is assigned is on the TOP . If yes, then bring the one you wanted on the TOP and and send e-mail..

You may want to flushdns / restart transport service after you do that
0
 
LVL 2

Author Comment

by:David Williamson
ID: 37758262
There is only one NIC and both IPs are assigned to it.
0
 
LVL 2

Author Closing Comment

by:David Williamson
ID: 37967097
My configuration, being single server, is not eligible for setting the outgoing IP to be used.  If I had a two server config, looks like I could do that.
0

Featured Post

What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article lists the top 5 free OST to PST Converter Tools. These tools save a lot of time for users when they want to convert OST to PST after their exchange server is no longer available or some other critical issue with exchange server or impor…
I don't pretend to be an expert at this, but I have found a few things that are useful. I hope that sharing them here will help others, so they will not have to face some rather hard choices. Since I felt this to be a topic of enough importance and…
In this video we show how to create a Contact in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Recipients >> Contact ta…
In this video we show how to create an email address policy in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.:  First we need to log into the Exchange Admin Center. Navigate to the Mail Flow…

650 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question