Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 593
  • Last Modified:

Grant "admin" full mailbox access in Exchange 2003 Ent

I have a need to be able to open any mailbox in the Exchange server.

Of course by default the usual "admin" (administrator/domain admin) are explicity denied this right...

That said, I've change the rights so they're no longer "denied", and in fact now have full access in as much as security goes, but still, I cannot access other mailboxes.

Is there something else that needs to get changed, or reset to allow full access to the admin user(s)?

This was working in a previous install, so I know it can be done, but I can't seem to get past the access block in this new install.

I've changed the rights, I've also used ADSIEDIT to remove the DENY options, and still not cooperating...

I realize there's a reason for the default exclusion, but there has to be a reasonably simple answer for this...
0
btetlow-expert
Asked:
btetlow-expert
  • 8
  • 5
  • 2
  • +1
1 Solution
 
als315Commented:
0
 
btetlow-expertAuthor Commented:
Already did these changes --- results are the same.   Still denied access for some reason
0
 
btetlow-expertAuthor Commented:
If I am logged in as administrator, which is part of domain admin group also, or really any user that belongs to that group --- no access.

Using Outlook alone, OPEN OTHER USERS FOLDER, I get Cannot display the folder.  The inbox folder cannot be found.

If I attach the mailbox in question, I get Cannot display the folder.  Microsoft Office Outlook cannot access the specified folder location.  The operation failed. An object cannot be found.

Also has pop-up of "Cannot expand the folder"

This is the expected response when I am denied access to the users mailbox --- BUT --- all my rights are setup that should allow me in...
0
Microsoft Certification Exam 74-409

VeeamĀ® is happy to provide the Microsoft community with a study guide prepared by MVP and MCT, Orin Thomas. This guide will take you through each of the exam objectives, helping you to prepare for and pass the examination.

 
meko72Commented:
Here is a Microsoft KB that will help you

http://support.microsoft.com/kb/821897
0
 
als315Commented:
May be you have anywhere deny rule?
0
 
TAWpowerCommented:
We have an account with this need, too. Here are the group memberships for our account.

Administrators (Exchange Local)
Domain Users (Must not be a Domain Admin)
Exchange View-Only Administrators
View-Only Organizational Management

The "View-Only" groups can be set in System Manager (Exchange)

Let me know if that helps or if you need anything further.

TAW
0
 
meko72Commented:
In the Active Directory Users and Computer, when you select a user go into the "Exchange advanced" Tab then Click on Mailbox rights.
Is the Domain Administrator and Administrator listed in there for the following
"Full mailbox access: Allow
0
 
btetlow-expertAuthor Commented:
@meko72 - KB already reviewed...- mailbox full access already set to allow

@als375 - no deny on any of the designated users or groups...

@TAW -- On your groups, are you speaking of these at the AD level, or within Exchange?  Your reference is not clear to me other than the grouping itself.
0
 
btetlow-expertAuthor Commented:
@TAW -- are you referring to the delegation controls in the ESM?
0
 
TAWpowerCommented:
Been since 2008 since I was on 2003 but if I recall....

Go  to System Manager then...

Administrative group
First Admin Group>Servers>Servername
First Storage Group
Set the appropriate permissions on each store you need access to.

By the way, in case others search this topic... The reason you don't want to give these rights to domain admins is because they have Deny rights by default on the storage groups. While a subset of admins may need access, you do not want to give blanket access. Therefore, the best practice is to give a single user, specifically created for this task, access to all mail stores/mailboxes.

Also, on the local exchange server, add that same user to the local Administrators group.
0
 
btetlow-expertAuthor Commented:
I've actually done these steps here --- except for the last one of adding that user to the local admin group...

I suspect whoever previously had this server setup had to have allowed it to a much broader base than I would have....

I'll see if that additional change gets me to the end...

Thanks for the additional input.
0
 
TAWpowerCommented:
Looked this up in old notes - not sure where I got them, but the fact I kepty them means they worked.

When setting permissions make sure the following are selected:

Administer Information Store
Send As
Receive As

Click the Advanced button and ensure that the option Select the Allow inheritable permissions from parent to propagate to this object and all child objects is checked.

Click OK.

Repeat the above steps for each Exchange Server within the routing group that will be hosting mailboxes for BlackBerry device users who have accounts on a BlackBerry Enterprise Server.
0
 
btetlow-expertAuthor Commented:
Alas, this last part didn't solve my problem.

There must be something else in the mix that's getting in the way.
0
 
TAWpowerCommented:
I used the last comment, as it indicates, for giving the access permissions to our BES Admin... I used this to create another "All access" account though...
0
 
btetlow-expertAuthor Commented:
In my case, I've created a single all access user...  That user happens to also be domain admin...  I wonder if there's a rights conflict because of that?

There's defintely no "deny" left in any of the rights.... unless it's a hidden one.
0
 
TAWpowerCommented:
Yes, there is a conflict... Take that user out of domain admins then login as that user and try again.

Be sure you did the following too...

When setting permissions make sure the following are selected:

Administer Information Store
Send As
Receive As

Click the Advanced button and ensure that the option Select the Allow inheritable permissions from parent to propagate to this object and all child objects is checked.

Click OK.
0
 
btetlow-expertAuthor Commented:
Issue seems to be that the user I had been "using" was also part of domain admin.

When I created a specific user, and gave them the exact same rights, this user works.

Understanding that you want a mail server locked down as much as possible, this sure was quite a battle of wits in the logic of setting up for a specific user or even a group to have full rights....Sometimes, there's a reason it's needed....

Thanks for the help!
0

Featured Post

Free Tool: Site Down Detector

Helpful to verify reports of your own downtime, or to double check a downed website you are trying to access.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 8
  • 5
  • 2
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now