Solved

Mobile device users prompted for password when connecting to Exchange 2003 through 2010 CAS

Posted on 2012-03-23
7
1,211 Views
Last Modified: 2012-03-26
We are running in coexistence with Exchange 2010 and 2003.  I have set up the legacy namespace for OWA access and initially we were getting an "unspecified error" message when attempting to connect to OWA 2003 through our CAS array.  I found a TID that contained the fix, enabling forms based authentication on the 2003 OWA Exchange Virtual Server.  After enabling FBA we could connect to both 2010 and 2003 accounts through the CAS array using a web browser.  We also verified that our Exchange 2010 users with Android, iPhone and tablet devices could use their mail client with the external URL that we use for OWA set as their mail server (mail.xxxx.com).  However we found that our 2003 mailbox users got a pop-up window asking for their password, entering their network password did not work.  We tried recreating an iPhone user's mail profile and after entering her credentials she got a message that the server was unable to validate authentication.

I'm wondering if this is because we enabled FBA on the 2003 OWA server but I'm not sure how to resolve this.  We need our 2003 users to be able to access OWA through a web browser and still be able to use their mobile device mail clients.
0
Comment
Question by:Marc_Johnson
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
7 Comments
 
LVL 2

Expert Comment

by:AllanMartins
ID: 37758744
tried using their credentials with the full username path (domainname\username) ?
0
 
LVL 43

Expert Comment

by:Amit
ID: 37758763
You need to use form based authentication only once. Prefer is 2010
0
 
LVL 43

Assisted Solution

by:Amit
Amit earned 250 total points
ID: 37758799
Ignore my above post, that was for if we have exchange 2010 in multiple sites. For coexist, follow this kb

http://technet.microsoft.com/en-us/library/ee332348.aspx

Read all steps and apply it.
0
PeopleSoft Has Never Been Easier

PeopleSoft Adoption Made Smooth & Simple!

On-The-Job Training Is made Intuitive & Easy With WalkMe's On-Screen Guidance Tool.  Claim Your Free WalkMe Account Now

 
LVL 32

Accepted Solution

by:
endital1097 earned 250 total points
ID: 37760506
you need to ensure that you have Windows integrated authentication enabled on the Microsoft-Server-ActiveSync virtual directory on your 2003 backend server
this needs to be set thru Exchange System Manager

you may need to following hotfix to enable this
http://support.microsoft.com/kb/937031
0
 

Author Closing Comment

by:Marc_Johnson
ID: 37766881
That was exactly it, I did not have integrated Windows authentication enabled on the ActiveSync on the 2003 front end server.  Once I enabled this our 2003 users were able to connect to Exchange through their mobile devices.  I am accepting the solutions for both amitkulshrestha and  endital1097 because they both referenced the fix in their solutions.  

Much thanks to both of you for the solution!
0
 

Author Comment

by:Marc_Johnson
ID: 37766970
I also forgot to mention that I did apply the hotfix referred to in both solutions above before enabling Windows integrated authentication.  Note: if you are running Exchange 2003 in a clustered environment you need to stop the cluster service before applying the hotfix to the nodes in the cluster.
0
 
LVL 43

Expert Comment

by:Amit
ID: 37767359
Thanks for your valuable inputs.
0

Featured Post

Edgartown IT Case Study

Learn about Edgartown's quest to ensure the safety and security of the entire town's employee and citizen data. Read the case study!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Email is way too noisy, prone to hiding the important stuff, and really becoming unreliable for critical/timely communications. There are better ways to communicate.
This article will help to fix the below errors for MS Exchange Server 2013 I. Certificate error "name on the security certificate is invalid or does not match the name of the site" II. Out of Office not working III. Make Internal URLs and Externa…
In this video we show how to create an Accepted Domain in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Mail Flow >> Ac…
There are cases when e.g. an IT administrator wants to have full access and view into selected mailboxes on Exchange server, directly from his own email account in Outlook or Outlook Web Access. This proves useful when for example administrator want…

691 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question