Win 7 Task Scheduler doesn't complete task

Hi Experts,

I'm trying to create a simple task that will execute a batch file every 15min.  I did this by specifying under Actions, Open Program "D:\Scripts & BATs\Backup CSS_Res SQL.bat"

If i right-click and run the tasks, it hangs, but when I copy/paste "D:\Scripts & BATs\Backup CSS_Res SQL.bat" under run, it executes it under 1sec.

Furthermore, in hoping that the history tab would give me more details, but it is noted as (disabled)

Any feedback will be appreciated greatly.
APD TorontoAsked:
Who is Participating?
 
Run5kConnect With a Mentor Commented:
Open the the Task Scheduler interface with admin rights, and then double-click on the task to open the properties window.  In the Security Options section on the General tab, there is a field labeled "When running the task, use the following user account."  Click on the Change User button and in the field labeled Enter object name to select, type System and then utilize the Check Names button.
0
 
Run5kCommented:
First of all, keep in mind that task history is disabled by default.  You will need to toggle it on under the Actions section when you first open the Task Scheduler interface.

As for the problematic task itself, perhaps it's a privilege problem.  Have you tried configuring the task to run using the System account?
0
 
APD TorontoAuthor Commented:
Ok, i got the history enabled, but how do i run it under system?
0
 
burrcmConnect With a Mentor Commented:
If your batch file refers to a mapped drive by letter for any reason, scheduler won't work. You must specify a unc path, eg \\server\directory\file. It will run locally OK, but not scheduled.

Chris B
0
 
APD TorontoAuthor Commented:
The issue was that the batch file path contained spaces, when I removed them - it worked.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.