Freenas odd network loading

Hi all

I am having an odd issue with my Freenas server, It is setup as such:

Two network interfaces
 
EM0 - 192.168.0.8
EM1 - 192.168.0.9

I have an ESX box that connects to an iscsi target that ONLY runs on 192.168.0.8, it is disabled on 192.168.0.9.

I have samba setup on the box as well.

Now, I am copying files on a box to a samba share via 192.168.0.9.

Although looking at the interface graphs, It seems as though RX is being done by 192.168.0.9 and TX is being done by 192.168.0.8, I have attached the bandwidth graphs.

Bandwidth Graphs
LVL 1
alexanderfotiAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

arnoldCommented:
The issue is with the routing table where .8 is seen as the primary interface such that traffic arrives on .9 while when leaving the path is via em0
netstat -rn
Depending on your resources you could use bond to bind the two interfaces to appear as one.
If you are using sfw iptables firewall, you would need to setup rules that will tag the packets and thus maintain the path for the outgoing packet if binding the two interfaces is not an option.
0
alexanderfotiAuthor Commented:
Is there no way to tell the traffic to leave on the interface it came in on?
0
arnoldCommented:
You have to use iptables to mark, tag the packet to make sure it leaves on the interface on which it came.
Here is an example reference
http://www.linuxforums.org/forum/networking/21557-load-balancing-iptables-packet-tagging.html
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
alexanderfotiAuthor Commented:
Many thanks, I will give it a go and report back.
0
alexanderfotiAuthor Commented:
Thanks this resolved the issue.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux Networking

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.