Solved

Network issues after installing Netgear GS724TS Smart Stackable Switch

Posted on 2012-03-24
15
2,030 Views
Last Modified: 2012-08-13
We just upgraded part of our network to a Netgear GS724TS smart stackable gigabit switch. Now we're having all kinds of issues.

Our network set is as follows.
(1) Sonic Wall TZ180
(1) Comcast Cable router
(1) Motorola DSL Router
(1) Intellinet 24 Port 10/100 Mbps "dumb" Switch
(1) Netgear GS724TS 24 Port 10/100/1000 Mbps Switch

The Comcast connection is our primary, and DSL is our backup connection as controlled by the SonicWall. The SonicWalls LAN port is connected to the Netgear as is the Intellinet switch. Our file server is connected to the Netgear as well.

We had a Zonet 10/100 Mbps "dumb" switch where the Netgear is now and the network was flawless (a little slow, but flawless).

After installing the Netgear we're having the following issues:
- VoIP phones (snom 320, 300, 720) weren't getting the right date and time and taking forever to register
- Intermittently able to VNC into other LAN connected computers
- Network printing is VERY slow
- A PC connected to the 10/100 "dumb" switch is rediculously slow accessing anything on the network especially if it's on the Netgear side of the network. (printing, accessing files, Quickbooks, etc)

We turned off STP and that seemed to resolve the issues with the phones getting the wrong date and time. We're still having the other issues though.

We usually use HP ProCurves but decided to play with a Netgear, I'm beginning to regret it. Thoughts?

Thanks all,

Brian
0
Comment
Question by:bacamaro
15 Comments
 
LVL 1

Expert Comment

by:Burns1978
ID: 37761159
Hi there

Did you configurer any feature on this new switch?
Did you update the firmware?
Did you double check the cabling between being sur
there's no loop?

Tkx
0
 

Expert Comment

by:fresnotech
ID: 37761163
I've never used one of those unfortunately. I also use HP procurve most of the time. Apparently that switch has a lot of features just by looking on the website.

Try turning off as many features of the switch as possible and see what happens with network performance.

QoS
802.1x authentication
MAC filtering
Access Control Lists.

http://www.netgear.com/business/products/switches/stackable-smart-switches/gs724ts.aspx

Any particular reason why you went with a "smart" switch over a "dumb" switch?
0
 
LVL 10

Expert Comment

by:Netty
ID: 37762003
Also "turn off" a spanning tree protocol (STP) on end users ports.
0
 
LVL 5

Expert Comment

by:Yohei0815
ID: 37762467
Check for vlan settings at the switch. Furthermore there is a feature called syslog where systemevents can be logged. Install a free syslogserver in the net and redirect those switch messages to this server. Normally you can set a loglevel. Set it to the highest possible value and take some time analysing the output. It will give you some idea why some things are not working as expected. Take care to watch for running times between network dialogs to see who is waiting for whom. That way you will find the bottleneck much faster. Its better than just guesswork.
0
 

Author Comment

by:bacamaro
ID: 37766407
Did you configurer any feature on this new switch?
Did you update the firmware?
Did you double check the cabling between being sur
there's no loop?

We turned all of the features off on the switch we could.
It has the latest firmware edition.
The cabling in the office is mostly new, and we did check for loops - there are none.


QoS
802.1x authentication
MAC filtering
Access Control Lists.

http://www.netgear.com/business/products/switches/stackable-smart-switches/gs724ts.aspx

Any particular reason why you went with a "smart" switch over a "dumb" switch?

All of the features on the switch are disabled. We went with a smart switch because we wanted to configure a few VLAN's.

I ordered an HP ProCurve to replace this switch. We installed a 48 port version of this Netgear on a client's network a week ago and they're having similar issues. They have (2) 48 port HP ProCurves that were working great - once we added the Netgear, they've been having all kinds of issues. Thanks again everyone, I'll post an update when the HP comes in on Wednesday.
0
 
LVL 3

Expert Comment

by:Konsultant
ID: 37767380
On sonicwall hard code 100 full duplex on the LAN port. Sonicwalls have issues with port speeds that do not match the default speed. TZ180 has no GB port so this is most likely the case. Also, replace cable between sonicwall and the switch.

Just guessing here but the slow speed may be coming from the Ethernet errors, ergo port speed/duplex. So look at the speeds of the up-link ports as well.

I am not sure it you can configure any VLANs on your sonicwall TZ180 you need new model TZ100 and UP.

Good luck!
0
 

Author Comment

by:bacamaro
ID: 37771771
@Konsultant -
My understanding is that the switch should be smart enough to autosense and drop the port speed to 100mbps. Am I wrong?

We took the Netgear out of the mix yesterday and put the Zonet 10/100mbps dumb switch back in. The problems didn't go away. We shut everything in the office down and brought it all back up and the problem still existed. We then unplugged everything from the network until the problem went away. Then we started plugging things back in until it came back. As it turned out it was the SonicWall was causing the problem - we unplugged it and the problem went away, about 2 minutes after plugging it back in the problem came back. We tested this 3-4 times over an hour period of time and it was consistent. We wiped the configuration on the SonicWall and reconfigured it (same exact configuration by the way) and brought everything on the network back up. The problem was gone. Route Advertisement on the SonicWall was turned off so we're at a loss. Any thoughts?
0
Zoho SalesIQ

Hassle-free live chat software re-imagined for business growth. 2 users, always free.

 
LVL 3

Expert Comment

by:Konsultant
ID: 37771927
The fact that you had to reset the sonicwall is strange. I have never done it due to new switch installation. But it it helped...  I can not argue with the fact.

Can you tell me about the "Route Advertisement" ? You seem to have a pretty simple network with one internal router (sonicwall). So I want to know what else was advertised.

I am assuming your setup is like this:
X0 LAN (private IP address network)
X1 WAN Comcast (cable modem - public IP)
OPT WAN DSL (motorola modem - public IP)

Then on your LAN you have 2 switches Zonet connected to the sonicwall's LAN port (x0) and Netgear connected (up-linked) to one of the free ports on Zonet switch.

So what is there to advertise exactly?
0
 

Author Comment

by:bacamaro
ID: 37773022
@Konsultant
The connections on the SonicWall are as you stated above.

The Netgear replaced the Zonet so only the Netgear and the Intellinet switches were active on the network. X0 on the SonicWall was connected to the Netgear and the Intellinet was connected to the Netgear. There should be nothing to advertise - my point was there was no way that anything on the network should have been able to screw up any of the LAN routing on the SonicWall because the Route Advertisement was turned off.

I did forget to mention that we do have another 8 port dumb switch on the other side of the office that is connected to the Intellinet and we do have a Linksys WRT54GL (running DDWRT) that handles our wireless and VPN to our datacenter. Neither of those devices had anything to do with the problem though. Either way there was nothing on the network running any kind of route advertisement so I don't know what could have caused the SonicWall to go nuts.
network-diagram.pdf
0
 
LVL 3

Expert Comment

by:Konsultant
ID: 37773064
I am not sure what it was but here are some possibilities:
1. Corrupt settings on the sonicwall
2. The same IP address assigned to X0 and some workstation (maybe for testing)
3. bridged LAN to WAN ( I have seen people connecting LAN and WAN while installing new switch or making changes)
4. Broken NIC in one of the computers

Question is; was the sonicwall reset required or it was the coincidence that problem wend away after you refreshed settings on the sonicwall.

We know that sonicwall worked OK before you introduced the change. I do not think that sonicwall just decided to stop working, it was something introduced to the system.

It would be good to have WireShark running next time it happens...
0
 

Author Comment

by:bacamaro
ID: 37774021
We tested 4 times over the period of an hour. The symptom we used for testing was: our cash register computer took exactly 25 seconds to print to the receipt printer when the problem was occurring. The receipt printer is a EpsonTM-T88 parallel printer hooked up to a parallel print server. When everything is working it prints immediately.

This symptom happened like clockwork. VNC was intermittent and wasn't a reliable problem to test for but 25 second lag in printing happened every single time the problem occurred without fail. It took a minute or two to start happening but within 15 seconds of disconnecting the SonicWall from the network it start printing immediately again.

The cash register computer and print server were hooked up to the 8 port "dumb" switch. We put a hub between that switch and the 24 port Intellinet switch and hooked up a netbook with wireshark. We saw no change in the packets between when the SonicWall was connected and disconnected. We're at a complete loss as to what was causing it.

We're going to hook up the Netgear again tomorrow just for grins to see if it happens again. The HP will be in tomorrow so we're going to see if we can break the network again. At this point its more of a matter of determination to see what caused the problem. I'll update when we make the changes tomorrow.

Thanks for your continued assistance with this,
Brian
0
 
LVL 3

Accepted Solution

by:
Konsultant earned 500 total points
ID: 37774450
OK if you used wireshark, have you seen any re-transmissions?
Sonicwall will not show you any Errors on its ports (this is real preoblem)
Please take a look at the switch ports and see if there are any errors.
In my experience it is always a NIC on sonicwall or not which floods network with errors.

Also, try to determine max MTU for your network. Is should not matter on the LAN but at this point we have nothing to lose.

Bottom line; I think some ports need to manually configured to 100/FD. I would configure the LAN port on the sonicwall and all UP link ports on switches.

Please let me know the outcome of the test.

Good luck!!!
0
 

Author Comment

by:bacamaro
ID: 37807830
Sorry about the delay on the update. So we installed the Netgear again, and sure enough we started having issues with the phones - they were able to register but were not able to get the date and time. We weren't having issues with the printing again, but we were having just random issues on the network. Sometimes some of the computers couldn't access exchange, speed issues, etc.

I pulled the Netgear out and swapped it out for our new HP ProCurve and the network works like a champ. All of the phones work perfectly, all computers can access Exchange all of the time. It's been hooked up since last Friday and we have had 0 issues whatsoever.

I have no idea what the problem was , but getting rid of the Netgear fixed it.

Thanks everyone for your assistance, it was much appreciated.
0
 

Author Closing Comment

by:bacamaro
ID: 37807853
Never really came up with a "solution" but Konsultant stuck with it and was very helpful in ruling things out. Thank you very much for your continued assistance.
0
 
LVL 3

Expert Comment

by:Konsultant
ID: 37807881
I am glad to hear that you crawled your way out of this one.
Good luck!
0

Featured Post

Top 6 Sources for Identifying Threat Actor TTPs

Understanding your enemy is essential. These six sources will help you identify the most popular threat actor tactics, techniques, and procedures (TTPs).

Join & Write a Comment

I see many questions here on Experts Exchange regarding switch port configurations and trunks. This article is meant for beginners in the subject to help to get basic knowledge about Virtual Local Area Network (VLAN (http://en.wikipedia.org/wiki/Vir…
I eventually solved a perplexing problem setting up telnet for a new switch.  I installed a new Cisco WS-03560X-24P switch connected to an existing Cisco 4506 running a WS-X4013-10GE Sup II-Plus. After configuring vlans and trunking,  I could no…
When you create an app prototype with Adobe XD, you can insert system screens -- sharing or Control Center, for example -- with just a few clicks. This video shows you how. You can take the full course on Experts Exchange at http://bit.ly/XDcourse.
This video demonstrates how to create an example email signature rule for a department in a company using CodeTwo Exchange Rules. The signature will be inserted beneath users' latest emails in conversations and will be displayed in users' Sent Items…

705 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

21 Experts available now in Live!

Get 1:1 Help Now