Solved

Rode Podcaster not working in Windows 7

Posted on 2012-03-24
23
2,953 Views
Last Modified: 2012-04-06
I'm trying to use my Rode Podcaster (USB) microphone in Windows 7. However, when I record, instead of recording from the microphone, it records from the mic that's built in with the webcam. I tried changing the input device in Audacity, but to no avail. What can I do?
0
Comment
Question by:etech0
  • 14
  • 8
23 Comments
 
LVL 14

Expert Comment

by:JohnnyCanuck
ID: 37762684
In control panel under sound click the "recording" tab.  Is the USB mic listed?  If it is, see if you can set it as the default device.
0
 
LVL 10

Author Comment

by:etech0
ID: 37763071
I set it as the default device, but it still won't record.
0
 
LVL 10

Author Comment

by:etech0
ID: 37763121
In Sound Recorder, I get an error - "An audio recording device cannot be found".
In Audacity, it just records from the webcam's mic.
0
 
LVL 70

Expert Comment

by:Merete
ID: 37763574
I don't know if this is possible since you have a laptop with an onboard audio chip that shares it's resources with inbuilt speakers and mic.
Try this
in Audacity go to EDIT>Preferences>Audio/IO tab> on the far right >recording> device>
MME Microsoft Sound mapper input.
Remember to put it back later
In the playback>Windows direct sound:Digital Output
Then click on the input level microphone just above the red  recording dot a little to the left,
you should see one red and one green bar appear, now speak into your mic and and test if you see the levels in both bars moving
Audacity AudioYou won't have the stereo mix with a laptop that's another problem as well.
0
 
LVL 10

Author Comment

by:etech0
ID: 37763604
0
 
LVL 10

Author Comment

by:etech0
ID: 37763607
I don't have an Audio I/O tab. Do you mean this (above)? If so, what should I select where?
0
 
LVL 70

Expert Comment

by:Merete
ID: 37763623
You need the stereo mix looks like you may not have the stereo mix required because of the laptop onboard audio chip it is a half duplex not full duplex because the onboard mic and speakers so your sound resources is shared.
look in your recording tab r/click an empty space then properties tick to show hidden devices. This what you should see
stereomixIf you don't see it then your work around is total recorder

Open Audacity then go EDIT at the bottom Preferences
0
 
LVL 10

Author Comment

by:etech0
ID: 37763656
Which one am I looking for?
screenshot
0
 
LVL 10

Author Comment

by:etech0
ID: 37763658
Also, I didn't see "show hidden devices". I only saw "show disabled devices" and "show disconnected devices".
0
 
LVL 70

Expert Comment

by:Merete
ID: 37764346
yep that's fine>>I only saw "show disabled devices" and "show disconnected devices".
Sometimes I get the words wrong.

looks like you have all necessary tools,  especially the stereomix
please click on stereo mix and make default for recording,
 now you should see the Audio/IO tab in the preferences,
unplug any other devices and reboot, then plug in your Rode Podcaster and open Audacity click on the microphone this tests it mode now speak into your rode mic
check your recording in the sound card is showing levels.
Those are the settings I use refer to my snapshot as you can see, when I plug in my microphone all I do is test it in Audacity everything seems to work straight up
 
did you download the lame.dll so that audacity will use that?
How to install lame.dll
http://manual.audacityteam.org/help/manual/man/faq_installation_and_plug_ins.html#lame

Top Tutorials & Tips
Podcasting Overviews
0
 
LVL 10

Author Comment

by:etech0
ID: 37764350
I made Stereo mix the default, and I still don't see AudioI/O.
(I don't know if it matters, but I'm using version 2.0.0)
Are you also using Windows 7?
0
How to improve team productivity

Quip adds documents, spreadsheets, and tasklists to your Slack experience
- Elevate ideas to Quip docs
- Share Quip docs in Slack
- Get notified of changes to your docs
- Available on iOS/Android/Desktop/Web
- Online/Offline

 
LVL 70

Expert Comment

by:Merete
ID: 37764351
Yes I'm running version 1.3.7 Audacity/ on windows 7 professional 32 bit desktop
download the lame dll?
http://www.youtube.com/watch?v=qrGqxl1Y8zg
Audacity Manual Contents
http://manual.audacityteam.org/man/Main_Page

If your onboard sound card does not support multiple inputs the audio/io tab will not be visible. As I was saying above something about laptops have a shared resources  that's why you see this apparently
http://manual.audacityteam.org/man/Devices_Preferences
From wiki
Windows Vista / Windows 7
 The two drop-down list controls in this pane is where you configure which device Audacity should use for sound input and output. This basically means which sound card, USB sound device, etc you want to use. If your sound card support multiple sound inputs, e.g. has a microphone input and a line-in, then you select these on the mixer toolbar.
 No need to adjust this if Audacity is already playing to and recording from the correct place.

The most recent Windows operating systems Windows 7 treat individual recording sources such as line-in, microphone and "stereo mix" as recording devices in their own right.
As a result, the Mixer Toolbar input selector will be always be greyed out by default. <<<
Well I am on Windows 7 and it's clearly available,

Put every back to how it was default on the mic
I'll have to take another look at your setup
this is a laptop right?
Must just be a setting in audacity.
0
 
LVL 10

Author Comment

by:etech0
ID: 37765484
Yes, I have installed LAME. I don't know why that would help, though. I thought LAME is for mp3 support.

I think I've tried every combination of those two dropdown boxes. I can get Audacity to record from my webcam, but not from my Rode Podcaster USB mic.

Do you have a Rode Podcaster that you're testing with?

What do you mean by "Put every back to how it was default on the mic "?
0
 
LVL 70

Expert Comment

by:Merete
ID: 37769710
Hi etech0
In order to save the file in MP3 format you will need to have the LAME for Audacity.
No I don't have a USB podcaster but I do have lots of experience.
The reason I suggested make the Rode Podcaster default was how you had it originally.
Try making stereomix the default like I have it.

What brand is your Laptop? Del HP etc?
Maybe Audacity just can't find the USB source over your inbuilt audio devices until you disable them.
Laptops are no good for using recording because they usually share the resources for audio off the mainboard.
But things have advanced and from some of your screenshots in the recording windows panel you have a device listed for a pink slot? That indicates to me you should have a full duplex audio chip.
 but it's getting Audacity to see this usb mic.

Audacity needs to use your sound card to playback regardless.
so there is still things we haven't tried. Take your sound card
Real tek
Even though you have a Laptop you should still have a default audio chip onboard like a realtek.
In your screen cast you have set MS sound mapper –input as your default playback MS Sound mapper –out << change that to windows direct sound realtek digital output (realtek HD audio)
then
try testing each driver listed in Audacity line in the recording list ie source,
click on one then click on the line in mic icon >test and talk into your mic,
Looking at your screenshot
Windows sees your Headset Microphone, but it is disabled good
Mic in rear ( pink) not plugged in.<<shows me you have a good sound card
Microphone Realtek HD ready<< disable this one
and your USB podcast don't make it default just leave as is
You may have to make stereomix default instead.

stereomix is working I can see the bar has green audio level, the fact you have sound there now it's working so if you can't hear the plyback
 you have to change your playback driver in Audacity from the recording driver to playback.
Let me confuse you lol
When I record I have to put the output audio the one on the left of Audacity to Windows direct sound:Realtek Digital Output ( Realtek HD Audio)
And the input is on Windows DirectSound:Microphone (RealTek
To playback what I have just recorded in Audacity I change the driver to windows directSound:Speakers (realtek High definition Audio) then highlight the track recorded and
then test playback in audacity
So it is a juggling act with in Audacity between the recording and playback

In order to hear from the speakers sound in your laptop use the stereomix and  make that default in windows sounds>recording.
I don't change this ever
 when I plug in the mic windows detects it and Audacity sees it in the input device automatically.
And that is where you have a problem, is Audacity seeing your USB mic in the list of devices in input device.

So at this point check the stereomix is default in windows recording
Then plug in your USB mic
open Audacity
in Audacity change the input recording to Windows DirectSound: Microphone ( Realtek HD Audio)
and the Output audio to Windows DirectSound Output: Realtek High Def Audio.
click on the mic to test if you see a graph and hit record talk into your mic
press stop
to listen to what you just recorded highlight the recorded bit then up top with output device change it to Windows directSound:speakers (realtek High Def Audio
and press play
Audacity output settings
0
 
LVL 10

Author Comment

by:etech0
ID: 37774684
Okay, let's take this in order:

*I set the default recording device in Sound Settings to Stereo Mix

*I set the input device in Audacity to WIndows Direct Sound, and Realtek Digital Output

*I tried recording with the following input options:
***Primary Sound Capture Driver --> It recorded 'silence'
***Stereo Mix --> same
***Microphone (realtek high driver) --> it recorded from my webcam
***Microphone (2-Rode Podcaster) --> it gave me the same error as before

I disabled Microphone Realtek HD, and d recording with the following input options:
***Primary Sound Capture Driver --> It recorded 'silence'
***Stereo Mix --> same
***Microphone (realtek high driver) -->it gave me the same error as before
***Microphone (2-Rode Podcaster) --> it gave me the same error as before

"in Audacity change the input recording to Windows DirectSound: Microphone ( Realtek HD Audio)
and the Output audio to Windows DirectSound Output: Realtek High Def Audio.
click on the mic to test if you see a graph and hit record talk into your mic"
--> I tried this, and got the same error.

(It's a Lenovo laptop.
Headset Microphone is my bluetooth, which is not paired with the computer at this time.)

Any other ideas?
0
 
LVL 70

Expert Comment

by:Merete
ID: 37775222
What is the error etech0
Wish I had my old laptop :(
Is your pod cast mic Bluetooth?
Analog or digital.?


recapping yours
Okay, let's take this in order:

*I set the default recording device in Sound Settings to Stereo Mix<< correct that is in windows recording tab right? That is correct
Also check in>> windows playback devices what do you have set there? Speakers as default?
-------------------------------------------------------------------------------------------------------------

*I set the input device in Audacity to WIndows Direct Sound,<<incorrect>>  should be  your Podcast mic, input is the source.

* and Realtek Digital Output in Audacity<<correct during recording.
-------------------------------------------------------------------------------------------------------------------
***Microphone (realtek high driver) --> it recorded from my webcam<<< oh yeah that holds the key.  disable it..
------------------------------------------------------------------------------
***Microphone (2-Rode Podcaster) --> it gave me the same error as before<< which is?
DIS-ABLE all other recording devices for now bar the pod cast mic.

In the windows sounds recorder> 2-Rode Podcaster highlight it and properties>
click on listen> put a tick in the Listen to this device, any progress?
In levels
adjust the mic’s level from the Levels tab to suit your preferences.
As you move the slider the setting takes effect immediately, so you can monitor the mic input level in Record at the same time, helping you to fine-tune the setting in real time
In the default playback expand the arrow and put it on realtek speakers or digital out which ever works. or leave at default
In enhancements>disable all sound effects tick DC offset cancellation
and tick Acoustic Echo cancellation
Advanced
2channel 16 bit 44100Hz cd quality
exclusive mod
Allow applications to take exclusive control of this device
Give exclusive mode application priority

The internal web cam and mic is the problem here.
Check in windows recording devices that you are only recording from the USB microphone: i.e. disable all the other recording devices
Disable all these
0
 
LVL 10

Author Comment

by:etech0
ID: 37778457
Error: error
My Podcaster is, as I may have mentioned, a USB mic. (The bluetooth recording device that you saw in my sound settings is my bluetooth earpiece; not connected now, and not related to this issue)

The Podcaster is plugged in, and in the recording tab of sound settings, I see those green bars when I talk into it. But when I try to record in audacity, I get that error. This happens even when I disable all other recording devices in sound settings.
0
 
LVL 70

Accepted Solution

by:
Merete earned 500 total points
ID: 37779484
ok back to square one, re-enable the stereomix and the Rode Podcaster
Those green bars in the stereomix is live audio action in the pc speakers or what you hear,
then  Rode Podcaster properties enhancements
go back to the feature in Realtek saying "Acoustic Echo Cancellation" which reduces speaker volume during recording. Disabling this allows both the microphone and Stereo Mix to pick up sound regardless of what is set to default device.
realtek acoustic echo cancellation
0
 
LVL 10

Author Comment

by:etech0
ID: 37779542
I don't have Acoustic Echo Cancellation.
sound.PNG
0
 
LVL 10

Author Comment

by:etech0
ID: 37779553
One sec - am I supposed to be in "Microphone - realtek hd audio"
or in "Stereo Mix - Realtek hd audio"?
0
 
LVL 10

Author Closing Comment

by:etech0
ID: 37780047
WOW!!!!
That did it. A three month old issue is solved.
Thanks for all you help - you deserve WAY more than 500 points.
0
 
LVL 70

Expert Comment

by:Merete
ID: 37780342
COOL !!!!!!
( teary eyed)  I am so happy to hear it's resolved finally.
Imagining the big cheesy grin as you jump for joy.
It's a shared feeling
Have fun :)
0
 
LVL 10

Author Comment

by:etech0
ID: 37785099
I will...
Thanks for all your help!
0

Featured Post

How to run any project with ease

Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
- Combine task lists, docs, spreadsheets, and chat in one
- View and edit from mobile/offline
- Cut down on emails

Join & Write a Comment

The article will include the best Data Recovery Tools along with their Features, Capabilities, and their Download Links. Hope you’ll enjoy it and will choose the one as required by you.
In this article, you will read about the trends across the human resources departments for the upcoming year. Some of them include improving employee experience, adopting new technologies, using HR software to its full extent, and integrating artifi…
Viewers will learn how to use LFOs to modulate the sound of their Sampler instruments. Click the Modulation tab in Sampler: Choose one (or more) of the three available LFOs, and click the respective button to turn it on: Select a waveform, an LF…
XMind Plus helps organize all details/aspects of any project from large to small in an orderly and concise manner. If you are working on a complex project, use this micro tutorial to show you how to make a basic flow chart. The software is free when…

747 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

11 Experts available now in Live!

Get 1:1 Help Now