Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

InterVLAN routing with Cisco ASA 5510 + Can't access internet with either VLANS

Posted on 2012-03-24
8
Medium Priority
?
880 Views
Last Modified: 2012-03-30
I am trying to create a Voice VLAN to separate voice and data traffic using the ASA as the layer 3 bridge.  I can successfully ping across the VLAN's but neither VLAN can access the internet.  The ASA though can ping the internet successfully.

Any idea's based on my config?  Thanks in advance!

ali6265

ciscoasa# sh run
: Saved
:
ASA Version 7.0(6)
!
hostname ciscoasa
domain-name domain.com
enable password xxxxxxxx encrypted
names
dns-guard
!
interface Ethernet0/0
 nameif outside
 security-level 0
 ip address xxx.xxx.xxx.xxx 255.255.255.248
!
interface Ethernet0/1
 no nameif
 security-level 100
 no ip address
!
interface Ethernet0/1.1
 vlan 1
 nameif inside
 security-level 100
 ip address 192.1.1.149 255.255.255.0
!
interface Ethernet0/1.2
 vlan 2
 nameif voice
 security-level 100
 ip address 192.1.2.1 255.255.255.0
!
interface Ethernet0/2
 shutdown
 no nameif
 no security-level
 no ip address
!
interface Management0/0
 nameif management
 security-level 100
 ip address 192.168.1.1 255.255.255.0
 management-only
!
!
passwd xxxxxxxxxxx encrypted
ftp mode passive
clock timezone PST -8
clock summer-time PDT recurring
same-security-traffic permit inter-interface
same-security-traffic permit intra-interface
access-list outside_access_in extended permit tcp any host xxx.xxx.xxx.xxx eq https
access-list outside_access_in extended permit tcp any host xxx.xxx.xxx.xxx eq www
access-list outside_access_in extended permit icmp any any
access-list inside_nat0_outbound extended permit ip 192.1.1.0 255.255.255.0 192.168.100.0 255.255.255.0
access-list inside_nat0_outbound extended permit ip 192.1.1.0 255.255.255.0 10.10.10.0 255.255.255.0
access-list outside_cryptomap_20 extended permit ip 192.1.1.0 255.255.255.0 192.168.100.0 255.255.255.0
access-list inside_access extended permit ip any any
pager lines 24
logging enable
logging asdm informational
mtu outside 1500
mtu inside 1500
mtu voice 1500
mtu management 1500
ip local pool mypool 10.10.10.1-10.10.10.254
asdm image disk0:/asdm506.bin
no asdm history enable
arp timeout 14400
nat-control
global (outside) 10 interface
nat (inside) 0 access-list inside_nat0_outbound
nat (inside) 1 192.1.1.0 255.255.255.0
nat (voice) 1 192.1.2.0 255.255.255.0
static (inside,voice) 192.1.1.0 192.1.1.0 netmask 255.255.255.0
static (voice,inside) 192.1.2.0 192.1.2.0 netmask 255.255.255.0
static (inside,outside) xxx.xxx.xxx.xxx 192.1.1.1 netmask 255.255.255.255
access-group outside_access_in in interface outside
access-group inside_access in interface inside
route outside 192.168.100.0 255.255.255.0 xxx.xxx.xxx.xxx 1
route outside 0.0.0.0 0.0.0.0 xxx.xxx.xxx.xxx 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00
timeout mgcp-pat 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
group-policy xxxxxx internal
group-policy xxxxxx attributes
 wins-server value 192.1.1.1
 dns-server value 192.1.1.1
 webvpn
aaa authentication ssh console LOCAL
http server enable
http 0.0.0.0 0.0.0.0 outside
http 192.168.1.0 255.255.255.0 management
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
crypto dynamic-map dynmap 1 set transform-set ESP-3DES-MD5
crypto map outside_map 20 match address outside_cryptomap_20
crypto map outside_map 20 set peer xxx.xxx.xxx.xxx
crypto map outside_map 20 set transform-set ESP-3DES-MD5
crypto map outside_map 65535 ipsec-isakmp dynamic dynmap
crypto map outside_map interface outside
isakmp identity address
isakmp enable outside
isakmp policy 1 authentication pre-share
isakmp policy 1 encryption 3des
isakmp policy 1 hash sha
isakmp policy 1 group 2
isakmp policy 1 lifetime 86400
isakmp policy 10 authentication pre-share
isakmp policy 10 encryption 3des
isakmp policy 10 hash md5
isakmp policy 10 group 2
isakmp policy 10 lifetime 86400
isakmp nat-traversal  120
tunnel-group xxxxx type ipsec-ra
tunnel-group xxxxx general-attributes
 address-pool mypool
 default-group-policy xxxxxxx
tunnel-group xxxxxx ipsec-attributes
 pre-shared-key *
tunnel-group xxx.xxx.xxx.xxx type ipsec-l2l
tunnel-group xxx.xxx.xxx.xxx ipsec-attributes
 pre-shared-key *
telnet timeout 5
ssh 0.0.0.0 0.0.0.0 outside
ssh timeout 5
console timeout 0
management-access inside
dhcpd address 192.168.1.2-192.168.1.254 management
dhcpd dns xxx.xxx.xxx.xxx
dhcpd lease 3600
dhcpd ping_timeout 50
dhcpd enable management
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map global_policy
 class inspection_default
  inspect dns maximum-length 512
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect tftp
!
service-policy global_policy global
Cryptochecksum:1a19f962fdf1ba02bf255b96b5064f8c
: end

Open in new window

0
Comment
Question by:dstanton007
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 3
  • 2
8 Comments
 
LVL 17

Expert Comment

by:lruiz52
ID: 37762259
Could not see all your config but you may be missing the below entries;

Global (outside) 1 interface
Nat (inside) 1 0.0.0.0 0.0.0.0
Nat (voice) 1 0.0.0.0 0.0.0.0
0
 
LVL 17

Assisted Solution

by:Kvistofta
Kvistofta earned 1600 total points
ID: 37763303
Forget about the last 2 rows in Lruiz52:s suggestion. Your config is all right except that the "10" should be change to a "1" in your global-statement for outside.

Best regards
Kvistofta
0
 

Author Comment

by:dstanton007
ID: 37763524
What does the 10 or 1 signify in the Global statement?
0
Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

 
LVL 17

Accepted Solution

by:
lruiz52 earned 400 total points
ID: 37763808
Kvisto is right, you can disregard the last two lines in my first reply, just change;

global (outside) 10 interface
To
global (outside) 1 interface

For a brief explination check link below.

http://www.dasblinkenlichten.com/?p=224
0
 

Author Comment

by:dstanton007
ID: 37785414
Thanks guys,

Kvisto you were correct.  Iruiz, thanks for the explanation.
0
 
LVL 17

Expert Comment

by:Kvistofta
ID: 37785783
You are welcome.

The 10 or 1 or 237478234 is just a number. Which number you use doesn´t matter, as long as you use the same number in the nat and global-statements.

Best regards
Kvistofta
0
 

Author Comment

by:dstanton007
ID: 37788196
Hey guys,

Any idea why the Site to Site VPN no longer works?  I show that the tunnel is up, but I can't ping across.

Should I open a new question?
0
 
LVL 17

Expert Comment

by:Kvistofta
ID: 37788470
Open a new question and post your config there. But I bet a lot that it is nat-related, probably that you have no nat0-statements including your vpn-traffic.

/Kvistofta.
0

Featured Post

Enroll in September's Course of the Month

This month’s featured course covers 16 hours of training in installation, management, and deployment of VMware vSphere virtualization environments. It's free for Premium Members, Team Accounts, and Qualified Experts!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Use of TCL script on Cisco devices:  - create file and merge it with running configuration to apply configuration changes
Many of the companies I’ve worked with have embraced cloud solutions due to their desire to “get out of the datacenter business.” The ability to achieve better security and availability, and the speed with which they are able to deploy, is far grea…
Both in life and business – not all partnerships are created equal. As the demand for cloud services increases, so do the number of self-proclaimed cloud partners. Asking the right questions up front in the partnership, will enable both parties …
Both in life and business – not all partnerships are created equal. Spend 30 short minutes with us to learn:   • Key questions to ask when considering a partnership to accelerate your business into the cloud • Pitfalls and mistakes other partners…

715 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question