• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 331
  • Last Modified:

Exchnage 2010 Certificate Error in Outlook in local network

I have configured  exchangeserver 2010 with wild card ssl certificate in my network.Now I can send and receive emails without any issue

But I have the following issues

1. I am getting error while I create outlook account in local netwok like this  "the name of the security certificate is invalid or does not match the name of the site"

I found that it is trying to connect to ex1.domain.local its my local host name but I assigned the certificate to mail.domainname.com which is my external host name

how can I resolve this

2.When I try to access owa from local network using my external hostname https://mail.domain.com/owa I am getting a certificate error that it is not from a trusted authority and when i click continue that becomes in accessble
but It works fine from outside network ..there is no error


Please help me to resove this issue
0
Sudir LB
Asked:
Sudir LB
  • 4
  • 3
1 Solution
 
suriyaehnopCommented:
You are using self sign certificate. You can get certificate information by running Get-ExchangeCertificate to verify who is certificate issue. You need to get a SAN/UC public certificate e.g. Digicert
0
 
Sudir LBAuthor Commented:
Hello suriyaehnop,


I am using a Wildcard certificate from godaddy.I contacted them and they advised me to
purchase another standard ssl and configure it for IIS and keep current wildcard cert for exchange as it is .Do you think it will fix my problem?

My Internal and external domains are different

Please advise
0
 
suriyaehnopCommented:
0
Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

 
Sudir LBAuthor Commented:
Hi Thanks for your reply,


Do you think if I use a seperate standard ssl for iis will fix mu issue
0
 
suriyaehnopCommented:
I think the best solution is use normal SAN/UC certificate (Godaddy, Digicert and etc) to reduce complexity
0
 
Sudir LBAuthor Commented:
Yes Exactly,But is there will be any chance to fail if I move forward with an extra Standard SSL for IIS

Thanks for Supporting
0
 
suriyaehnopCommented:
It will better for other experts comments on IIS part since I have lack of experiance on this.
0
 
James HaywoodCommented:
There is a selection in the send connector to use external DNS. If you uncheck this it should remove the certificate error. That way you should not need to change the certificate
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Making Bulk Changes to Active Directory

Watch this video to see how easy it is to make mass changes to Active Directory from an external text file without using complicated scripts.

  • 4
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now